diff mbox series

Config.in: Introduce BR2_HOST_GCC_AT_LEAST_11

Message ID 20231103000650.195673-1-adam.duskett@amarulasolutions.com
State Accepted
Headers show
Series Config.in: Introduce BR2_HOST_GCC_AT_LEAST_11 | expand

Commit Message

Adam Duskett Nov. 3, 2023, 12:06 a.m. UTC
NodeJS 20 requires gcc >= 10.1. Unfortuantly, the only host gcc that has a
decimal place is 4.9, and every other HOST_GCC_AT_LEAST is an even release,
we round up to 11.

Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
---
 Config.in | 10 ++++++++++
 Makefile  |  2 +-
 2 files changed, 11 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Nov. 3, 2023, 8:16 p.m. UTC | #1
On Thu,  2 Nov 2023 18:06:49 -0600
Adam Duskett <adam.duskett@amarulasolutions.com> wrote:

> NodeJS 20 requires gcc >= 10.1. Unfortuantly, the only host gcc that has a
> decimal place is 4.9, and every other HOST_GCC_AT_LEAST is an even release,
> we round up to 11.
> 
> Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
> ---
>  Config.in | 10 ++++++++++
>  Makefile  |  2 +-
>  2 files changed, 11 insertions(+), 1 deletion(-)

Applied to master with an improved commit title and commit log. Thanks!

Thomas
diff mbox series

Patch

diff --git a/Config.in b/Config.in
index 556b6c2575..7dd49567f6 100644
--- a/Config.in
+++ b/Config.in
@@ -55,6 +55,16 @@  config BR2_HOST_GCC_AT_LEAST_9
 	default y if BR2_HOST_GCC_VERSION = "9"
 	select BR2_HOST_GCC_AT_LEAST_8
 
+config BR2_HOST_GCC_AT_LEAST_10
+	bool
+	default y if BR2_HOST_GCC_VERSION = "10"
+	select BR2_HOST_GCC_AT_LEAST_9
+
+config BR2_HOST_GCC_AT_LEAST_11
+	bool
+	default y if BR2_HOST_GCC_VERSION = "11"
+	select BR2_HOST_GCC_AT_LEAST_10
+
 # When adding new entries above, be sure to update
 # the HOSTCC_MAX_VERSION variable in the Makefile.
 
diff --git a/Makefile b/Makefile
index 3e85d5ef09..37deb35912 100644
--- a/Makefile
+++ b/Makefile
@@ -353,7 +353,7 @@  export HOSTARCH := $(shell LC_ALL=C $(HOSTCC_NOCCACHE) -v 2>&1 | \
 
 # When adding a new host gcc version in Config.in,
 # update the HOSTCC_MAX_VERSION variable:
-HOSTCC_MAX_VERSION := 9
+HOSTCC_MAX_VERSION := 11
 
 HOSTCC_VERSION := $(shell V=$$($(HOSTCC_NOCCACHE) --version | \
 	sed -n -r 's/^.* ([0-9]*)\.([0-9]*)\.([0-9]*)[ ]*.*/\1 \2/p'); \