diff mbox series

[v2,1/1] package/elfutils: enable on musl

Message ID 20231022154133.1619344-1-bernd@kuhls.net
State Accepted
Headers show
Series [v2,1/1] package/elfutils: enable on musl | expand

Commit Message

Bernd Kuhls Oct. 22, 2023, 3:41 p.m. UTC
Buildroot commit eb60820c0a9b3f938f32516f24df2eee9aac1e26 disabled
elfutils for musl toolchains in 2015. Current code builds fine with musl
so remove the exceptions.

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
v2: fix ELFUTILS_CONF_OPTS (Thomas)

 package/avrdude/Config.in    | 6 ++----
 package/bpftool/Config.in    | 4 +---
 package/elfutils/Config.in   | 9 +++------
 package/elfutils/elfutils.mk | 5 ++++-
 package/kexec-lite/Config.in | 6 ++----
 package/kmemd/Config.in      | 6 ++----
 package/libbpf/Config.in     | 6 ++----
 package/ltrace/Config.in     | 6 ++----
 package/mesa3d/Config.in     | 8 --------
 package/petitboot/Config.in  | 4 +---
 package/racehound/Config.in  | 6 ++----
 11 files changed, 21 insertions(+), 45 deletions(-)

Comments

Yann E. MORIN Oct. 22, 2023, 4:11 p.m. UTC | #1
Bernd, All,

On 2023-10-22 17:41 +0200, Bernd Kuhls spake thusly:
> Buildroot commit eb60820c0a9b3f938f32516f24df2eee9aac1e26 disabled
> elfutils for musl toolchains in 2015. Current code builds fine with musl
> so remove the exceptions.
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
[--SNIP--]
> diff --git a/package/elfutils/Config.in b/package/elfutils/Config.in
> index 5f45de14ab..c355048c6d 100644
> --- a/package/elfutils/Config.in
> +++ b/package/elfutils/Config.in
> @@ -1,17 +1,14 @@
> -comment "elfutils needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads"
> +comment "elfutils needs a toolchain w/ wchar, dynamic library, threads"
>  	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS \
> -		|| !BR2_TOOLCHAIN_HAS_THREADS \
> -		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
> +		|| !BR2_TOOLCHAIN_HAS_THREADS
>  
>  config BR2_PACKAGE_ELFUTILS
>  	bool "elfutils"
>  	depends on BR2_USE_WCHAR
>  	depends on !BR2_STATIC_LIBS
>  	depends on BR2_TOOLCHAIN_HAS_THREADS
> -	# Only glibc and uClibc implement the myriad of required GNUisms
> -	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC
>  	select BR2_PACKAGE_ZLIB
> -	select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
> +	select BR2_PACKAGE_ARGP_STANDALONE if !BR2_TOOLCHAIN_USES_GLIBC

I'm not a fan of this negative condition; I'd much prefer we use
positive logic. i.e. it is musl that needs argp-sa, so select it for
musl. uclibc needs it too, select it for uclibc.

But...

>  	select BR2_PACKAGE_MUSL_FTS if !BR2_TOOLCHAIN_USES_GLIBC

... this negativity is already what we use for fts, so meh, let's keep
it for arg-sa.

See below for a bit more...

>  	help
>  	  Libraries/utilities to handle ELF objects (drop in
> diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
> index 0757851b72..28fcb52eb3 100644
> --- a/package/elfutils/elfutils.mk
> +++ b/package/elfutils/elfutils.mk
> @@ -61,8 +61,11 @@ HOST_ELFUTILS_CONF_OPTS += --disable-libdebuginfod --disable-debuginfod
>  ELFUTILS_CONF_ENV += \
>  	LDFLAGS="$(ELFUTILS_LDFLAGS)"
>  
> -ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
> +ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),)

We already had a conditional block about !glibc, a bit above in the
file, so I moved all the libc-related conditions together.

Applied to master, thanks.

Regards,
Yann E. MORIN.
Yann E. MORIN Oct. 22, 2023, 4:36 p.m. UTC | #2
Bernd, All,

A little addition to the review, not directly related to your patch, see
below...

+Fabrice for commit 99ce85cdb80

On 2023-10-22 17:41 +0200, Bernd Kuhls spake thusly:
> Buildroot commit eb60820c0a9b3f938f32516f24df2eee9aac1e26 disabled
> elfutils for musl toolchains in 2015. Current code builds fine with musl
> so remove the exceptions.
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
[--SNIP--]
> diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
> index 0757851b72..28fcb52eb3 100644
> --- a/package/elfutils/elfutils.mk
> +++ b/package/elfutils/elfutils.mk

As I said in my review, we had a !glibc-related condiitional block; with
this change, it now looks like that:

   52 ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),)
   53 ELFUTILS_DEPENDENCIES += musl-fts argp-standalone
   54 ELFUTILS_LDFLAGS += -lfts
   55 endif

This means we link with fts for all of elfutils.

I was a bit surprised to see the explicit -lfts, but nothing for
argp-sa, and sure the build succeeded anyway.

However, from what I could see, libelf itself does not use fts, as it
does not use fts_open() or other fts-related symbols. So, libelf is
linked to libfts, and this is superfluous.

libdw does use it, though.

So I tried dropping the explicit -lfts from LDFLAGS, libdw is still
properly linked to fts, though (tested both with a uclibc and a musl
toolchain):

    $ readelf -a per-package/elfutils/target/usr/lib/libdw.so |grep fts
     0x00000001 (NEEDED)                     Shared library: [libfts.so.0]
    0007b94c  00003516 R_ARM_JUMP_SLOT   00000000   fts_close
    0007ba7c  00007916 R_ARM_JUMP_SLOT   00000000   fts_set
    0007baec  00009316 R_ARM_JUMP_SLOT   00000000   fts_read
    0007bb4c  0000a916 R_ARM_JUMP_SLOT   00000000   fts_open
        53: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_close
       121: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_set
       147: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_read
       169: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_open
      3629: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_close
      3812: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_set
      3868: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_read
      3929: 00000000     0 FUNC    GLOBAL DEFAULT  UND fts_open

Fabrice, in commit 99ce85cdb80, you added the explicit -lfts. Do you
remember the details (except for the autobuild failure)?

Bernd, could you check if upstream has changed something around the
handling of fts?

It would be nice if we could drop the explicit -lfts if it is no longer
needed.

Regards,
Yann E. MORIN.
Bernd Kuhls Oct. 22, 2023, 5:03 p.m. UTC | #3
Am Sun, 22 Oct 2023 18:36:59 +0200 schrieb Yann E. MORIN:

> Bernd, could you check if upstream has changed something around the
> handling of fts?

Hi Yann,

maybe this commit?
https://sourceware.org/git/?
p=elfutils.git;a=commitdiff;h=da855fc9cd415c288bfcb9de1f3d5eb329de0557

Regards, Bernd
Yann E. MORIN Oct. 22, 2023, 6:10 p.m. UTC | #4
Bernd, All,

On 2023-10-22 19:03 +0200, Bernd Kuhls spake thusly:
> Am Sun, 22 Oct 2023 18:36:59 +0200 schrieb Yann E. MORIN:
> > Bernd, could you check if upstream has changed something around the
> > handling of fts?
> maybe this commit?
> https://sourceware.org/git/?
> p=elfutils.git;a=commitdiff;h=da855fc9cd415c288bfcb9de1f3d5eb329de0557

It looks like it has all the keywords, yes. :-)

Will you send a patch to drop the explicit -lfts in Buildroot?

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/package/avrdude/Config.in b/package/avrdude/Config.in
index cbbd076667..06fee0ca7f 100644
--- a/package/avrdude/Config.in
+++ b/package/avrdude/Config.in
@@ -3,7 +3,6 @@  config BR2_PACKAGE_AVRDUDE
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_USE_WCHAR # elfutils
 	depends on !BR2_STATIC_LIBS # elfutils
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # libusb
 	select BR2_PACKAGE_ELFUTILS
 	select BR2_PACKAGE_LIBUSB
@@ -27,7 +26,6 @@  comment "SPI support needs a toolchain w/ linux headers >= 4.8"
 
 endif
 
-comment "avrdude needs a uClibc or glibc toolchain w/ threads, wchar, dynamic library, gcc >= 4.9"
+comment "avrdude needs a toolchain w/ threads, wchar, dynamic library, gcc >= 4.9"
 	depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR \
-		|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
diff --git a/package/bpftool/Config.in b/package/bpftool/Config.in
index d131ec566e..ef3a7a8a45 100644
--- a/package/bpftool/Config.in
+++ b/package/bpftool/Config.in
@@ -16,7 +16,6 @@  config BR2_PACKAGE_BPFTOOL
 	depends on BR2_USE_WCHAR # binutils, elfutils
 	depends on !BR2_STATIC_LIBS # elfutils
 	depends on BR2_TOOLCHAIN_HAS_THREADS # elfutils
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12
 	select BR2_PACKAGE_BINUTILS
 	select BR2_PACKAGE_ELFUTILS
@@ -24,11 +23,10 @@  config BR2_PACKAGE_BPFTOOL
 	  bpftool is a tool for for inspection and simple manipulation
 	  of eBPF programs and maps.
 
-comment "bpftool needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads, headers >= 4.12"
+comment "bpftool needs a toolchain w/ wchar, dynamic library, threads, headers >= 4.12"
 	depends on BR2_PACKAGE_BPFTOOL_ARCH_SUPPORTS
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4
 	depends on !BR2_nios2
 	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS \
 		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC) \
 		|| !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12
diff --git a/package/elfutils/Config.in b/package/elfutils/Config.in
index 5f45de14ab..c355048c6d 100644
--- a/package/elfutils/Config.in
+++ b/package/elfutils/Config.in
@@ -1,17 +1,14 @@ 
-comment "elfutils needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads"
+comment "elfutils needs a toolchain w/ wchar, dynamic library, threads"
 	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS \
-		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| !BR2_TOOLCHAIN_HAS_THREADS
 
 config BR2_PACKAGE_ELFUTILS
 	bool "elfutils"
 	depends on BR2_USE_WCHAR
 	depends on !BR2_STATIC_LIBS
 	depends on BR2_TOOLCHAIN_HAS_THREADS
-	# Only glibc and uClibc implement the myriad of required GNUisms
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_ZLIB
-	select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+	select BR2_PACKAGE_ARGP_STANDALONE if !BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_MUSL_FTS if !BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Libraries/utilities to handle ELF objects (drop in
diff --git a/package/elfutils/elfutils.mk b/package/elfutils/elfutils.mk
index 0757851b72..28fcb52eb3 100644
--- a/package/elfutils/elfutils.mk
+++ b/package/elfutils/elfutils.mk
@@ -61,8 +61,11 @@  HOST_ELFUTILS_CONF_OPTS += --disable-libdebuginfod --disable-debuginfod
 ELFUTILS_CONF_ENV += \
 	LDFLAGS="$(ELFUTILS_LDFLAGS)"
 
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),)
 ELFUTILS_DEPENDENCIES += argp-standalone
+endif
+
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 ELFUTILS_CONF_OPTS += --disable-symbol-versioning
 endif
 
diff --git a/package/kexec-lite/Config.in b/package/kexec-lite/Config.in
index abfa95ab36..5beaec6418 100644
--- a/package/kexec-lite/Config.in
+++ b/package/kexec-lite/Config.in
@@ -4,7 +4,6 @@  config BR2_PACKAGE_KEXEC_LITE
 	depends on !BR2_STATIC_LIBS # dtc, elfutils
 	depends on BR2_USE_WCHAR # elfutils
 	depends on BR2_TOOLCHAIN_HAS_THREADS # elfutils
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	select BR2_PACKAGE_ELFUTILS
 	select BR2_PACKAGE_DTC
 	select BR2_PACKAGE_DTC_PROGRAMS
@@ -18,8 +17,7 @@  config BR2_PACKAGE_KEXEC_LITE
 
 	  https://github.com/antonblanchard/kexec-lite
 
-comment "kexec-lite needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads"
+comment "kexec-lite needs a toolchain w/ wchar, dynamic library, threads"
 	depends on BR2_powerpc || BR2_powerpc64
 	depends on BR2_STATIC_LIBS || !BR2_USE_WCHAR \
-		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/kmemd/Config.in b/package/kmemd/Config.in
index cd92757508..b3aebf1224 100644
--- a/package/kmemd/Config.in
+++ b/package/kmemd/Config.in
@@ -5,16 +5,14 @@  config BR2_PACKAGE_KMEMD
 	depends on !BR2_STATIC_LIBS # libbpf
 	depends on BR2_TOOLCHAIN_HAS_THREADS # libbpf
 	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_14
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # libbpf
 	select BR2_PACKAGE_LIBBPF
 	help
 	  Explore a live Linux kernel's memory using GDB
 
 	  https://github.com/wkz/kmemd
 
-comment "kmemd needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads, headers >= 5.14"
+comment "kmemd needs a toolchain w/ wchar, dynamic library, threads, headers >= 5.14"
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4
 	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS \
 		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_13 \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_13
diff --git a/package/libbpf/Config.in b/package/libbpf/Config.in
index 1465366c9e..a78392cdc8 100644
--- a/package/libbpf/Config.in
+++ b/package/libbpf/Config.in
@@ -5,7 +5,6 @@  config BR2_PACKAGE_LIBBPF
 	depends on !BR2_STATIC_LIBS # elfutils
 	depends on BR2_TOOLCHAIN_HAS_THREADS # elfutils
 	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_13
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	select BR2_PACKAGE_ELFUTILS
 	select BR2_PACKAGE_ZLIB
 	help
@@ -16,9 +15,8 @@  config BR2_PACKAGE_LIBBPF
 
 	  https://github.com/libbpf/libbpf
 
-comment "libbpf needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads, headers >= 4.13"
+comment "libbpf needs a toolchain w/ wchar, dynamic library, threads, headers >= 4.13"
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4
 	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS \
 		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_13 \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_13
diff --git a/package/ltrace/Config.in b/package/ltrace/Config.in
index ce5a85edcf..21d381db70 100644
--- a/package/ltrace/Config.in
+++ b/package/ltrace/Config.in
@@ -15,7 +15,6 @@  config BR2_PACKAGE_LTRACE
 	depends on BR2_USE_WCHAR # elfutils
 	depends on !BR2_STATIC_LIBS # elfutils
 	depends on BR2_TOOLCHAIN_HAS_THREADS # elfutils
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	depends on BR2_PACKAGE_LTRACE_ARCH_SUPPORTS
 	select BR2_PACKAGE_ELFUTILS
 	help
@@ -26,8 +25,7 @@  config BR2_PACKAGE_LTRACE
 
 	  http://ltrace.org
 
-comment "ltrace needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads"
+comment "ltrace needs a toolchain w/ wchar, dynamic library, threads"
 	depends on BR2_PACKAGE_LTRACE_ARCH_SUPPORTS
 	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS \
-		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/mesa3d/Config.in b/package/mesa3d/Config.in
index 1e4a73a50f..ca7b9c8178 100644
--- a/package/mesa3d/Config.in
+++ b/package/mesa3d/Config.in
@@ -194,7 +194,6 @@  config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI
 	depends on BR2_USE_MMU # libdrm
 	depends on BR2_i386 || BR2_x86_64
 	depends on BR2_PACKAGE_MESA3D_LLVM
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
 	select BR2_PACKAGE_LIBDRM_AMDGPU
 	select BR2_PACKAGE_LIBDRM_RADEON
@@ -204,13 +203,6 @@  config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI
 	help
 	  Driver for ATI/AMD Radeon HD7000/HD8000/Rx200 GPUs.
 
-# Radeon SI needs libelf
-# musl is not currently compatible with elfutils
-comment "Radeon SI driver needs a uClibc or glibc toolchain"
-	depends on BR2_USE_MMU
-	depends on BR2_PACKAGE_MESA3D_LLVM
-	depends on !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
-
 config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA
 	bool "Gallium vmware svga driver"
 	depends on BR2_i386 || BR2_x86_64
diff --git a/package/petitboot/Config.in b/package/petitboot/Config.in
index 0b4dc762bb..3d3c798c25 100644
--- a/package/petitboot/Config.in
+++ b/package/petitboot/Config.in
@@ -6,7 +6,6 @@  config BR2_PACKAGE_PETITBOOT
 	depends on BR2_USE_WCHAR # elfutils
 	depends on !BR2_STATIC_LIBS # elfutils, lvm2
 	depends on BR2_TOOLCHAIN_HAS_THREADS # elfutils, lvm2
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	depends on BR2_PACKAGE_HAS_UDEV
 	select BR2_PACKAGE_ELFUTILS
 	select BR2_PACKAGE_LVM2 # devmapper
@@ -22,10 +21,9 @@  config BR2_PACKAGE_PETITBOOT
 
 	  http://www.kernel.org/pub/linux/kernel/people/geoff/petitboot/petitboot.html
 
-comment "petitboot needs a uClibc or glibc toolchain w/ wchar, dynamic library, threads, udev /dev management"
+comment "petitboot needs a toolchain w/ wchar, dynamic library, threads, udev /dev management"
 	depends on BR2_PACKAGE_KEXEC_ARCH_SUPPORTS
 	depends on BR2_USE_MMU
 	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS || \
 		BR2_TOOLCHAIN_HAS_THREADS || \
-		!(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC) || \
 		!BR2_PACKAGE_HAS_UDEV
diff --git a/package/racehound/Config.in b/package/racehound/Config.in
index d13f90adb4..5b8bdc77bc 100644
--- a/package/racehound/Config.in
+++ b/package/racehound/Config.in
@@ -5,7 +5,6 @@  config BR2_PACKAGE_RACEHOUND
 	depends on BR2_USE_WCHAR # elfutils
 	depends on !BR2_STATIC_LIBS # elfutils
 	depends on BR2_TOOLCHAIN_HAS_THREADS # elfutils
-	depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
 	# only x86/x86_64 supported
 	depends on BR2_i386 || BR2_x86_64
 	select BR2_PACKAGE_ELFUTILS
@@ -30,8 +29,7 @@  comment "racehound needs an Linux kernel >= 3.14 to be built"
 	depends on !BR2_LINUX_KERNEL
 	depends on BR2_i386 || BR2_x86_64
 
-comment "racehound needs a uClibc or glibc toolchain w/ C++, wchar, dynamic library, threads"
+comment "racehound needs a toolchain w/ C++, wchar, dynamic library, threads"
 	depends on BR2_i386 || BR2_x86_64
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || BR2_STATIC_LIBS \
-		|| !BR2_TOOLCHAIN_HAS_THREADS \
-		|| !(BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC)
+		|| !BR2_TOOLCHAIN_HAS_THREADS