diff mbox series

package/gcc: remoce leftover from legacy PowerPC patch

Message ID 20231014203645.866867-1-yann.morin.1998@free.fr
State Accepted
Headers show
Series package/gcc: remoce leftover from legacy PowerPC patch | expand

Commit Message

Yann E. MORIN Oct. 14, 2023, 8:36 p.m. UTC
In commit 0c82f3f63563 (package/gcc: remove powerpc conditional patching
logic), the macro defining the conditional patch was removed, but it was
still referenced and expanded in the apply-patches hook.

Drop that now.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Romain Naour <romain.naour@gmail.com>
---
 package/gcc/gcc.mk | 1 -
 1 file changed, 1 deletion(-)

Comments

Peter Korsgaard Oct. 15, 2023, 8:49 a.m. UTC | #1
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > In commit 0c82f3f63563 (package/gcc: remove powerpc conditional patching
 > logic), the macro defining the conditional patch was removed, but it was
 > still referenced and expanded in the apply-patches hook.

 > Drop that now.

 > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
 > Cc: Romain Naour <romain.naour@gmail.com>

Committed, thanks.
Peter Korsgaard Oct. 15, 2023, 6:21 p.m. UTC | #2
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > In commit 0c82f3f63563 (package/gcc: remove powerpc conditional patching
 > logic), the macro defining the conditional patch was removed, but it was
 > still referenced and expanded in the apply-patches hook.

 > Drop that now.

 > Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
 > Cc: Romain Naour <romain.naour@gmail.com>

Committed to 2023.02.x and 2023.08.x, thanks.
diff mbox series

Patch

diff --git a/package/gcc/gcc.mk b/package/gcc/gcc.mk
index 4a3b780618..9a164c8374 100644
--- a/package/gcc/gcc.mk
+++ b/package/gcc/gcc.mk
@@ -44,7 +44,6 @@  define HOST_GCC_APPLY_PATCHES
 			$(APPLY_PATCHES) $(@D) $${patchdir} \*.patch || exit 1; \
 		fi; \
 	done
-	$(HOST_GCC_APPLY_POWERPC_PATCH)
 endef
 
 HOST_GCC_EXCLUDES = \