diff mbox series

[RFC,1/3] package/rpi-firmware: bump version for pi5 support

Message ID 20231013180145.162565-2-gael.portay@rtone.fr
State Superseded
Headers show
Series Add support for Pi5 | expand

Commit Message

Gaël PORTAY Oct. 13, 2023, 6:01 p.m. UTC
This bumps to 7e9c2063fc15274fbc4dab1ca614f9228834d881[1] that states
"Add support for PI 5", and it updates the comments of Pi4 variants for
Pi5.

Note: That commit bumps the kernel files (images, modules, device-trees
and device-tree overlays) but it does not bump the bootloader files for
VC (start.elf, fixup.dat). This bump appears to not be really needed to
bring the support for the Pi 5; it assumes the Pi5's VC7 uses the exact
same files as the Pi4's VC6 (i.e. start4.elf, fixup4.dat, and cd, x and
debug variants) at least for now.

[1]: https://github.com/raspberrypi/firmware/commit/7e9c2063fc15274fbc4dab1ca614f9228834d881

Signed-off-by: Gaël PORTAY <gael.portay@rtone.fr>
---
 package/rpi-firmware/Config.in         | 22 +++++++++++-----------
 package/rpi-firmware/rpi-firmware.hash |  2 +-
 package/rpi-firmware/rpi-firmware.mk   |  2 +-
 3 files changed, 13 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/package/rpi-firmware/Config.in b/package/rpi-firmware/Config.in
index a9aeaed745..90ad35fd3c 100644
--- a/package/rpi-firmware/Config.in
+++ b/package/rpi-firmware/Config.in
@@ -14,9 +14,9 @@  if BR2_PACKAGE_RPI_FIRMWARE
 config BR2_PACKAGE_RPI_FIRMWARE_BOOTCODE_BIN
 	bool "rpi 0/1/2/3 bootcode.bin"
 	help
-	  The bootcode.bin for versions Zero/1/2/3 (not needed on rpi4,
-	  because it has been replaced by boot code in the onboard
-	  EEPROM).
+	  The bootcode.bin for versions Zero/1/2/3 (not needed on
+	  rpi4/5, because it has been replaced by boot code in the
+	  onboard EEPROM).
 
 config BR2_PACKAGE_RPI_FIRMWARE_VARIANT_PI
 	bool "rpi 0/1/2/3 (default)"
@@ -41,27 +41,27 @@  config BR2_PACKAGE_RPI_FIRMWARE_VARIANT_PI_DB
 	  The debug set of files for versions Zero/1/2/3.
 
 config BR2_PACKAGE_RPI_FIRMWARE_VARIANT_PI4
-	bool "rpi 4 (default)"
+	bool "rpi 4/5 (default)"
 	help
-	  The default set of files for versions 4 (standard GPU
+	  The default set of files for versions 4/5 (standard GPU
 	  features).
 
 config BR2_PACKAGE_RPI_FIRMWARE_VARIANT_PI4_X
-	bool "rpi 4 (extended)"
+	bool "rpi 4/5 (extended)"
 	help
-	  The extended set of files for versions 4 (additional GPU
+	  The extended set of files for versions 4/5 (additional GPU
 	  features, eg. more audio/video codecs).
 
 config BR2_PACKAGE_RPI_FIRMWARE_VARIANT_PI4_CD
-	bool "rpi 4 (cut-down)"
+	bool "rpi 4/5 (cut-down)"
 	help
-	  The cut-down set of files for versions 4 (only features
+	  The cut-down set of files for versions 4/5 (only features
 	  required to boot a Linux kernel).
 
 config BR2_PACKAGE_RPI_FIRMWARE_VARIANT_PI4_DB
-	bool "rpi 4 (debug)"
+	bool "rpi 4/5 (debug)"
 	help
-	  The debug set of files for versions 4.
+	  The debug set of files for versions 4/5.
 
 config BR2_PACKAGE_RPI_FIRMWARE_CONFIG_FILE
 	string "Path to a file stored as boot/config.txt"
diff --git a/package/rpi-firmware/rpi-firmware.hash b/package/rpi-firmware/rpi-firmware.hash
index ec13115f3b..659613591d 100644
--- a/package/rpi-firmware/rpi-firmware.hash
+++ b/package/rpi-firmware/rpi-firmware.hash
@@ -1,3 +1,3 @@ 
 # Locally computed
-sha256  33aea2cb9c3be94c3dd6a96fbb3443eee5af1dc5fc9140e1fadc50832983064e  rpi-firmware-3f20b832b27cd730deb6419b570f31a98167eef6.tar.gz
+sha256  f3442fb80966faf1e28a32f9d9b91acb4b87c6ff33f0ced4179ec6ccbfa92c65  rpi-firmware-7e9c2063fc15274fbc4dab1ca614f9228834d881.tar.gz
 sha256  c7283ff51f863d93a275c66e3b4cb08021a5dd4d8c1e7acc47d872fbe52d3d6b  boot/LICENCE.broadcom
diff --git a/package/rpi-firmware/rpi-firmware.mk b/package/rpi-firmware/rpi-firmware.mk
index 53d6d8ca06..e765d0ea82 100644
--- a/package/rpi-firmware/rpi-firmware.mk
+++ b/package/rpi-firmware/rpi-firmware.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-RPI_FIRMWARE_VERSION = 3f20b832b27cd730deb6419b570f31a98167eef6
+RPI_FIRMWARE_VERSION = 7e9c2063fc15274fbc4dab1ca614f9228834d881
 RPI_FIRMWARE_SITE = $(call github,raspberrypi,firmware,$(RPI_FIRMWARE_VERSION))
 RPI_FIRMWARE_LICENSE = BSD-3-Clause
 RPI_FIRMWARE_LICENSE_FILES = boot/LICENCE.broadcom