diff mbox series

[1/2] package/firewalld: enable missing kernel config options

Message ID 20231011092250.3739529-1-adam.duskett@amarulasolutions.com
State Accepted
Headers show
Series [1/2] package/firewalld: enable missing kernel config options | expand

Commit Message

Adam Duskett Oct. 11, 2023, 9:22 a.m. UTC
Firewalld requires IPV6 to function. We also should enable the
other dependencies such as networking support to ensure all other
options in the giant list of kernel config options are selected
properly.

Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
---
 package/firewalld/firewalld.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Nov. 4, 2023, 2:23 p.m. UTC | #1
On Wed, 11 Oct 2023 11:22:49 +0200
Adam Duskett <adam.duskett@amarulasolutions.com> wrote:

> Firewalld requires IPV6 to function. We also should enable the
> other dependencies such as networking support to ensure all other
> options in the giant list of kernel config options are selected
> properly.
> 
> Signed-off-by: Adam Duskett <adam.duskett@amarulasolutions.com>
> ---
>  package/firewalld/firewalld.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/firewalld/firewalld.mk b/package/firewalld/firewalld.mk
index 188550d449..23ba1e6c2a 100644
--- a/package/firewalld/firewalld.mk
+++ b/package/firewalld/firewalld.mk
@@ -72,9 +72,16 @@  define FIREWALLD_INSTALL_INIT_SYSV
 		$(TARGET_DIR)/etc/init.d/S46firewalld
 endef
 
+# Firewalld needs ipv6
 # Firewalld requires almost every single nftable option selected.
 define FIREWALLD_LINUX_CONFIG_FIXUPS
 	$(call KCONFIG_ENABLE_OPT,CONFIG_BRIDGE)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_INET)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_INET_DIAG)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_NET)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_ADVANCED)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_IPV6)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_IP6_NF_FILTER)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_IP6_NF_IPTABLES)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_IP6_NF_MANGLE)