diff mbox series

[1/1] package/libebml: bump to version 1.4.4

Message ID 20231008212643.67946-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libebml: bump to version 1.4.4 | expand

Commit Message

Fabrice Fontaine Oct. 8, 2023, 9:26 p.m. UTC
- Drop patch (already in version)
- C++14 is required since
  https://github.com/Matroska-Org/libebml/commit/4159caf84c18f64137e6cdb5f15c5e76d0bb0976

https://github.com/Matroska-Org/libebml/blob/release-1.4.4/NEWS.md

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .checkpackageignore                           |  1 -
 ...-header-files-for-std-numeric_limits.patch | 40 -------------------
 package/libebml/Config.in                     |  6 ++-
 package/libebml/libebml.hash                  |  2 +-
 package/libebml/libebml.mk                    |  2 +-
 package/libmatroska/Config.in                 |  6 ++-
 6 files changed, 10 insertions(+), 47 deletions(-)
 delete mode 100644 package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch

Comments

Arnout Vandecappelle Oct. 10, 2023, 8:52 p.m. UTC | #1
On 08/10/2023 23:26, Fabrice Fontaine wrote:
> - Drop patch (already in version)
> - C++14 is required since
>    https://github.com/Matroska-Org/libebml/commit/4159caf84c18f64137e6cdb5f15c5e76d0bb0976
> 
> https://github.com/Matroska-Org/libebml/blob/release-1.4.4/NEWS.md
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   .checkpackageignore                           |  1 -
>   ...-header-files-for-std-numeric_limits.patch | 40 -------------------
>   package/libebml/Config.in                     |  6 ++-
>   package/libebml/libebml.hash                  |  2 +-
>   package/libebml/libebml.mk                    |  2 +-
>   package/libmatroska/Config.in                 |  6 ++-
>   6 files changed, 10 insertions(+), 47 deletions(-)
>   delete mode 100644 package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch
> 
> diff --git a/.checkpackageignore b/.checkpackageignore
> index 0e8e5921ce..21a1009a1b 100644
> --- a/.checkpackageignore
> +++ b/.checkpackageignore
> @@ -650,7 +650,6 @@ package/libdnet/0001-python-makefile.patch Upstream
>   package/libdrm/0001-tests-meson.build-disable-nouveau-tests-for-static-b.patch Upstream
>   package/libdvbcsa/0001-altivec-powerpc64.patch Upstream
>   package/libeXosip2/0001-src-eXtl_dtls.c-fix-build-with-libressl-3.4.1.patch Upstream
> -package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch Upstream
>   package/libedit/0001-check-bsd-functions-in-libbsd.patch Upstream
>   package/libevent/0001-Don-t-define-BIO_get_init-for-LibreSSL-3-5.patch Upstream
>   package/libfcgi/0001-link-against-math.patch Upstream
> diff --git a/package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch b/package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch
> deleted file mode 100644
> index c7e789c02e..0000000000
> --- a/package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch
> +++ /dev/null
> @@ -1,40 +0,0 @@
> -From f0bfd53647961e799a43d918c46cf3b6bff89806 Mon Sep 17 00:00:00 2001
> -From: Moritz Bunkus <mo@bunkus.online>
> -Date: Sat, 27 Feb 2021 20:36:52 +0100
> -Subject: [PATCH] include appropriate header files for std::numeric_limits
> -
> -Fixes #80.
> -
> -[Retrieved (and updated to remove ChangeLog update) from:
> -https://github.com/Matroska-Org/libebml/commit/f0bfd53647961e799a43d918c46cf3b6bff89806]
> -Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ----
> - ChangeLog                 | 4 ++++
> - src/EbmlString.cpp        | 1 +
> - src/EbmlUnicodeString.cpp | 1 +
> - 3 files changed, 6 insertions(+)
> -
> -diff --git a/src/EbmlString.cpp b/src/EbmlString.cpp
> -index 27e55fd..4c05fcf 100644
> ---- a/src/EbmlString.cpp
> -+++ b/src/EbmlString.cpp
> -@@ -34,6 +34,7 @@
> -   \author Steve Lhomme     <robux4 @ users.sf.net>
> - */
> - #include <cassert>
> -+#include <limits>
> -
> - #include "ebml/EbmlString.h"
> -
> -diff --git a/src/EbmlUnicodeString.cpp b/src/EbmlUnicodeString.cpp
> -index 496a16a..99fc073 100644
> ---- a/src/EbmlUnicodeString.cpp
> -+++ b/src/EbmlUnicodeString.cpp
> -@@ -36,6 +36,7 @@
> - */
> -
> - #include <cassert>
> -+#include <limits>
> -
> - #include "ebml/EbmlUnicodeString.h"
> -
> diff --git a/package/libebml/Config.in b/package/libebml/Config.in
> index a00b894358..b770154af7 100644
> --- a/package/libebml/Config.in
> +++ b/package/libebml/Config.in
> @@ -2,11 +2,13 @@ config BR2_PACKAGE_LIBEBML
>   	bool "libebml"
>   	depends on BR2_INSTALL_LIBSTDCPP
>   	depends on BR2_USE_WCHAR
> +	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
>   	help
>   	  Access library for the EBML (Extensible Binary Meta
>   	  Language, a binary derivative of XML) format.
>   
>   	  http://matroska.org
>   
> -comment "libebml needs a toolchain w/ C++, wchar"
> -	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
> +comment "libebml needs a toolchain w/ C++, wchar, gcc >= 4.9"
> +	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
> +		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
> diff --git a/package/libebml/libebml.hash b/package/libebml/libebml.hash
> index 32ca1e3dd3..c83fde32ab 100644
> --- a/package/libebml/libebml.hash
> +++ b/package/libebml/libebml.hash
> @@ -1,3 +1,3 @@
>   # Locally calculated
> -sha256  41c7237ce05828fb220f62086018b080af4db4bb142f31bec0022c925889b9f2  libebml-1.4.2.tar.xz
> +sha256  82dc5f83356cc9340aee76ed7512210b3a4edf5f346bc9c2c7044f55052687a7  libebml-1.4.4.tar.xz
>   sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  LICENSE.LGPL
> diff --git a/package/libebml/libebml.mk b/package/libebml/libebml.mk
> index 056cf888e1..c85638c03e 100644
> --- a/package/libebml/libebml.mk
> +++ b/package/libebml/libebml.mk
> @@ -4,7 +4,7 @@
>   #
>   ################################################################################
>   
> -LIBEBML_VERSION = 1.4.2
> +LIBEBML_VERSION = 1.4.4
>   LIBEBML_SOURCE = libebml-$(LIBEBML_VERSION).tar.xz
>   LIBEBML_SITE = http://dl.matroska.org/downloads/libebml
>   LIBEBML_INSTALL_STAGING = YES
> diff --git a/package/libmatroska/Config.in b/package/libmatroska/Config.in
> index ec0e8415d7..b2e4354df5 100644
> --- a/package/libmatroska/Config.in
> +++ b/package/libmatroska/Config.in
> @@ -2,6 +2,7 @@ config BR2_PACKAGE_LIBMATROSKA
>   	bool "libmatroska"
>   	depends on BR2_INSTALL_LIBSTDCPP
>   	depends on BR2_USE_WCHAR
> +	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # libebml
>   	select BR2_PACKAGE_LIBEBML
>   	help
>   	  Extensible open standard audio/video container format access
> @@ -9,5 +10,6 @@ config BR2_PACKAGE_LIBMATROSKA
>   
>   	  http://matroska.org
>   
> -comment "libmatroska needs a toolchain w/ C++, wchar"
> -	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
> +comment "libmatroska needs a toolchain w/ C++, wchar, gcc >= 4.9"
> +	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
> +		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
diff mbox series

Patch

diff --git a/.checkpackageignore b/.checkpackageignore
index 0e8e5921ce..21a1009a1b 100644
--- a/.checkpackageignore
+++ b/.checkpackageignore
@@ -650,7 +650,6 @@  package/libdnet/0001-python-makefile.patch Upstream
 package/libdrm/0001-tests-meson.build-disable-nouveau-tests-for-static-b.patch Upstream
 package/libdvbcsa/0001-altivec-powerpc64.patch Upstream
 package/libeXosip2/0001-src-eXtl_dtls.c-fix-build-with-libressl-3.4.1.patch Upstream
-package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch Upstream
 package/libedit/0001-check-bsd-functions-in-libbsd.patch Upstream
 package/libevent/0001-Don-t-define-BIO_get_init-for-LibreSSL-3-5.patch Upstream
 package/libfcgi/0001-link-against-math.patch Upstream
diff --git a/package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch b/package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch
deleted file mode 100644
index c7e789c02e..0000000000
--- a/package/libebml/0001-include-appropriate-header-files-for-std-numeric_limits.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From f0bfd53647961e799a43d918c46cf3b6bff89806 Mon Sep 17 00:00:00 2001
-From: Moritz Bunkus <mo@bunkus.online>
-Date: Sat, 27 Feb 2021 20:36:52 +0100
-Subject: [PATCH] include appropriate header files for std::numeric_limits
-
-Fixes #80.
-
-[Retrieved (and updated to remove ChangeLog update) from:
-https://github.com/Matroska-Org/libebml/commit/f0bfd53647961e799a43d918c46cf3b6bff89806]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- ChangeLog                 | 4 ++++
- src/EbmlString.cpp        | 1 +
- src/EbmlUnicodeString.cpp | 1 +
- 3 files changed, 6 insertions(+)
-
-diff --git a/src/EbmlString.cpp b/src/EbmlString.cpp
-index 27e55fd..4c05fcf 100644
---- a/src/EbmlString.cpp
-+++ b/src/EbmlString.cpp
-@@ -34,6 +34,7 @@
-   \author Steve Lhomme     <robux4 @ users.sf.net>
- */
- #include <cassert>
-+#include <limits>
- 
- #include "ebml/EbmlString.h"
- 
-diff --git a/src/EbmlUnicodeString.cpp b/src/EbmlUnicodeString.cpp
-index 496a16a..99fc073 100644
---- a/src/EbmlUnicodeString.cpp
-+++ b/src/EbmlUnicodeString.cpp
-@@ -36,6 +36,7 @@
- */
- 
- #include <cassert>
-+#include <limits>
- 
- #include "ebml/EbmlUnicodeString.h"
- 
diff --git a/package/libebml/Config.in b/package/libebml/Config.in
index a00b894358..b770154af7 100644
--- a/package/libebml/Config.in
+++ b/package/libebml/Config.in
@@ -2,11 +2,13 @@  config BR2_PACKAGE_LIBEBML
 	bool "libebml"
 	depends on BR2_INSTALL_LIBSTDCPP
 	depends on BR2_USE_WCHAR
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
 	help
 	  Access library for the EBML (Extensible Binary Meta
 	  Language, a binary derivative of XML) format.
 
 	  http://matroska.org
 
-comment "libebml needs a toolchain w/ C++, wchar"
-	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
+comment "libebml needs a toolchain w/ C++, wchar, gcc >= 4.9"
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
diff --git a/package/libebml/libebml.hash b/package/libebml/libebml.hash
index 32ca1e3dd3..c83fde32ab 100644
--- a/package/libebml/libebml.hash
+++ b/package/libebml/libebml.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  41c7237ce05828fb220f62086018b080af4db4bb142f31bec0022c925889b9f2  libebml-1.4.2.tar.xz
+sha256  82dc5f83356cc9340aee76ed7512210b3a4edf5f346bc9c2c7044f55052687a7  libebml-1.4.4.tar.xz
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  LICENSE.LGPL
diff --git a/package/libebml/libebml.mk b/package/libebml/libebml.mk
index 056cf888e1..c85638c03e 100644
--- a/package/libebml/libebml.mk
+++ b/package/libebml/libebml.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LIBEBML_VERSION = 1.4.2
+LIBEBML_VERSION = 1.4.4
 LIBEBML_SOURCE = libebml-$(LIBEBML_VERSION).tar.xz
 LIBEBML_SITE = http://dl.matroska.org/downloads/libebml
 LIBEBML_INSTALL_STAGING = YES
diff --git a/package/libmatroska/Config.in b/package/libmatroska/Config.in
index ec0e8415d7..b2e4354df5 100644
--- a/package/libmatroska/Config.in
+++ b/package/libmatroska/Config.in
@@ -2,6 +2,7 @@  config BR2_PACKAGE_LIBMATROSKA
 	bool "libmatroska"
 	depends on BR2_INSTALL_LIBSTDCPP
 	depends on BR2_USE_WCHAR
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # libebml
 	select BR2_PACKAGE_LIBEBML
 	help
 	  Extensible open standard audio/video container format access
@@ -9,5 +10,6 @@  config BR2_PACKAGE_LIBMATROSKA
 
 	  http://matroska.org
 
-comment "libmatroska needs a toolchain w/ C++, wchar"
-	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR
+comment "libmatroska needs a toolchain w/ C++, wchar, gcc >= 4.9"
+	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9