diff mbox series

package/iproute2: bump to version 6.5.0

Message ID 20230929172732.3214611-1-francois.perrad@gadz.org
State Accepted
Headers show
Series package/iproute2: bump to version 6.5.0 | expand

Commit Message

Francois Perrad Sept. 29, 2023, 5:27 p.m. UTC
remove upstream patches

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 .../0001-tc-add-missing-separator.patch       |  32 -----
 .../0002-tc-f_u32-fix-json-object-leak.patch  | 134 ------------------
 package/iproute2/iproute2.hash                |   2 +-
 package/iproute2/iproute2.mk                  |   2 +-
 4 files changed, 2 insertions(+), 168 deletions(-)
 delete mode 100644 package/iproute2/0001-tc-add-missing-separator.patch
 delete mode 100644 package/iproute2/0002-tc-f_u32-fix-json-object-leak.patch

Comments

Peter Korsgaard Sept. 29, 2023, 8:02 p.m. UTC | #1
>>>>> "Francois" == Francois Perrad <fperrad@gmail.com> writes:

 > remove upstream patches
 > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/iproute2/0001-tc-add-missing-separator.patch b/package/iproute2/0001-tc-add-missing-separator.patch
deleted file mode 100644
index 534b2c8f6..000000000
--- a/package/iproute2/0001-tc-add-missing-separator.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 4e0e56e0ef05387f7f5d8ab41fe6ec6a1897b26d Mon Sep 17 00:00:00 2001
-From: Christian Hesse <mail@eworm.de>
-Date: Thu, 23 Feb 2023 11:15:03 +0100
-Subject: [PATCH] tc: add missing separator
-Upstream: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=4e0e56e0ef05387f7f5d8ab41fe6ec6a1897b26d
-
-This is missing a separator, that was accidently removed
-when JSON was added.
-
-Fixes: 010a8388aea1 ("tc: Add JSON output to tc-class")
-Signed-off-by: Christian Hesse <mail@eworm.de>
-Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
----
- tc/tc_class.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tc/tc_class.c b/tc/tc_class.c
-index c1feb009..096fa2ec 100644
---- a/tc/tc_class.c
-+++ b/tc/tc_class.c
-@@ -356,7 +356,7 @@ int print_class(struct nlmsghdr *n, void *arg)
- 		print_string(PRINT_ANY, "parent", "parent %s ", abuf);
- 	}
- 	if (t->tcm_info)
--		print_0xhex(PRINT_ANY, "leaf", "leaf %x", t->tcm_info>>16);
-+		print_0xhex(PRINT_ANY, "leaf", "leaf %x: ", t->tcm_info>>16);
- 
- 	q = get_qdisc_kind(RTA_DATA(tb[TCA_KIND]));
- 	if (tb[TCA_OPTIONS]) {
--- 
-2.40.0
-
diff --git a/package/iproute2/0002-tc-f_u32-fix-json-object-leak.patch b/package/iproute2/0002-tc-f_u32-fix-json-object-leak.patch
deleted file mode 100644
index 3d90fee56..000000000
--- a/package/iproute2/0002-tc-f_u32-fix-json-object-leak.patch
+++ /dev/null
@@ -1,134 +0,0 @@ 
-From 6637a6d512a940c3d9c101f4eaca3c1c7a36517c Mon Sep 17 00:00:00 2001
-From: Hangbin Liu <liuhangbin@gmail.com>
-Date: Tue, 28 Feb 2023 15:31:46 +0800
-Subject: [PATCH] tc: f_u32: fix json object leak
-Upstream: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=6637a6d512a940c3d9c101f4eaca3c1c7a36517c
-
-Previously, the code returned directly within the switch statement in
-the functions print_{ipv4, ipv6}. While this approach was functional,
-after the commit 721435dc, we can no longer return directly because we
-need to close the match object. To resolve this issue, replace the return
-statement with break.
-
-Fixes: 721435dcfd92 ("tc: u32: add json support in `print_raw`, `print_ipv4`, `print_ipv6`")
-Signed-off-by: Hangbin Liu <liuhangbin@gmail.com>
-Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
----
- tc/f_u32.c | 24 ++++++++++--------------
- 1 file changed, 10 insertions(+), 14 deletions(-)
-
-diff --git a/tc/f_u32.c b/tc/f_u32.c
-index de2d0c9e..936dbd65 100644
---- a/tc/f_u32.c
-+++ b/tc/f_u32.c
-@@ -828,12 +828,12 @@ static void print_ipv4(FILE *f, const struct tc_u32_key *key)
- 			print_nl();
- 			print_uint(PRINT_ANY, "ip_ihl", "  match IP ihl %u",
- 				   ntohl(key->val) >> 24);
--			return;
-+			break;
- 		case 0x00ff0000:
- 			print_nl();
- 			print_0xhex(PRINT_ANY, "ip_dsfield", "  match IP dsfield %#x",
- 				    ntohl(key->val) >> 16);
--			return;
-+			break;
- 		}
- 		break;
- 	case 8:
-@@ -841,7 +841,6 @@ static void print_ipv4(FILE *f, const struct tc_u32_key *key)
- 			print_nl();
- 			print_int(PRINT_ANY, "ip_protocol", "  match IP protocol %d",
- 				  ntohl(key->val) >> 16);
--			return;
- 		}
- 		break;
- 	case 12:
-@@ -864,7 +863,6 @@ static void print_ipv4(FILE *f, const struct tc_u32_key *key)
- 				print_string(PRINT_ANY, "address", "%s", addr);
- 				print_int(PRINT_ANY, "prefixlen", "/%d", bits);
- 				close_json_object();
--				return;
- 			}
- 		}
- 		break;
-@@ -874,19 +872,19 @@ static void print_ipv4(FILE *f, const struct tc_u32_key *key)
- 		case 0x0000ffff:
- 			print_uint(PRINT_ANY, "dport", "match dport %u",
- 				   ntohl(key->val) & 0xffff);
--			return;
-+			break;
- 		case 0xffff0000:
- 			print_nl();
- 			print_uint(PRINT_ANY, "sport", "  match sport %u",
- 				   ntohl(key->val) >> 16);
--			return;
-+			break;
- 		case 0xffffffff:
- 			print_nl();
- 			print_uint(PRINT_ANY, "dport", "  match dport %u, ",
- 				   ntohl(key->val) & 0xffff);
- 			print_uint(PRINT_ANY, "sport", "match sport %u",
- 				   ntohl(key->val) >> 16);
--			return;
-+			break;
- 		}
- 		/* XXX: Default print_raw */
- 	}
-@@ -905,12 +903,12 @@ static void print_ipv6(FILE *f, const struct tc_u32_key *key)
- 			print_nl();
- 			print_uint(PRINT_ANY, "ip_ihl", "  match IP ihl %u",
- 				   ntohl(key->val) >> 24);
--			return;
-+			break;
- 		case 0x00ff0000:
- 			print_nl();
- 			print_0xhex(PRINT_ANY, "ip_dsfield", "  match IP dsfield %#x",
- 				    ntohl(key->val) >> 16);
--			return;
-+			break;
- 		}
- 		break;
- 	case 8:
-@@ -918,7 +916,6 @@ static void print_ipv6(FILE *f, const struct tc_u32_key *key)
- 			print_nl();
- 			print_int(PRINT_ANY, "ip_protocol", "  match IP protocol %d",
- 				  ntohl(key->val) >> 16);
--			return;
- 		}
- 		break;
- 	case 12:
-@@ -941,7 +938,6 @@ static void print_ipv6(FILE *f, const struct tc_u32_key *key)
- 				print_string(PRINT_ANY, "address", "%s", addr);
- 				print_int(PRINT_ANY, "prefixlen", "/%d", bits);
- 				close_json_object();
--				return;
- 			}
- 		}
- 		break;
-@@ -952,11 +948,11 @@ static void print_ipv6(FILE *f, const struct tc_u32_key *key)
- 			print_nl();
- 			print_uint(PRINT_ANY, "sport", "  match sport %u",
- 				   ntohl(key->val) & 0xffff);
--			return;
-+			break;
- 		case 0xffff0000:
- 			print_uint(PRINT_ANY, "dport", "match dport %u",
- 				   ntohl(key->val) >> 16);
--			return;
-+			break;
- 		case 0xffffffff:
- 			print_nl();
- 			print_uint(PRINT_ANY, "sport", "  match sport %u, ",
-@@ -964,7 +960,7 @@ static void print_ipv6(FILE *f, const struct tc_u32_key *key)
- 			print_uint(PRINT_ANY, "dport", "match dport %u",
- 				   ntohl(key->val) >> 16);
- 
--			return;
-+			break;
- 		}
- 		/* XXX: Default print_raw */
- 	}
--- 
-2.40.0
-
diff --git a/package/iproute2/iproute2.hash b/package/iproute2/iproute2.hash
index d1ab93618..edd03b645 100644
--- a/package/iproute2/iproute2.hash
+++ b/package/iproute2/iproute2.hash
@@ -1,3 +1,3 @@ 
 # From https://kernel.org/pub/linux/utils/net/iproute2/sha256sums.asc
-sha256  4d72730200ec5b2aabaa1a2f20553c6748292f065d9a154c7d5e22559df9fd62  iproute2-6.2.0.tar.xz
+sha256  a70179085fa1b96d3c33b040c809b75e2b57563adc505a4ad05e2609df373463  iproute2-6.5.0.tar.xz
 sha256  e6d6a009505e345fe949e1310334fcb0747f28dae2856759de102ab66b722cb4  COPYING
diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index 49a65516d..a2e90a66f 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-IPROUTE2_VERSION = 6.2.0
+IPROUTE2_VERSION = 6.5.0
 IPROUTE2_SOURCE = iproute2-$(IPROUTE2_VERSION).tar.xz
 IPROUTE2_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/net/iproute2
 IPROUTE2_DEPENDENCIES = host-bison host-flex host-pkgconf \