diff mbox series

[v2] package/luajit: bump to version 41fb94defa8f830ce69a8122b03f6ac3216d392a

Message ID 20230912185706.2605439-1-francois.perrad@gadz.org
State Accepted
Headers show
Series [v2] package/luajit: bump to version 41fb94defa8f830ce69a8122b03f6ac3216d392a | expand

Commit Message

Francois Perrad Sept. 12, 2023, 6:57 p.m. UTC
The LuaJIT project switches to a rolling release scheme.
Now, the version contains the timestamp of its latest commit.

The timestamp can be seen in build log:
==== Successfully installed LuaJIT 2.1.1693350652 to /usr ====

Comments

Thomas Petazzoni Sept. 14, 2023, 8:25 p.m. UTC | #1
On Tue, 12 Sep 2023 20:57:06 +0200
Francois Perrad <fperrad@gmail.com> wrote:


> +# emulation of git archive with .gitattributes & export-subst
> +# Timestamp of the $(LUAJIT_VERSION) commit, obtained in the LuaJit
> +# repo, with:   git show -s --format=%ct $(LUAJIT_VERSION)
> +define LUAJIT_ROLLING_VERSION

We normally name our hooks after an action, with a verb, so I renamed
to LUAJIT_GEN_RELVER_FILE, and applied to master. Thanks!

Thomas
Yann E. MORIN Sept. 15, 2023, 8:11 p.m. UTC | #2
François, All,

+Thomas

On 2023-09-12 20:57 +0200, Francois Perrad spake thusly:
> The LuaJIT project switches to a rolling release scheme.
> Now, the version contains the timestamp of its latest commit.
> 
> The timestamp can be seen in build log:
> ==== Successfully installed LuaJIT 2.1.1693350652 to /usr ====
[--SNIP--]
> diff --git a/package/luajit/luajit.mk b/package/luajit/luajit.mk
> index 2a27aa505..07cb6e015 100644
> --- a/package/luajit/luajit.mk
> +++ b/package/luajit/luajit.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -LUAJIT_VERSION = 8635cbabf3094c4d8bd00578c7d812bea87bb2d3
> +LUAJIT_VERSION = 41fb94defa8f830ce69a8122b03f6ac3216d392a
>  LUAJIT_SITE = $(call github,LuaJIT,LuaJIT,$(LUAJIT_VERSION))

In your v1, you were using the git method to do the download, but this
v2 no longer does.

We are using the github-generated archive, and that applies the
export-subst replacements on the github side, so the .relver file has
been replaced in the archive served by github. Then, see below...

[--SNIP--]
> +# emulation of git archive with .gitattributes & export-subst
> +# Timestamp of the $(LUAJIT_VERSION) commit, obtained in the LuaJit
> +# repo, with:   git show -s --format=%ct $(LUAJIT_VERSION)
> +define LUAJIT_ROLLING_VERSION
> +	echo 1693350652 >$(@D)/.relver
> +endef
> +LUAJIT_POST_EXTRACT_HOOKS = LUAJIT_ROLLING_VERSION
> +HOST_LUAJIT_POST_EXTRACT_HOOKS = LUAJIT_ROLLING_VERSION

As I explained my review of your v1, the placeholder to be replaced in
the commiter UNIX time, so this is reproducible, because this does not
suffer from local settings (no timezone, no leap second...).

So, we don't need these hooks when we use the github tarball...

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff COPYRIGHT:
    -Copyright (C) 2005-2022 Mike Pall. All rights reserved.
    +Copyright (C) 2005-2023 Mike Pall. All rights reserved.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/luajit/0001-no-bin-symlink.patch |  4 ++--
 package/luajit/0002-install-inc.patch    |  6 +++---
 package/luajit/luajit.hash               |  4 ++--
 package/luajit/luajit.mk                 | 12 +++++++++++-
 4 files changed, 18 insertions(+), 8 deletions(-)

diff --git a/package/luajit/0001-no-bin-symlink.patch b/package/luajit/0001-no-bin-symlink.patch
index dc36fa58d..ea0e5bf8d 100644
--- a/package/luajit/0001-no-bin-symlink.patch
+++ b/package/luajit/0001-no-bin-symlink.patch
@@ -6,7 +6,7 @@  Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -45,8 +45,7 @@
+@@ -50,8 +50,7 @@
  INSTALL_MAN= $(INSTALL_SHARE)/man/man1
  INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
  
@@ -16,7 +16,7 @@  Index: b/Makefile
  INSTALL_ANAME= libluajit-$(ABIVER).a
  INSTALL_SOSHORT1= libluajit-$(ABIVER).so
  INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
-@@ -61,7 +60,6 @@
+@@ -66,7 +65,6 @@
  INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
  INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
  INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
diff --git a/package/luajit/0002-install-inc.patch b/package/luajit/0002-install-inc.patch
index 8de777dce..163a5d36f 100644
--- a/package/luajit/0002-install-inc.patch
+++ b/package/luajit/0002-install-inc.patch
@@ -6,12 +6,12 @@  Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -33,7 +33,7 @@
+@@ -38,7 +38,7 @@
  INSTALL_BIN=   $(DPREFIX)/bin
  INSTALL_LIB=   $(DPREFIX)/$(MULTILIB)
  INSTALL_SHARE= $(DPREFIX)/share
--INSTALL_DEFINC= $(DPREFIX)/include/luajit-$(MAJVER).$(MINVER)
+-INSTALL_DEFINC= $(DPREFIX)/include/luajit-$(MMVERSION)
 +INSTALL_DEFINC= $(DPREFIX)/include
  INSTALL_INC=   $(INSTALL_DEFINC)
  
- INSTALL_LJLIBD= $(INSTALL_SHARE)/luajit-$(VERSION)
+ INSTALL_LJLIBD= $(INSTALL_SHARE)/luajit-$(MMVERSION)
diff --git a/package/luajit/luajit.hash b/package/luajit/luajit.hash
index 049f8c2fc..578bb7a3e 100644
--- a/package/luajit/luajit.hash
+++ b/package/luajit/luajit.hash
@@ -1,5 +1,5 @@ 
 # Locally calculated
-sha256  835035b244c3dc3d3d19bdd5ac623af90b84207e6330fb78f9fa51d6e200d760  luajit-8635cbabf3094c4d8bd00578c7d812bea87bb2d3.tar.gz
+sha256  b518721280390e4cec1af30f6819d86756ce4234d82410a55a4e121855f64e08  luajit-41fb94defa8f830ce69a8122b03f6ac3216d392a.tar.gz
 
 # Locally calculated
-sha256  52fc5b15ac968ed81aabb4c1e23ab3bce50f57a5764e9cdca86b463a11072921  COPYRIGHT
+sha256  1130331ac861a4b4520e9c8ad0814efdc6f1e79ea55ea9c460c73733d13ccb5f  COPYRIGHT
diff --git a/package/luajit/luajit.mk b/package/luajit/luajit.mk
index 2a27aa505..07cb6e015 100644
--- a/package/luajit/luajit.mk
+++ b/package/luajit/luajit.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LUAJIT_VERSION = 8635cbabf3094c4d8bd00578c7d812bea87bb2d3
+LUAJIT_VERSION = 41fb94defa8f830ce69a8122b03f6ac3216d392a
 LUAJIT_SITE = $(call github,LuaJIT,LuaJIT,$(LUAJIT_VERSION))
 LUAJIT_LICENSE = MIT
 LUAJIT_LICENSE_FILES = COPYRIGHT
@@ -33,6 +33,16 @@  LUAJIT_HOST_CC = $(HOSTCC) -m32
 LUAJIT_XCFLAGS += -DLUAJIT_DISABLE_GC64
 endif
 
+# emulation of git archive with .gitattributes & export-subst
+# Timestamp of the $(LUAJIT_VERSION) commit, obtained in the LuaJit
+# repo, with:   git show -s --format=%ct $(LUAJIT_VERSION)
+define LUAJIT_ROLLING_VERSION
+	echo 1693350652 >$(@D)/.relver
+endef
+
+LUAJIT_POST_EXTRACT_HOOKS = LUAJIT_ROLLING_VERSION
+HOST_LUAJIT_POST_EXTRACT_HOOKS = LUAJIT_ROLLING_VERSION
+
 # We unfortunately can't use TARGET_CONFIGURE_OPTS, because the luajit
 # build system uses non conventional variable names.
 define LUAJIT_BUILD_CMDS