diff mbox series

Makefile: remove $(TARGET_DIR)/usr/mkspecs in target-finalize

Message ID 20230824210800.1589677-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series Makefile: remove $(TARGET_DIR)/usr/mkspecs in target-finalize | expand

Commit Message

Thomas Petazzoni Aug. 24, 2023, 9:08 p.m. UTC
qt6base installs things in /usr/mkspecs, but also the soon to be added
qt6core5compat, and the existing package qwt as well. So let's move
the removal of /usr/mkspecs in target-finalize, where we already
remove lots of development-related directories.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 Makefile           | 1 +
 package/qwt/qwt.mk | 1 -
 2 files changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Aug. 24, 2023, 9:17 p.m. UTC | #1
On 2023-08-24 23:08 +0200, Thomas Petazzoni via buildroot spake thusly:
> qt6base installs things in /usr/mkspecs, but also the soon to be added
> qt6core5compat, and the existing package qwt as well. So let's move
> the removal of /usr/mkspecs in target-finalize, where we already
> remove lots of development-related directories.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  Makefile           | 1 +
>  package/qwt/qwt.mk | 1 -
>  2 files changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index da52a51716..f255b1e443 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -747,6 +747,7 @@ endif
>  	rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
>  	rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
>  	rm -rf $(TARGET_DIR)/usr/share/gtk-doc
> +	rm -rf $(TARGET_DIR)/usr/mkspecs

Why don't you make that a QT6BASE_TARGET_FINALIZE_HOOKS ?

I'm warry of adding package-specific cleanup in the generic code, and we
introduced FOO_TARGET_FINALIZE_HOOKS specifically for such use-cases.

Regards,
Yann E. MORIN.

>  	rmdir $(TARGET_DIR)/usr/share 2>/dev/null || true
>  ifneq ($(BR2_ENABLE_DEBUG):$(BR2_STRIP_strip),y:)
>  	rm -rf $(TARGET_DIR)/lib/debug $(TARGET_DIR)/usr/lib/debug
> diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
> index 9f0b78655f..f344ca4e3a 100644
> --- a/package/qwt/qwt.mk
> +++ b/package/qwt/qwt.mk
> @@ -58,7 +58,6 @@ endef
>  
>  define QWT_INSTALL_TARGET_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install INSTALL_ROOT=$(TARGET_DIR)
> -	rm -Rf $(TARGET_DIR)/usr/mkspecs
>  endef
>  
>  $(eval $(qmake-package))
> -- 
> 2.41.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Yann E. MORIN Dec. 28, 2023, 8:33 p.m. UTC | #2
Thomas, All,

On 2023-08-24 23:08 +0200, Thomas Petazzoni via buildroot spake thusly:
> qt6base installs things in /usr/mkspecs, but also the soon to be added
> qt6core5compat, and the existing package qwt as well. So let's move
> the removal of /usr/mkspecs in target-finalize, where we already
> remove lots of development-related directories.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  Makefile           | 1 +
>  package/qwt/qwt.mk | 1 -
>  2 files changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/Makefile b/Makefile
> index da52a51716..f255b1e443 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -747,6 +747,7 @@ endif
>  	rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
>  	rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
>  	rm -rf $(TARGET_DIR)/usr/share/gtk-doc
> +	rm -rf $(TARGET_DIR)/usr/mkspecs

As I suggested back in August, without negative feedback, I made that
a target-finalize hook of the qt6base package.

Applied to master, thanks.

Regards,
Yann E. MORIN.

>  	rmdir $(TARGET_DIR)/usr/share 2>/dev/null || true
>  ifneq ($(BR2_ENABLE_DEBUG):$(BR2_STRIP_strip),y:)
>  	rm -rf $(TARGET_DIR)/lib/debug $(TARGET_DIR)/usr/lib/debug
> diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
> index 9f0b78655f..f344ca4e3a 100644
> --- a/package/qwt/qwt.mk
> +++ b/package/qwt/qwt.mk
> @@ -58,7 +58,6 @@ endef
>  
>  define QWT_INSTALL_TARGET_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install INSTALL_ROOT=$(TARGET_DIR)
> -	rm -Rf $(TARGET_DIR)/usr/mkspecs
>  endef
>  
>  $(eval $(qmake-package))
> -- 
> 2.41.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/Makefile b/Makefile
index da52a51716..f255b1e443 100644
--- a/Makefile
+++ b/Makefile
@@ -747,6 +747,7 @@  endif
 	rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
 	rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
 	rm -rf $(TARGET_DIR)/usr/share/gtk-doc
+	rm -rf $(TARGET_DIR)/usr/mkspecs
 	rmdir $(TARGET_DIR)/usr/share 2>/dev/null || true
 ifneq ($(BR2_ENABLE_DEBUG):$(BR2_STRIP_strip),y:)
 	rm -rf $(TARGET_DIR)/lib/debug $(TARGET_DIR)/usr/lib/debug
diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
index 9f0b78655f..f344ca4e3a 100644
--- a/package/qwt/qwt.mk
+++ b/package/qwt/qwt.mk
@@ -58,7 +58,6 @@  endef
 
 define QWT_INSTALL_TARGET_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install INSTALL_ROOT=$(TARGET_DIR)
-	rm -Rf $(TARGET_DIR)/usr/mkspecs
 endef
 
 $(eval $(qmake-package))