diff mbox series

package/pounce: New package

Message ID 20230814113637.28134-1-ismael@iodev.co.uk
State Rejected
Headers show
Series package/pounce: New package | expand

Commit Message

Ismael Luceno Aug. 14, 2023, 11:36 a.m. UTC
Simple IRC bouncer.

Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>
---
 DEVELOPERS                 |  1 +
 package/Config.in          |  1 +
 package/pounce/Config.in   | 18 ++++++++++++++++++
 package/pounce/pounce.hash |  3 +++
 package/pounce/pounce.mk   | 14 ++++++++++++++
 5 files changed, 37 insertions(+)
 create mode 100644 package/pounce/Config.in
 create mode 100644 package/pounce/pounce.hash
 create mode 100644 package/pounce/pounce.mk

Comments

Yann E. MORIN Aug. 14, 2023, 11:59 a.m. UTC | #1
Ismael, All,

On 2023-08-14 13:36 +0200, Ismael Luceno spake thusly:
> Simple IRC bouncer.
> 
> Signed-off-by: Ismael Luceno <ismael@iodev.co.uk>

You did not take into account a single one of the comments I made in
my previous review:
    https://lore.kernel.org/buildroot/20230712193831.GI188780@scaer/

Please read that review and act upon the comments before you submit
again.

If you have some concerns or questions about some of what I said, please
address those by replying to my review mail.

Regards,
Yann E. MORIN.

> ---
>  DEVELOPERS                 |  1 +
>  package/Config.in          |  1 +
>  package/pounce/Config.in   | 18 ++++++++++++++++++
>  package/pounce/pounce.hash |  3 +++
>  package/pounce/pounce.mk   | 14 ++++++++++++++
>  5 files changed, 37 insertions(+)
>  create mode 100644 package/pounce/Config.in
>  create mode 100644 package/pounce/pounce.hash
>  create mode 100644 package/pounce/pounce.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 6ffa3ee693a8..4dad3d474ad0 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1338,6 +1338,7 @@ F:	package/exempi/
>  N:	Ismael Luceno <ismael@iodev.co.uk>
>  F:	package/axel/
>  F:	package/mawk/
> +F:	package/pounce/
>  
>  N:	Jagan Teki <jagan@amarulasolutions.com>
>  F:	board/amarula/
> diff --git a/package/Config.in b/package/Config.in
> index 54cddc39140d..783683dd5201 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -2458,6 +2458,7 @@ endif
>  	source "package/phytool/Config.in"
>  	source "package/pimd/Config.in"
>  	source "package/pixiewps/Config.in"
> +	source "package/pounce/Config.in"
>  	source "package/pound/Config.in"
>  	source "package/pppd/Config.in"
>  	source "package/pptp-linux/Config.in"
> diff --git a/package/pounce/Config.in b/package/pounce/Config.in
> new file mode 100644
> index 000000000000..83bb66643652
> --- /dev/null
> +++ b/package/pounce/Config.in
> @@ -0,0 +1,18 @@
> +config BR2_PACKAGE_POUNCE
> +	bool "pounce"
> +	select BR2_PACKAGE_LIBRESSL
> +	help
> +	  pounce is a multi-client, TLS-only IRC bouncer. It maintains a
> +	  persistent connection to an IRC server, acting as a proxy and
> +	  buffer for a number of clients. When a client connects, any
> +	  messages received since it last disconnected will be relayed to
> +	  it. Unlike some other bouncers, pounce uses a single buffer for
> +	  all IRC messages, which acts as a queue from which each client
> +	  reads messages independently.
> +
> +	  pounce speaks regular modern IRC to both servers and clients, using
> +	  the server-time extension to indicate when messages originally
> +	  occurred. Clients identify themselves to pounce by their IRC
> +	  usernames.
> +
> +	  https://git.causal.agency/pounce/
> diff --git a/package/pounce/pounce.hash b/package/pounce/pounce.hash
> new file mode 100644
> index 000000000000..a827bd389f40
> --- /dev/null
> +++ b/package/pounce/pounce.hash
> @@ -0,0 +1,3 @@
> +# Locally computed
> +sha256  97f245556b1cc940553fca18f4d7d82692e6c11a30f612415e5e391e5d96604e  pounce-3.1.tar.gz
> +sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE
> diff --git a/package/pounce/pounce.mk b/package/pounce/pounce.mk
> new file mode 100644
> index 000000000000..b0a28efd91bd
> --- /dev/null
> +++ b/package/pounce/pounce.mk
> @@ -0,0 +1,14 @@
> +################################################################################
> +#
> +# pounce
> +#
> +################################################################################
> +
> +POUNCE_VERSION = 3.1
> +POUNCE_SITE = https://git.causal.agency/pounce/snapshot
> +POUNCE_SOURCE = pounce-$(POUNCE_VERSION).tar.gz
> +POUNCE_LICENSE = GPL-3.0+
> +POUNCE_LICENSE_FILES = LICENSE
> +POUNCE_DEPENDENCIES = libressl
> +
> +$(eval $(autotools-package))
> -- 
> 2.41.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Ismael Luceno Aug. 14, 2023, 12:12 p.m. UTC | #2
On 14/Aug/2023 13:59, Yann E. MORIN wrote:
<...> 
> You did not take into account a single one of the comments I made in
> my previous review:
<...>

Ah, sorry, I sent it again by accident.
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 6ffa3ee693a8..4dad3d474ad0 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1338,6 +1338,7 @@  F:	package/exempi/
 N:	Ismael Luceno <ismael@iodev.co.uk>
 F:	package/axel/
 F:	package/mawk/
+F:	package/pounce/
 
 N:	Jagan Teki <jagan@amarulasolutions.com>
 F:	board/amarula/
diff --git a/package/Config.in b/package/Config.in
index 54cddc39140d..783683dd5201 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2458,6 +2458,7 @@  endif
 	source "package/phytool/Config.in"
 	source "package/pimd/Config.in"
 	source "package/pixiewps/Config.in"
+	source "package/pounce/Config.in"
 	source "package/pound/Config.in"
 	source "package/pppd/Config.in"
 	source "package/pptp-linux/Config.in"
diff --git a/package/pounce/Config.in b/package/pounce/Config.in
new file mode 100644
index 000000000000..83bb66643652
--- /dev/null
+++ b/package/pounce/Config.in
@@ -0,0 +1,18 @@ 
+config BR2_PACKAGE_POUNCE
+	bool "pounce"
+	select BR2_PACKAGE_LIBRESSL
+	help
+	  pounce is a multi-client, TLS-only IRC bouncer. It maintains a
+	  persistent connection to an IRC server, acting as a proxy and
+	  buffer for a number of clients. When a client connects, any
+	  messages received since it last disconnected will be relayed to
+	  it. Unlike some other bouncers, pounce uses a single buffer for
+	  all IRC messages, which acts as a queue from which each client
+	  reads messages independently.
+
+	  pounce speaks regular modern IRC to both servers and clients, using
+	  the server-time extension to indicate when messages originally
+	  occurred. Clients identify themselves to pounce by their IRC
+	  usernames.
+
+	  https://git.causal.agency/pounce/
diff --git a/package/pounce/pounce.hash b/package/pounce/pounce.hash
new file mode 100644
index 000000000000..a827bd389f40
--- /dev/null
+++ b/package/pounce/pounce.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  97f245556b1cc940553fca18f4d7d82692e6c11a30f612415e5e391e5d96604e  pounce-3.1.tar.gz
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE
diff --git a/package/pounce/pounce.mk b/package/pounce/pounce.mk
new file mode 100644
index 000000000000..b0a28efd91bd
--- /dev/null
+++ b/package/pounce/pounce.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# pounce
+#
+################################################################################
+
+POUNCE_VERSION = 3.1
+POUNCE_SITE = https://git.causal.agency/pounce/snapshot
+POUNCE_SOURCE = pounce-$(POUNCE_VERSION).tar.gz
+POUNCE_LICENSE = GPL-3.0+
+POUNCE_LICENSE_FILES = LICENSE
+POUNCE_DEPENDENCIES = libressl
+
+$(eval $(autotools-package))