diff mbox series

package/esp-hosted: fix build failure with missing CONFIG_SPI/MMC

Message ID 20230812212032.349673-1-giulio.benetti@benettiengineering.com
State Accepted
Headers show
Series package/esp-hosted: fix build failure with missing CONFIG_SPI/MMC | expand

Commit Message

Giulio Benetti Aug. 12, 2023, 9:20 p.m. UTC
Depending on the interface chosen we need to enable Linux CONFIG_SPI or
CONFIG_MMC, so let's do that according to BR2_PACKAGE_ESP_HOSTED_SPI.

Fixes:
http://autobuild.buildroot.net/results/cdf65ad07aba1d86f195576a2317c83aeb3dfce2

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 package/esp-hosted/esp-hosted.mk | 3 +++
 1 file changed, 3 insertions(+)

Comments

Thomas Petazzoni Aug. 22, 2023, 8:10 p.m. UTC | #1
On Sat, 12 Aug 2023 23:20:32 +0200
Giulio Benetti <giulio.benetti@benettiengineering.com> wrote:

> Depending on the interface chosen we need to enable Linux CONFIG_SPI or
> CONFIG_MMC, so let's do that according to BR2_PACKAGE_ESP_HOSTED_SPI.
> 
> Fixes:
> http://autobuild.buildroot.net/results/cdf65ad07aba1d86f195576a2317c83aeb3dfce2
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> ---
>  package/esp-hosted/esp-hosted.mk | 3 +++
>  1 file changed, 3 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/esp-hosted/esp-hosted.mk b/package/esp-hosted/esp-hosted.mk
index dcb0b3bd70..7491c46512 100644
--- a/package/esp-hosted/esp-hosted.mk
+++ b/package/esp-hosted/esp-hosted.mk
@@ -17,6 +17,9 @@  define ESP_HOSTED_LINUX_CONFIG_FIXUPS
 	$(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_MAC80211)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_BT)
+	$(if $(BR2_PACKAGE_ESP_HOSTED_SPI),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_SPI),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_MMC))
 endef
 
 ifeq ($(BR2_PACKAGE_ESP_HOSTED_SPI),y)