diff mbox series

[v3,2/8] support/scripts/pkg-stats: ignore llvm-project.mk

Message ID 20230812192842.135682-2-dalang@gmx.at
State Superseded
Headers show
Series [v3,1/8] support/scripts/pkg-stats: fix typos | expand

Commit Message

Daniel Lang Aug. 12, 2023, 7:28 p.m. UTC
Fixes:
f6eaf60 ("package/llvm-project: new group for llvm packages")

Signed-off-by: Daniel Lang <dalang@gmx.at>
---
 support/scripts/pkg-stats | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle Aug. 30, 2023, 8:31 p.m. UTC | #1
On 12/08/2023 21:28, Daniel Lang wrote:
> Fixes:
> f6eaf60 ("package/llvm-project: new group for llvm packages")
> 
> Signed-off-by: Daniel Lang <dalang@gmx.at>
> ---
>   support/scripts/pkg-stats | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
> index eea900124c..1ac538f5f9 100755
> --- a/support/scripts/pkg-stats
> +++ b/support/scripts/pkg-stats
> @@ -345,6 +345,7 @@ def get_pkglist(npackages, package_list):
>                        "package/gstreamer/gstreamer.mk",
>                        "package/gstreamer1/gstreamer1.mk",
>                        "package/gtk2-themes/gtk2-themes.mk",
> +                     "package/llvm-project/llvm-project.mk",

  Why this specific one, and not the I-don't-know-how-many others that are in a 
similar situation? E.g. qt6, barebox to take two examples.

  Regards,
  Arnout

>                        "package/matchbox/matchbox.mk",
>                        "package/opengl/opengl.mk",
>                        "package/qt5/qt5.mk",
Daniel Lang Aug. 31, 2023, 3:35 a.m. UTC | #2
Hi Arnout,

On 30.08.23 22:31, Arnout Vandecappelle via buildroot wrote:
> 
> 
> On 12/08/2023 21:28, Daniel Lang wrote:
>> Fixes:
>> f6eaf60 ("package/llvm-project: new group for llvm packages")
>>
>> Signed-off-by: Daniel Lang <dalang@gmx.at>
>> ---
>>   support/scripts/pkg-stats | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
>> index eea900124c..1ac538f5f9 100755
>> --- a/support/scripts/pkg-stats
>> +++ b/support/scripts/pkg-stats
>> @@ -345,6 +345,7 @@ def get_pkglist(npackages, package_list):
>>                        "package/gstreamer/gstreamer.mk",
>>                        "package/gstreamer1/gstreamer1.mk",
>>                        "package/gtk2-themes/gtk2-themes.mk",
>> +                     "package/llvm-project/llvm-project.mk",
> 
>  Why this specific one, and not the I-don't-know-how-many others that are in a similar situation? E.g. qt6, barebox to take two examples.

I contributed the llvm-project sub-directory some time ago
and always wondered why it showed up in pkg-stats but not
qt5, which was my reference.
Working on this series I took a closer look at the script
and found the list of excluded packages, so I added llvm-project.
I will check all packages that are in a similar situation
for v4.

> 
>  Regards,
>  Arnout
> 
>>                        "package/matchbox/matchbox.mk",
>>                        "package/opengl/opengl.mk",
>>                        "package/qt5/qt5.mk",

Regards
Daniel
diff mbox series

Patch

diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
index eea900124c..1ac538f5f9 100755
--- a/support/scripts/pkg-stats
+++ b/support/scripts/pkg-stats
@@ -345,6 +345,7 @@  def get_pkglist(npackages, package_list):
                      "package/gstreamer/gstreamer.mk",
                      "package/gstreamer1/gstreamer1.mk",
                      "package/gtk2-themes/gtk2-themes.mk",
+                     "package/llvm-project/llvm-project.mk",
                      "package/matchbox/matchbox.mk",
                      "package/opengl/opengl.mk",
                      "package/qt5/qt5.mk",