diff mbox series

[1/1] package/cairo: mutex support depends on NPTL

Message ID 20230727065417.347083-1-bernd@kuhls.net
State Superseded
Headers show
Series [1/1] package/cairo: mutex support depends on NPTL | expand

Commit Message

Bernd Kuhls July 27, 2023, 6:54 a.m. UTC
Fixes:
http://autobuild.buildroot.net/results/041/041ac8f0809a0f9415c545b7585cd197db08b55f/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
The last bump of cairo took place in 2019 with commit
8d2a9d089a969909ad2de8acb67ee14ced03de28, the first build error of this
kind I could find dates back to Sep 2022:
http://autobuild.buildroot.net/results/8c5/8c547ec2e148ce3c4f230bb4b0d5c5b360d74dd5/

 package/cairo/cairo.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 27, 2023, 8:56 a.m. UTC | #1
On Thu, 27 Jul 2023 08:54:17 +0200
Bernd Kuhls <bernd@kuhls.net> wrote:

> Fixes:
> http://autobuild.buildroot.net/results/041/041ac8f0809a0f9415c545b7585cd197db08b55f/
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
> The last bump of cairo took place in 2019 with commit
> 8d2a9d089a969909ad2de8acb67ee14ced03de28, the first build error of this
> kind I could find dates back to Sep 2022:
> http://autobuild.buildroot.net/results/8c5/8c547ec2e148ce3c4f230bb4b0d5c5b360d74dd5/

This could have gone in the commit message itself. I believe (but I'm
not 100% sure) that this issue started occurring when fully random
configurations started being tested. Indeed before that we were not
testing configurations with threads enabled but not NPTL, I believe.

Anyway, the fact that the issue existed in September 2022 means we need
to backport this fix to our stable 2023.02.x and 2023.05.x branches,
which is really the information that we need to have.

Thomas
diff mbox series

Patch

diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index e8a704c7da..7bc8f92deb 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -26,7 +26,7 @@  ifeq ($(BR2_m68k_cf),y)
 CAIRO_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
 endif
 
-ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS_NPTL),)
 CAIRO_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -DCAIRO_NO_MUTEX=1"
 endif