diff mbox series

[v2] boot/barebox: Fix building of internal scripts

Message ID 20230724080409.29778-1-eagle.alexander923@gmail.com
State Accepted
Headers show
Series [v2] boot/barebox: Fix building of internal scripts | expand

Commit Message

Alexander Shiyan July 24, 2023, 8:04 a.m. UTC
Some barebox targets need to use internal scripts, for example rockchip64
uses scripts/rkimage which requires the pkg-config package to look up the
openssl options. Because buildroot hides the host pkg-config tool, the
scripts cannot be built correctly.
To solve this problem, let's use the pkg-config host environment and add
BR2_TARGET_BAREBOX_NEEDS_OPENSSL and BR2_TARGET_BAREBOX_NEEDS_LIBUSB options
if barebox scripts should use the openssl or libusb host libraries.

  HOSTCC  scripts/rkimage
Package openssl was not found in the pkg-config search path.
Perhaps you should add the directory containing `openssl.pc'
to the PKG_CONFIG_PATH environment variable
Package 'openssl', required by 'virtual:world', not found
/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: /tmp/ccN8Xyaj.o: in function `main':
rkimage.c:(.text.startup+0x218): undefined reference to `SHA256_Init'
/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: rkimage.c:(.text.startup+0x22b): undefined reference to `SHA256_Update'
/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: rkimage.c:(.text.startup+0x23e): undefined reference to `SHA256_Final'
/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: rkimage.c:(.text.startup+0x253): undefined reference to `SHA256_Init'
/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: rkimage.c:(.text.startup+0x265): undefined reference to `SHA256_Update'
/usr/lib/gcc/x86_64-pc-linux-gnu/12/../../../../x86_64-pc-linux-gnu/bin/ld: rkimage.c:(.text.startup+0x275): undefined reference to `SHA256_Final'
collect2: error: ld returned 1 exit status
make[2]: *** [scripts/Makefile.host:107: scripts/rkimage] Error 1
make[1]: *** [Makefile:976: scripts] Error 2

Signed-off-by: Alexander Shiyan <eagle.alexander923@gmail.com>
---
 boot/barebox/Config.in  | 12 ++++++++++++
 boot/barebox/barebox.mk | 14 ++++++++++++++
 2 files changed, 26 insertions(+)

Comments

Thomas Petazzoni July 28, 2023, 8:42 p.m. UTC | #1
Hello Alexander,

On Mon, 24 Jul 2023 11:04:09 +0300
Alexander Shiyan <eagle.alexander923@gmail.com> wrote:

> Some barebox targets need to use internal scripts, for example rockchip64
> uses scripts/rkimage which requires the pkg-config package to look up the
> openssl options. Because buildroot hides the host pkg-config tool, the
> scripts cannot be built correctly.
> To solve this problem, let's use the pkg-config host environment and add
> BR2_TARGET_BAREBOX_NEEDS_OPENSSL and BR2_TARGET_BAREBOX_NEEDS_LIBUSB options
> if barebox scripts should use the openssl or libusb host libraries.

I've reworded this because it was a bit unclear. You're insisting on
pkg-config in the explanation, while really what matters is
host-openssl and host-libusb.

New commit message looks like this:

commit 624d50b20cf4bf4a67ad6274263f85927660f8c4 (HEAD -> master, official/master)
Author: Alexander Shiyan <eagle.alexander923@gmail.com>
Date:   Mon Jul 24 11:04:09 2023 +0300

    boot/barebox: add optional dependencies on host-openssl and host-libusb
    
    Some barebox targets need to build host tools (for example rockchip64
    uses scripts/rkimage) that require some host libraries, such as
    host-openssl or host-libusb. These are detected by the Barebox build
    system using pkg-config.
    
    In order to allow supporting such Barebox configurations, we add two
    new options: BR2_TARGET_BAREBOX_NEEDS_OPENSSL and
    BR2_TARGET_BAREBOX_NEEDS_LIBUSB that respectively allow to ensure that
    host-openssl and/or host-libusb are built before Barebox.
    
    Additionally, $(1)_MAKE_ENV is adjusted to ensure that when pkg-config
    is run by the Barebox build system, it finds host libraries. This is
    similar to what is done in U-Boot.
    
> +ifeq ($(BR2_TARGET_BAREBOX_NEEDS_OPENSSL),y)
> +BAREBOX_DEPENDENCIES += host-openssl
> +endif
> +
> +ifeq ($(BR2_TARGET_BAREBOX_NEEDS_LIBUSB),y)
> +BAREBOX_DEPENDENCIES += host-libusb
> +endif

You forgot host-pkgconf in both cases. Without this, you have
host-openssl and/or host-libusb installed but pkg-config is not there
to allow detecting them. I fixed that up when applying.

Thanks for your work!

Thomas
diff mbox series

Patch

diff --git a/boot/barebox/Config.in b/boot/barebox/Config.in
index 3961c69c56..dba4a1a8d6 100644
--- a/boot/barebox/Config.in
+++ b/boot/barebox/Config.in
@@ -54,6 +54,18 @@  config BR2_TARGET_BAREBOX_CUSTOM_PATCH_DIR
 
 	  Most users may leave this empty
 
+config BR2_TARGET_BAREBOX_NEEDS_OPENSSL
+	bool "Barebox needs OpenSSL"
+	help
+	  Select this option if your Barebox board configuration
+	  requires OpenSSL to be available on the host.
+
+config BR2_TARGET_BAREBOX_NEEDS_LIBUSB
+	bool "Barebox needs LibUSB"
+	help
+	  Select this option if your Barebox board configuration
+	  requires libUSB to be available on the host.
+
 if BR2_TARGET_BAREBOX_CUSTOM_GIT
 
 config BR2_TARGET_BAREBOX_CUSTOM_GIT_REPO_URL
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index d7bcafe436..ead159a0f9 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -43,6 +43,14 @@  ifeq ($(BR2_TARGET_BAREBOX_LATEST_VERSION),y)
 $(1)_LICENSE_FILES = COPYING
 endif
 
+ifeq ($(BR2_TARGET_BAREBOX_NEEDS_OPENSSL),y)
+BAREBOX_DEPENDENCIES += host-openssl
+endif
+
+ifeq ($(BR2_TARGET_BAREBOX_NEEDS_LIBUSB),y)
+BAREBOX_DEPENDENCIES += host-libusb
+endif
+
 $(1)_CUSTOM_EMBEDDED_ENV_PATH = $$(call qstrip,$$(BR2_TARGET_$(1)_CUSTOM_EMBEDDED_ENV_PATH))
 
 ifneq ($$(call qstrip,$$(BR2_TARGET_BAREBOX_CUSTOM_PATCH_DIR)),)
@@ -73,6 +81,12 @@  endif
 
 $(1)_MAKE_FLAGS = ARCH=$$($(1)_ARCH) CROSS_COMPILE="$$(TARGET_CROSS)"
 $(1)_MAKE_ENV = $$(TARGET_MAKE_ENV)
+$(1)_MAKE_ENV += \
+	PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
+	PKG_CONFIG_SYSROOT_DIR="/" \
+	PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1 \
+	PKG_CONFIG_ALLOW_SYSTEM_LIBS=1 \
+	PKG_CONFIG_LIBDIR="$(HOST_DIR)/lib/pkgconfig:$(HOST_DIR)/share/pkgconfig"
 
 ifeq ($$(BR2_REPRODUCIBLE),y)
 $(1)_MAKE_ENV += \