diff mbox series

[v1,1/1] package/go-bootstrap-stage2: bump version to 1.19.11

Message ID 20230724011811.434148-1-christian@aperture.us
State Accepted
Headers show
Series [v1,1/1] package/go-bootstrap-stage2: bump version to 1.19.11 | expand

Commit Message

Christian Stewart July 24, 2023, 1:18 a.m. UTC
While it's not strictly necessary to update go-bootstrap-stage2, we can
continue to update the package to the latest 1.19.x until Go 1.19.x is
discontinued, at which point we can leave it at the final 1.19.x
version.

This package is only used when bootstrapping host-go.

go1.19.11 includes a security fix to the net/http package, as well as
bug fixes to cgo, the cover tool, the go command, the runtime, and the
go/printer package.

https://go.dev/doc/devel/release#go1.19.minor

Signed-off-by: Christian Stewart <christian@aperture.us>
---
 package/go-bootstrap-stage2/go-bootstrap-stage2.hash | 3 ++-
 package/go-bootstrap-stage2/go-bootstrap-stage2.mk   | 2 +-
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Aug. 8, 2023, 5:29 p.m. UTC | #1
On Sun, 23 Jul 2023 18:18:11 -0700
Christian Stewart via buildroot <buildroot@buildroot.org> wrote:

> While it's not strictly necessary to update go-bootstrap-stage2, we can
> continue to update the package to the latest 1.19.x until Go 1.19.x is
> discontinued, at which point we can leave it at the final 1.19.x
> version.
> 
> This package is only used when bootstrapping host-go.
> 
> go1.19.11 includes a security fix to the net/http package, as well as
> bug fixes to cgo, the cover tool, the go command, the runtime, and the
> go/printer package.
> 
> https://go.dev/doc/devel/release#go1.19.minor
> 
> Signed-off-by: Christian Stewart <christian@aperture.us>
> ---
>  package/go-bootstrap-stage2/go-bootstrap-stage2.hash | 3 ++-
>  package/go-bootstrap-stage2/go-bootstrap-stage2.mk   | 2 +-
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/package/go-bootstrap-stage2/go-bootstrap-stage2.hash b/package/go-bootstrap-stage2/go-bootstrap-stage2.hash
> index 874737ea2d..a698adaa23 100644
> --- a/package/go-bootstrap-stage2/go-bootstrap-stage2.hash
> +++ b/package/go-bootstrap-stage2/go-bootstrap-stage2.hash
> @@ -1,3 +1,4 @@
>  # From https://go.dev/dl
> -sha256  13755bcce529747d5f2930dee034730c86d02bd3e521ab3e2bbede548d3b953f  go1.19.10.src.tar.gz
> +sha256  e25c9ab72d811142b7f41ff6da5165fec2d1be5feec3ef2c66bc0bdecb431489  go1.19.11.src.tar.gz
>  sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
> +

Addition of a useless empty newline here causing a check-package
warning.

Fixed that, and applied to master. I've applied to master because it's
a low-risk update, with a security fix inside, even though admittedly
go-bootstrap-stage2 doesn't go on the target.

Thomas
diff mbox series

Patch

diff --git a/package/go-bootstrap-stage2/go-bootstrap-stage2.hash b/package/go-bootstrap-stage2/go-bootstrap-stage2.hash
index 874737ea2d..a698adaa23 100644
--- a/package/go-bootstrap-stage2/go-bootstrap-stage2.hash
+++ b/package/go-bootstrap-stage2/go-bootstrap-stage2.hash
@@ -1,3 +1,4 @@ 
 # From https://go.dev/dl
-sha256  13755bcce529747d5f2930dee034730c86d02bd3e521ab3e2bbede548d3b953f  go1.19.10.src.tar.gz
+sha256  e25c9ab72d811142b7f41ff6da5165fec2d1be5feec3ef2c66bc0bdecb431489  go1.19.11.src.tar.gz
 sha256  2d36597f7117c38b006835ae7f537487207d8ec407aa9d9980794b2030cbc067  LICENSE
+
diff --git a/package/go-bootstrap-stage2/go-bootstrap-stage2.mk b/package/go-bootstrap-stage2/go-bootstrap-stage2.mk
index 477c24299c..72f3200a2e 100644
--- a/package/go-bootstrap-stage2/go-bootstrap-stage2.mk
+++ b/package/go-bootstrap-stage2/go-bootstrap-stage2.mk
@@ -6,7 +6,7 @@ 
 
 # Use last Go version that go-bootstrap-stage1 can build: v1.19.x
 # See https://golang.org/doc/install/source#bootstrapFromSource
-GO_BOOTSTRAP_STAGE2_VERSION = 1.19.10
+GO_BOOTSTRAP_STAGE2_VERSION = 1.19.11
 GO_BOOTSTRAP_STAGE2_SITE = https://storage.googleapis.com/golang
 GO_BOOTSTRAP_STAGE2_SOURCE = go$(GO_BOOTSTRAP_STAGE2_VERSION).src.tar.gz