diff mbox series

linux: add support for vendor dirs for appended DTBs

Message ID 20230706222607.287386-1-alexander.sverdlin@gmail.com
State Accepted
Headers show
Series linux: add support for vendor dirs for appended DTBs | expand

Commit Message

Alexander Sverdlin July 6, 2023, 10:26 p.m. UTC
Take the basename of the appended DTBs to workaround the following problem:

(cd .../arch/arm/boot; for dtb in cirrus/ep93xx-edb9302
 do if test -e ${dtb}.dtb ; then dtbpath=${dtb}.dtb
 else dtbpath=dts/${dtb}.dtb ; fi
 cat zImage ${dtbpath} > zImage.${dtb} || exit 1; done)
/bin/sh: line 1: zImage.cirrus/ep93xx-edb9302: No such file or directory

Necessary to support ARM Linux starting from commit 724ba6751532
("ARM: dts: Move .dts files to vendor sub-directories"), i.e. Linux v6.4+.

Signed-off-by: Alexander Sverdlin <alexander.sverdlin@gmail.com>
---
 linux/linux.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni July 11, 2023, 9:44 p.m. UTC | #1
On Fri,  7 Jul 2023 00:26:07 +0200
Alexander Sverdlin <alexander.sverdlin@gmail.com> wrote:

> Take the basename of the appended DTBs to workaround the following problem:
> 
> (cd .../arch/arm/boot; for dtb in cirrus/ep93xx-edb9302
>  do if test -e ${dtb}.dtb ; then dtbpath=${dtb}.dtb
>  else dtbpath=dts/${dtb}.dtb ; fi
>  cat zImage ${dtbpath} > zImage.${dtb} || exit 1; done)
> /bin/sh: line 1: zImage.cirrus/ep93xx-edb9302: No such file or directory
> 
> Necessary to support ARM Linux starting from commit 724ba6751532
> ("ARM: dts: Move .dts files to vendor sub-directories"), i.e. Linux v6.4+.
> 
> Signed-off-by: Alexander Sverdlin <alexander.sverdlin@gmail.com>
> ---
>  linux/linux.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 1c4fe45ac9..1db5c6046d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -468,7 +468,7 @@  define LINUX_APPEND_DTB
 			else \
 				dtbpath=dts/$${dtb}.dtb ; \
 			fi ; \
-			cat zImage $${dtbpath} > zImage.$${dtb} || exit 1; \
+			cat zImage $${dtbpath} > zImage.$$(basename $${dtb}) || exit 1; \
 		done)
 endef
 ifeq ($(BR2_LINUX_KERNEL_APPENDED_UIMAGE),y)