diff mbox series

[v2,2/2] package/onevpl-intel-gpu: new package

Message ID 20230706170106.10825-2-bernd@kuhls.net
State Superseded
Headers show
Series [v2,1/2] package/onevpl: new package | expand

Commit Message

Bernd Kuhls July 6, 2023, 5:01 p.m. UTC
From: Bernd Kuhls <bernd.kuhls@t-online.de>

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
v2: bump to 23.2.4

 DEVELOPERS                                    |  1 +
 package/Config.in                             |  1 +
 package/onevpl-intel-gpu/Config.in            | 23 +++++++++++++++++++
 .../onevpl-intel-gpu/onevpl-intel-gpu.hash    |  3 +++
 package/onevpl-intel-gpu/onevpl-intel-gpu.mk  | 13 +++++++++++
 5 files changed, 41 insertions(+)
 create mode 100644 package/onevpl-intel-gpu/Config.in
 create mode 100644 package/onevpl-intel-gpu/onevpl-intel-gpu.hash
 create mode 100644 package/onevpl-intel-gpu/onevpl-intel-gpu.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 891b9f3b48..f6a154a4a0 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -412,6 +412,7 @@  F:	package/minidlna/
 F:	package/mjpg-streamer/
 F:	package/nut/
 F:	package/onevpl/
+F:	package/onevpl-intel-gpu/
 F:	package/perl-crypt-openssl-guess/
 F:	package/perl-crypt-openssl-random/
 F:	package/perl-crypt-openssl-rsa/
diff --git a/package/Config.in b/package/Config.in
index caed8ed904..7b3edd4496 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1634,6 +1634,7 @@  menu "Graphics"
 	source "package/libwpe/Config.in"
 	source "package/menu-cache/Config.in"
 	source "package/onevpl/Config.in"
+	source "package/onevpl-intel-gpu/Config.in"
 	source "package/opencl-clhpp/Config.in"
 	source "package/opencv3/Config.in"
 	source "package/opencv4/Config.in"
diff --git a/package/onevpl-intel-gpu/Config.in b/package/onevpl-intel-gpu/Config.in
new file mode 100644
index 0000000000..a0ca9e3d7d
--- /dev/null
+++ b/package/onevpl-intel-gpu/Config.in
@@ -0,0 +1,23 @@ 
+config BR2_PACKAGE_ONEVPL_INTEL_GPU
+	bool "onevpl-intel-gpu"
+	depends on BR2_PACKAGE_ONEVPL_ARCH_SUPPORTS # onevpl
+	depends on BR2_INSTALL_LIBSTDCPP # onevpl
+	depends on !BR2_STATIC_LIBS # onevpl
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # onevpl
+	depends on BR2_TOOLCHAIN_HAS_SYNC_1 # intel-mediadriver -> mesa3d
+	depends on BR2_TOOLCHAIN_HAS_THREADS # onevpl
+	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # intel-mediadriver -> mesa3d
+	select BR2_PACKAGE_INTEL_MEDIADRIVER # runtime
+	select BR2_PACKAGE_LIBVA
+	select BR2_PACKAGE_ONEVPL
+	help
+	  IntelĀ® oneVPL GPU Runtime is a Runtime implementation of
+	  oneVPL API for Intel Gen GPUs, starting with Tiger Lake.
+
+	  https://github.com/oneapi-src/oneVPL-intel-gpu
+
+comment "onevpl-intel-gpu needs a toolchain w/ dynamic library, gcc >= 7, C++, NPTL"
+	depends on BR2_PACKAGE_ONEVPL_ARCH_SUPPORTS
+	depends on BR2_TOOLCHAIN_HAS_SYNC_1
+	depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_7 || \
+		!BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/onevpl-intel-gpu/onevpl-intel-gpu.hash b/package/onevpl-intel-gpu/onevpl-intel-gpu.hash
new file mode 100644
index 0000000000..5b5cc9a002
--- /dev/null
+++ b/package/onevpl-intel-gpu/onevpl-intel-gpu.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  77a768645c323dfd3e395e6e7e1aff886a7d3af75fb9f38ee9e7014d11e6356f  onevpl-intel-gpu-23.2.4.tar.gz
+sha256  c31c3cc5fd66d1250dbca1c3d9011a9f874537442ac71c8de80f2f0fed13f297  LICENSE
diff --git a/package/onevpl-intel-gpu/onevpl-intel-gpu.mk b/package/onevpl-intel-gpu/onevpl-intel-gpu.mk
new file mode 100644
index 0000000000..ec889ac4b2
--- /dev/null
+++ b/package/onevpl-intel-gpu/onevpl-intel-gpu.mk
@@ -0,0 +1,13 @@ 
+################################################################################
+#
+# onevpl-intel-gpu
+#
+################################################################################
+
+ONEVPL_INTEL_GPU_VERSION = 23.2.4
+ONEVPL_INTEL_GPU_SITE = $(call github,oneapi-src,oneVPL-intel-gpu,intel-onevpl-$(ONEVPL_INTEL_GPU_VERSION))
+ONEVPL_INTEL_GPU_LICENSE = MIT
+ONEVPL_INTEL_GPU_LICENSE_FILES = LICENSE
+ONEVPL_INTEL_GPU_DEPENDENCIES = libva onevpl
+
+$(eval $(cmake-package))