diff mbox series

[1/1] configs/imx8mn_bsh_smm_s2[_pro]_defconfig: explicitly set binutils version

Message ID 20230706104035.4021893-1-dario.binacchi@amarulasolutions.com
State Changes Requested, archived
Headers show
Series [1/1] configs/imx8mn_bsh_smm_s2[_pro]_defconfig: explicitly set binutils version | expand

Commit Message

Dario Binacchi July 6, 2023, 10:40 a.m. UTC
The commit fb50eab8a5e6b ("package/binutils: switch to 2.39.x as the
default version") raised the following error during the compilation of the
arm-trusted-firmware-v2.5 package:

  PP      bl31/bl31.ld.S
  AR      output/build/arm-trusted-firmware-v2.5/build/imx8mn/debug/lib/libc.a
  LD      output/build/arm-trusted-firmware-v2.5/build/imx8mn/debug/bl31/bl31.elf
output/host/bin/aarch64-buildroot-linux-gnu-ld: warning: output/build/arm-trusted-firmware-v2.5/build/imx8mn/debug/bl31/bl31.elf has a LOAD segment with RWX permissions
make[2]: *** [Makefile:1143: output/build/arm-trusted-firmware-v2.5/build/imx8mn/debug/bl31/bl31.elf] Error 1
make[1]: *** [package/pkg-generic.mk:293: output/build/arm-trusted-firmware-v2.5/.stamp_built] Error 2
make: *** [Makefile:82: _all] Error 2

I tried to bump arm-trusted-firmware to the version that fixes the issue
against binutils version 2.39, but the subsequent board update was
unsuccessful. Therefore, for now, it is better not to change the version of
binutils to ensure the proper compilation of the image.

Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
---
 configs/imx8mn_bsh_smm_s2_defconfig     | 1 +
 configs/imx8mn_bsh_smm_s2_pro_defconfig | 1 +
 2 files changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/configs/imx8mn_bsh_smm_s2_defconfig b/configs/imx8mn_bsh_smm_s2_defconfig
index 8b2b74395efc..55d05393e184 100644
--- a/configs/imx8mn_bsh_smm_s2_defconfig
+++ b/configs/imx8mn_bsh_smm_s2_defconfig
@@ -1,5 +1,6 @@ 
 BR2_aarch64=y
 BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_6_1=y
+BR2_BINUTILS_VERSION_2_38_X=y
 BR2_TARGET_GENERIC_GETTY_PORT="ttymxc3"
 BR2_ROOTFS_POST_BUILD_SCRIPT="board/bsh/imx8mn-bsh-smm-s2/post-build.sh"
 BR2_LINUX_KERNEL=y
diff --git a/configs/imx8mn_bsh_smm_s2_pro_defconfig b/configs/imx8mn_bsh_smm_s2_pro_defconfig
index e9ff244a3555..b3767b332e84 100644
--- a/configs/imx8mn_bsh_smm_s2_pro_defconfig
+++ b/configs/imx8mn_bsh_smm_s2_pro_defconfig
@@ -1,5 +1,6 @@ 
 BR2_aarch64=y
 BR2_PACKAGE_HOST_LINUX_HEADERS_CUSTOM_6_1=y
+BR2_BINUTILS_VERSION_2_38_X=y
 BR2_TARGET_GENERIC_GETTY_PORT="ttymxc3"
 BR2_ROOTFS_POST_BUILD_SCRIPT="board/bsh/imx8mn-bsh-smm-s2-pro/post-build.sh"
 BR2_ROOTFS_POST_IMAGE_SCRIPT="board/bsh/imx8mn-bsh-smm-s2-pro/post-image.sh"