diff mbox series

[1/1] package/ffmpeg: mmal is not available on aarch64

Message ID 20230705161042.700055-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/1] package/ffmpeg: mmal is not available on aarch64 | expand

Commit Message

Bernd Kuhls July 5, 2023, 4:10 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/aa5/aa589b38e1591a0ec4d400891bf86f5138cf4542/

For details see:
https://lists.buildroot.org/pipermail/buildroot/2023-July/669839.html
https://github.com/raspberrypi/userland/issues/688

Reported-by: Guillermo G <ggalan3@gmail.com>
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/ffmpeg/ffmpeg.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni July 11, 2023, 9:03 p.m. UTC | #1
On Wed,  5 Jul 2023 18:10:42 +0200
Bernd Kuhls <bernd@kuhls.net> wrote:

> Fixes:
> http://autobuild.buildroot.net/results/aa5/aa589b38e1591a0ec4d400891bf86f5138cf4542/
> 
> For details see:
> https://lists.buildroot.org/pipermail/buildroot/2023-July/669839.html
> https://github.com/raspberrypi/userland/issues/688
> 
> Reported-by: Guillermo G <ggalan3@gmail.com>
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
>  package/ffmpeg/ffmpeg.mk | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 25, 2023, 1:19 p.m. UTC | #2
>>>>> "Bernd" == Bernd Kuhls <bernd@kuhls.net> writes:

 > Fixes:
 > http://autobuild.buildroot.net/results/aa5/aa589b38e1591a0ec4d400891bf86f5138cf4542/

 > For details see:
 > https://lists.buildroot.org/pipermail/buildroot/2023-July/669839.html
 > https://github.com/raspberrypi/userland/issues/688

 > Reported-by: Guillermo G <ggalan3@gmail.com>
 > Signed-off-by: Bernd Kuhls <bernd@kuhls.net>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
index 59e13b503e..9d9209706a 100644
--- a/package/ffmpeg/ffmpeg.mk
+++ b/package/ffmpeg/ffmpeg.mk
@@ -282,9 +282,14 @@  FFMPEG_CONF_OPTS += --disable-vdpau
 endif
 
 ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
-FFMPEG_CONF_OPTS += --enable-mmal --enable-omx --enable-omx-rpi \
+FFMPEG_CONF_OPTS += --enable-omx --enable-omx-rpi \
 	--extra-cflags=-I$(STAGING_DIR)/usr/include/IL
 FFMPEG_DEPENDENCIES += rpi-userland
+ifeq ($(BR2_arm),y)
+FFMPEG_CONF_OPTS += --enable-mmal
+else
+FFMPEG_CONF_OPTS += --disable-mmal
+endif
 else
 FFMPEG_CONF_OPTS += --disable-mmal --disable-omx --disable-omx-rpi
 endif