diff mbox series

[1/1] package/bluez5_utils: fix cross build

Message ID 20230704061944.496211-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/1] package/bluez5_utils: fix cross build | expand

Commit Message

Bernd Kuhls July 4, 2023, 6:19 a.m. UTC
Fix build error introduced by bumping bluez5_utils to 5.68 with buildroot
commit 7cac499ec46655a491e59b5bbc2a83a2137099bd due to upstream commit
https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/configure.ac?id=1106b28be85ac9586d1758839226e163e9030ee2

Fixes:
http://autobuild.buildroot.net/results/564/564952e0f9c7f69ef266d7df455ca033fb52d9f7/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 .../0001-configure-Check-ell-path.patch       | 35 +++++++++++++++++++
 package/bluez5_utils/bluez5_utils.mk          |  2 ++
 2 files changed, 37 insertions(+)
 create mode 100644 package/bluez5_utils/0001-configure-Check-ell-path.patch

Comments

Thomas Petazzoni July 10, 2023, 5:34 p.m. UTC | #1
On Tue,  4 Jul 2023 08:19:44 +0200
Bernd Kuhls <bernd@kuhls.net> wrote:

> Fix build error introduced by bumping bluez5_utils to 5.68 with buildroot
> commit 7cac499ec46655a491e59b5bbc2a83a2137099bd due to upstream commit
> https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/configure.ac?id=1106b28be85ac9586d1758839226e163e9030ee2
> 
> Fixes:
> http://autobuild.buildroot.net/results/564/564952e0f9c7f69ef266d7df455ca033fb52d9f7/
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
>  .../0001-configure-Check-ell-path.patch       | 35 +++++++++++++++++++
>  package/bluez5_utils/bluez5_utils.mk          |  2 ++
>  2 files changed, 37 insertions(+)
>  create mode 100644 package/bluez5_utils/0001-configure-Check-ell-path.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/bluez5_utils/0001-configure-Check-ell-path.patch b/package/bluez5_utils/0001-configure-Check-ell-path.patch
new file mode 100644
index 0000000000..3e5f7c6516
--- /dev/null
+++ b/package/bluez5_utils/0001-configure-Check-ell-path.patch
@@ -0,0 +1,35 @@ 
+From 124187ef9abed60a7c40f751153e9c4516cd1f91 Mon Sep 17 00:00:00 2001
+From: Rudi Heitbaum <rudi@heitbaum.com>
+Date: Sat, 1 Jul 2023 01:31:20 +0000
+Subject: [PATCH] configure: Check ell path
+
+Use of AC_CHECK_FILE prevents cross compilation.
+Instead use test to support cross compiling.
+
+Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
+
+Upstream: https://github.com/bluez/bluez/pull/546
+
+Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
+---
+ configure.ac | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index eff297960..bc7edfcd3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -298,9 +298,10 @@ if (test "${enable_external_ell}" = "yes"); then
+ 	AC_SUBST(ELL_LIBS)
+ fi
+ if (test "${enable_external_ell}" != "yes"); then
+-	AC_CHECK_FILE(${srcdir}/ell/ell.h, dummy=yes,
+-			AC_CHECK_FILE(${srcdir}/../ell/ell/ell.h, dummy=yes,
+-				AC_MSG_ERROR(ELL source is required or use --enable-external-ell)))
++	if (test ! -f ${srcdir}/ell/ell.h) &&
++			(test ! -f ${srcdir}/../ell/ell/ell.h); then
++				AC_MSG_ERROR(ELL source is required or use --enable-external-ell)
++	fi
+ fi
+ AM_CONDITIONAL(EXTERNAL_ELL, test "${enable_external_ell}" = "yes" ||
+ 				(test "${enable_btpclient}" != "yes" &&
diff --git a/package/bluez5_utils/bluez5_utils.mk b/package/bluez5_utils/bluez5_utils.mk
index 1e87041610..82800c0430 100644
--- a/package/bluez5_utils/bluez5_utils.mk
+++ b/package/bluez5_utils/bluez5_utils.mk
@@ -9,6 +9,8 @@  BLUEZ5_UTILS_VERSION = 5.68
 BLUEZ5_UTILS_SOURCE = bluez-$(BLUEZ5_UTILS_VERSION).tar.xz
 BLUEZ5_UTILS_SITE = $(BR2_KERNEL_MIRROR)/linux/bluetooth
 BLUEZ5_UTILS_INSTALL_STAGING = YES
+# 0001-configure-Check-ell-path.patch
+BLUEZ5_UTILS_AUTORECONF = YES
 BLUEZ5_UTILS_LICENSE = GPL-2.0+, LGPL-2.1+
 BLUEZ5_UTILS_LICENSE_FILES = COPYING COPYING.LIB
 BLUEZ5_UTILS_CPE_ID_VENDOR = bluez