diff mbox series

[1/1] package/libnatpmp: fix header install

Message ID 20230703202011.1995452-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/1] package/libnatpmp: fix header install | expand

Commit Message

Bernd Kuhls July 3, 2023, 8:20 p.m. UTC
Upstream renamed declspec.h to natpmp_declspec.h
https://github.com/miniupnp/libnatpmp/commit/1d113363980a98a5868ff2c2b05d7c94e3a18a70

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/libnatpmp/libnatpmp.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN July 3, 2023, 8:30 p.m. UTC | #1
Bernd, All,

On 2023-07-03 22:20 +0200, Bernd Kuhls spake thusly:
> Upstream renamed declspec.h to natpmp_declspec.h
> https://github.com/miniupnp/libnatpmp/commit/1d113363980a98a5868ff2c2b05d7c94e3a18a70
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>

Applied to master, thanks. But see a question, below...

> ---
>  package/libnatpmp/libnatpmp.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/libnatpmp/libnatpmp.mk b/package/libnatpmp/libnatpmp.mk
> index 3a625ea0fe..99d46d814a 100644
> --- a/package/libnatpmp/libnatpmp.mk
> +++ b/package/libnatpmp/libnatpmp.mk
> @@ -18,7 +18,7 @@ endef
>  define LIBNATPMP_INSTALL_STAGING_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
>  		PREFIX=$(STAGING_DIR) \
> -		HEADERS='declspec.h natpmp.h' \
> +		HEADERS='natpmp_declspec.h natpmp.h' \

So it means 0e258b6190a5 (package/libnatpmp: bump version to 20230423)
was not build-tested before being submitted? At least transmission
unonditionally uses it, so a runtime test of transmission would catch
it.

Regards,
Yann E. MORIN.

>  		$(TARGET_CONFIGURE_OPTS) install
>  endef
>  
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Bernd Kuhls July 3, 2023, 8:40 p.m. UTC | #2
Am Mon, 3 Jul 2023 22:30:26 +0200 schrieb Yann E. MORIN:

> So it means 0e258b6190a5 (package/libnatpmp: bump version to 20230423)
> was not build-tested before being submitted? At least transmission
> unonditionally uses it, so a runtime test of transmission would catch
> it.

Hi Yann,

I build-tested libnatpmp, which showed no errors because the tarball, 
contrary to https://github.com/miniupnp/libnatpmp, contains declspec.h 
which is unused by libnatpmp now so I did not catch the change of the 
header file.

At this stage I did not build-test its dependee package transmission, 
only later when build-testing all my stuff I noticed the problem and sent 
the patch right away.

Regards, Bernd
diff mbox series

Patch

diff --git a/package/libnatpmp/libnatpmp.mk b/package/libnatpmp/libnatpmp.mk
index 3a625ea0fe..99d46d814a 100644
--- a/package/libnatpmp/libnatpmp.mk
+++ b/package/libnatpmp/libnatpmp.mk
@@ -18,7 +18,7 @@  endef
 define LIBNATPMP_INSTALL_STAGING_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
 		PREFIX=$(STAGING_DIR) \
-		HEADERS='declspec.h natpmp.h' \
+		HEADERS='natpmp_declspec.h natpmp.h' \
 		$(TARGET_CONFIGURE_OPTS) install
 endef