diff mbox series

[1/1] package/sconeserver: re-add dependency to pcre

Message ID 20230702150232.3414717-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/1] package/sconeserver: re-add dependency to pcre | expand

Commit Message

Bernd Kuhls July 2, 2023, 3:02 p.m. UTC
While pcre was an optional dependency with autoconf [1] upstream removed
the HAVE_LIBPCRE defines with the introduction of cmake [2] breaking the
build without pcre after buildroot switched to cmake with commit
8b42bbf30a914b0fd40a4518e61ac7bc511a7deb.

Fixes:
http://autobuild.buildroot.net/results/a15/a15db87c8cec195905b6bcc2cbd3da59ad8aa3b9/

[1] https://github.com/sconemad/sconeserver/commit/98ec61436c9ea68ffe2d70a818c1175dcafa2a79
[2] https://github.com/sconemad/sconeserver/commit/0cb655721d7f8aa5d6d14fc1dfce18c518ce2419

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/sconeserver/Config.in      | 1 +
 package/sconeserver/sconeserver.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni July 3, 2023, 8:02 p.m. UTC | #1
On Sun,  2 Jul 2023 17:02:32 +0200
Bernd Kuhls <bernd@kuhls.net> wrote:

> While pcre was an optional dependency with autoconf [1] upstream removed
> the HAVE_LIBPCRE defines with the introduction of cmake [2] breaking the
> build without pcre after buildroot switched to cmake with commit
> 8b42bbf30a914b0fd40a4518e61ac7bc511a7deb.
> 
> Fixes:
> http://autobuild.buildroot.net/results/a15/a15db87c8cec195905b6bcc2cbd3da59ad8aa3b9/
> 
> [1] https://github.com/sconemad/sconeserver/commit/98ec61436c9ea68ffe2d70a818c1175dcafa2a79
> [2] https://github.com/sconemad/sconeserver/commit/0cb655721d7f8aa5d6d14fc1dfce18c518ce2419
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
>  package/sconeserver/Config.in      | 1 +
>  package/sconeserver/sconeserver.mk | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard July 17, 2023, 11:06 a.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni via buildroot <buildroot@buildroot.org> writes:

 > On Sun,  2 Jul 2023 17:02:32 +0200
 > Bernd Kuhls <bernd@kuhls.net> wrote:

 >> While pcre was an optional dependency with autoconf [1] upstream removed
 >> the HAVE_LIBPCRE defines with the introduction of cmake [2] breaking the
 >> build without pcre after buildroot switched to cmake with commit
 >> 8b42bbf30a914b0fd40a4518e61ac7bc511a7deb.
 >> 
 >> Fixes:
 >> http://autobuild.buildroot.net/results/a15/a15db87c8cec195905b6bcc2cbd3da59ad8aa3b9/
 >> 
 >> [1] https://github.com/sconemad/sconeserver/commit/98ec61436c9ea68ffe2d70a818c1175dcafa2a79
 >> [2] https://github.com/sconemad/sconeserver/commit/0cb655721d7f8aa5d6d14fc1dfce18c518ce2419
 >> 
 >> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
 >> ---
 >> package/sconeserver/Config.in      | 1 +
 >> package/sconeserver/sconeserver.mk | 2 +-
 >> 2 files changed, 2 insertions(+), 1 deletion(-)

 > Applied to master, thanks.

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/sconeserver/Config.in b/package/sconeserver/Config.in
index 3040dddbbb..0e8a995090 100644
--- a/package/sconeserver/Config.in
+++ b/package/sconeserver/Config.in
@@ -3,6 +3,7 @@  menuconfig BR2_PACKAGE_SCONESERVER
 	depends on BR2_INSTALL_LIBSTDCPP
 	depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
 	depends on !BR2_STATIC_LIBS # dlopen()
+	select BR2_PACKAGE_PCRE
 	select BR2_PACKAGE_ZLIB
 	help
 	  Sconeserver is a modular, object-orientated and extremely
diff --git a/package/sconeserver/sconeserver.mk b/package/sconeserver/sconeserver.mk
index bfbd5dc6ed..89abc8d3b2 100644
--- a/package/sconeserver/sconeserver.mk
+++ b/package/sconeserver/sconeserver.mk
@@ -10,7 +10,7 @@  SCONESERVER_LICENSE = GPL-2.0+
 SCONESERVER_LICENSE_FILES = COPYING
 SCONESERVER_DEPENDENCIES = \
 	host-pkgconf \
-	$(if $(BR2_PACKAGE_PCRE),pcre) \
+	pcre \
 	zlib
 # disable image as it fails to build with ImageMagick
 # disable markdown module because its git submodule cmark