diff mbox series

package/zfs: fix autotools crosscompilations

Message ID 20230608175538.1347170-1-salvador.joseluis@gmail.com
State Changes Requested
Headers show
Series package/zfs: fix autotools crosscompilations | expand

Commit Message

José Luis Salvador Rufo June 8, 2023, 5:55 p.m. UTC
Signed-off-by: José Luis Salvador Rufo <salvador.joseluis@gmail.com>
---
 package/zfs/zfs.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Alexander Mukhin June 9, 2023, 7:05 p.m. UTC | #1
José,

I am glad to confirm that your patch fixes the issue. Tested on:

Host:
Debian 11.7 x86-64

Toolchains:
x86-64--glibc--bleeding-edge-2022.08
armv6-eabihf--glibc--bleeding-edge-2022.08

Thank you!
Arnout Vandecappelle June 12, 2023, 5:57 p.m. UTC | #2
On 09/06/2023 21:05, Alexander Mukhin wrote:
> José,
> 
> I am glad to confirm that your patch fixes the issue. Tested on:
> 
> Host:
> Debian 11.7 x86-64
> 
> Toolchains:
> x86-64--glibc--bleeding-edge-2022.08
> armv6-eabihf--glibc--bleeding-edge-2022.08 >
> Thank you!
> 
> -- 
> Alexander.
> 

  Hi Alexander,

  Thank you for this test. In the future, please add the following tag 
(preferably below the signed-off-by, like I do below).

> On Thu, Jun 08, 2023 at 07:55:38PM +0200, José Luis Salvador Rufo wrote:
>> Signed-off-by: José Luis Salvador Rufo <salvador.joseluis@gmail.com>

Tested-by: Alexander Mukhin <alexander.i.mukhin@gmail.com>

(and put the details about how you tested below that).

This gets picked up by patchwork and:

- adds to the T column in the patchwork overview, so we can see at a glance that 
it's a patch that has been tested by someone;
- becomes part of the commit message when applying to the mainline tree, so if 
there's a problem later we can easily see in history that you originally tested 
it. Also, that way Peter can give you credit in the release notes.

  Regards,
  Arnout

>> ---
>>  package/zfs/zfs.mk | 8 ++++++++
>>  1 file changed, 8 insertions(+)
>>
>> diff --git a/package/zfs/zfs.mk b/package/zfs/zfs.mk
>> index 97e9442cf8..e99413e611 100644
>> --- a/package/zfs/zfs.mk
>> +++ b/package/zfs/zfs.mk
>> @@ -58,6 +58,14 @@ else
>>  ZFS_CONF_OPTS += --disable-pam
>>  endif
>>  
>> +# Sets the environment for the `make` that will be run ZFS autotools checks.
>> +ZFS_CONF_ENV += \
>> +	ARCH=$(KERNEL_ARCH) \
>> +	CROSS_COMPILE="$(TARGET_CROSS)"
>> +ZFS_MAKE_ENV += \
>> +	ARCH=$(KERNEL_ARCH) \
>> +	CROSS_COMPILE="$(TARGET_CROSS)"
>> +
>>  # ZFS userland tools are unfunctional without the Linux kernel modules.
>>  ZFS_MODULE_SUBDIRS = \
>>  	module/avl \
>> -- 
>> 2.41.0
>>
Thomas Petazzoni July 26, 2023, 9:30 p.m. UTC | #3
Hello José,

On Thu,  8 Jun 2023 19:55:38 +0200
José Luis Salvador Rufo <salvador.joseluis@gmail.com> wrote:

> Signed-off-by: José Luis Salvador Rufo <salvador.joseluis@gmail.com>

Thanks for the contribution, but unfortunately we cannot apply this
patch: it does not explain anything about which "autotools
crosscompilations" issues it is fixing. Are these failures visible in
the autobuilders? If so, what link? If not, what configuration/setup
exhibits the problem, what is the error message, how does the patch fix
the issue?

Could you send an updated patch with a non-empty commit log that
contains a sufficient amount of detail for us to properly
review/understand the change?

Thanks!

Thomas
José Luis Salvador Rufo Nov. 12, 2023, 10:17 p.m. UTC | #4
Hello Thomas,

Here is the same patch but with some explanation:
https://patchwork.ozlabs.org/project/buildroot/patch/20231112221115.2289525-3-salvador.joseluis@gmail.com/

Greetings.

El mié, 26 jul 2023 a las 23:30, Thomas Petazzoni (<
thomas.petazzoni@bootlin.com>) escribió:

> Hello José,
>
> On Thu,  8 Jun 2023 19:55:38 +0200
> José Luis Salvador Rufo <salvador.joseluis@gmail.com> wrote:
>
> > Signed-off-by: José Luis Salvador Rufo <salvador.joseluis@gmail.com>
>
> Thanks for the contribution, but unfortunately we cannot apply this
> patch: it does not explain anything about which "autotools
> crosscompilations" issues it is fixing. Are these failures visible in
> the autobuilders? If so, what link? If not, what configuration/setup
> exhibits the problem, what is the error message, how does the patch fix
> the issue?
>
> Could you send an updated patch with a non-empty commit log that
> contains a sufficient amount of detail for us to properly
> review/understand the change?
>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
>
diff mbox series

Patch

diff --git a/package/zfs/zfs.mk b/package/zfs/zfs.mk
index 97e9442cf8..e99413e611 100644
--- a/package/zfs/zfs.mk
+++ b/package/zfs/zfs.mk
@@ -58,6 +58,14 @@  else
 ZFS_CONF_OPTS += --disable-pam
 endif
 
+# Sets the environment for the `make` that will be run ZFS autotools checks.
+ZFS_CONF_ENV += \
+	ARCH=$(KERNEL_ARCH) \
+	CROSS_COMPILE="$(TARGET_CROSS)"
+ZFS_MAKE_ENV += \
+	ARCH=$(KERNEL_ARCH) \
+	CROSS_COMPILE="$(TARGET_CROSS)"
+
 # ZFS userland tools are unfunctional without the Linux kernel modules.
 ZFS_MODULE_SUBDIRS = \
 	module/avl \