diff mbox series

[1/1] package/tbb: bump to version 2021.8.0.

Message ID 20230428104403.10889-1-flaniel@linux.microsoft.com
State Accepted
Headers show
Series [1/1] package/tbb: bump to version 2021.8.0. | expand

Commit Message

Francis Laniel April 28, 2023, 10:44 a.m. UTC
- Remove upstream patches as they are no more needed.

Signed-off-by: Francis Laniel <flaniel@linux.microsoft.com>
---
 ...Musl-linux-can-not-use-RTLD_DEEPBIND.patch | 33 ---------------
 ...is-only-defined-on-glibc-and-android.patch | 42 -------------------
 ...-Define-ITT_ARCH_IA64-when-undefiend.patch | 27 ------------
 package/tbb/tbb.hash                          |  2 +-
 package/tbb/tbb.mk                            |  2 +-
 5 files changed, 2 insertions(+), 104 deletions(-)
 delete mode 100644 package/tbb/0001-Musl-linux-can-not-use-RTLD_DEEPBIND.patch
 delete mode 100644 package/tbb/0002-mallinfo-is-only-defined-on-glibc-and-android.patch
 delete mode 100644 package/tbb/0003-Define-ITT_ARCH_IA64-when-undefiend.patch

Comments

Peter Korsgaard May 1, 2023, 7:25 a.m. UTC | #1
>>>>> "Francis" == Francis Laniel <flaniel@linux.microsoft.com> writes:

 > - Remove upstream patches as they are no more needed.
 > Signed-off-by: Francis Laniel <flaniel@linux.microsoft.com>

Committed, thanks.
Francis Laniel May 2, 2023, 9:18 a.m. UTC | #2
Le lundi 1 mai 2023, 08:25:18 WEST Peter Korsgaard a écrit :
> >>>>> "Francis" == Francis Laniel <flaniel@linux.microsoft.com> writes:
>  > - Remove upstream patches as they are no more needed.
>  > Signed-off-by: Francis Laniel <flaniel@linux.microsoft.com>
> 
> Committed, thanks.

Thank you for the merge!
diff mbox series

Patch

diff --git a/package/tbb/0001-Musl-linux-can-not-use-RTLD_DEEPBIND.patch b/package/tbb/0001-Musl-linux-can-not-use-RTLD_DEEPBIND.patch
deleted file mode 100644
index 82182ce109..0000000000
--- a/package/tbb/0001-Musl-linux-can-not-use-RTLD_DEEPBIND.patch
+++ /dev/null
@@ -1,33 +0,0 @@ 
-From 883c2e5245c39624b3b5d6d56d5b203cf09eac38 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 15 Dec 2021 08:08:07 -0800
-Subject: [PATCH] Musl/linux can not use RTLD_DEEPBIND (#684)
-
-Exclude non-glibc linux systems along with android
-Fixes
-src/tbb/dynamic_link.cpp:417:29: error: use
- of undeclared identifier 'RTLD_DEEPBIND'                                                                                    |             flags = flags | RTLD_DEEPBIND;
-|                             ^
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-[Retrieved from:
-https://github.com/oneapi-src/oneTBB/commit/883c2e5245c39624b3b5d6d56d5b203cf09eac38]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- src/tbb/dynamic_link.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/tbb/dynamic_link.cpp b/src/tbb/dynamic_link.cpp
-index 3f1342503..5330d7107 100644
---- a/src/tbb/dynamic_link.cpp
-+++ b/src/tbb/dynamic_link.cpp
-@@ -413,7 +413,7 @@ namespace r1 {
-         int flags = RTLD_NOW;
-         if (local_binding) {
-             flags = flags | RTLD_LOCAL;
--#if __linux__ && !__ANDROID__ && !__TBB_USE_SANITIZERS
-+#if (__linux__ && __GLIBC__) && !__TBB_USE_SANITIZERS
-             flags = flags | RTLD_DEEPBIND;
- #endif
-         } else {
diff --git a/package/tbb/0002-mallinfo-is-only-defined-on-glibc-and-android.patch b/package/tbb/0002-mallinfo-is-only-defined-on-glibc-and-android.patch
deleted file mode 100644
index 9b397cac41..0000000000
--- a/package/tbb/0002-mallinfo-is-only-defined-on-glibc-and-android.patch
+++ /dev/null
@@ -1,42 +0,0 @@ 
-From 3a7f96db56cc9821055cbc769d3065db86b8b4c9 Mon Sep 17 00:00:00 2001
-From: Julien Voisin <jvoisin@users.noreply.github.com>
-Date: Mon, 7 Feb 2022 07:56:15 +0100
-Subject: [PATCH] mallinfo is only defined on glibc and android (#764)
-
-It currently prevents compilation under musl:
-
-```
-[ 90%] Building CXX object src/tbbmalloc_proxy/CMakeFiles/tbbmalloc_proxy.dir/proxy.cpp.o
-/__w/mimalloc-bench/mimalloc-bench/extern/tbb/src/tbbmalloc_proxy/proxy.cpp:263:26: error: return type 'struct mallinfo' is incomplete
-  263 | struct mallinfo mallinfo() __THROW
-      |                          ^
-compilation terminated due to -Wfatal-errors.
-``
-
-[Retrieved from:
-https://github.com/oneapi-src/oneTBB/commit/3a7f96db56cc9821055cbc769d3065db86b8b4c9]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- src/tbbmalloc_proxy/proxy.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/tbbmalloc_proxy/proxy.cpp b/src/tbbmalloc_proxy/proxy.cpp
-index e58e55e0b..23b9c19c1 100644
---- a/src/tbbmalloc_proxy/proxy.cpp
-+++ b/src/tbbmalloc_proxy/proxy.cpp
-@@ -260,6 +260,7 @@ int mallopt(int /*param*/, int /*value*/) __THROW
-     return 1;
- }
- 
-+#if defined(__GLIBC__) || defined(__ANDROID__)
- struct mallinfo mallinfo() __THROW
- {
-     struct mallinfo m;
-@@ -267,6 +268,7 @@ struct mallinfo mallinfo() __THROW
- 
-     return m;
- }
-+#endif
- 
- #if __ANDROID__
- // Android doesn't have malloc_usable_size, provide it to be compatible
diff --git a/package/tbb/0003-Define-ITT_ARCH_IA64-when-undefiend.patch b/package/tbb/0003-Define-ITT_ARCH_IA64-when-undefiend.patch
deleted file mode 100644
index 5b7f002499..0000000000
--- a/package/tbb/0003-Define-ITT_ARCH_IA64-when-undefiend.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-From 6fad69889da67bc4d4baff4afa94f77da45e006d Mon Sep 17 00:00:00 2001
-From: Felix Yan <felixonmars@archlinux.org>
-Date: Thu, 7 Oct 2021 14:16:16 +0800
-Subject: [PATCH] Define ITT_ARCH_IA64 when undefiend (#550)
-
-[Retrieved from:
-https://github.com/oneapi-src/oneTBB/commit/6fad69889da67bc4d4baff4afa94f77da45e006d]
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- src/tbb/tools_api/ittnotify_config.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/tbb/tools_api/ittnotify_config.h b/src/tbb/tools_api/ittnotify_config.h
-index 8ecc23781..f904a8e9d 100644
---- a/src/tbb/tools_api/ittnotify_config.h
-+++ b/src/tbb/tools_api/ittnotify_config.h
-@@ -147,6 +147,10 @@
- #  define ITT_ARCH_IA32E 2
- #endif /* ITT_ARCH_IA32E */
- 
-+#ifndef ITT_ARCH_IA64
-+#  define ITT_ARCH_IA64 3
-+#endif /* ITT_ARCH_IA64 */
-+
- #ifndef ITT_ARCH_ARM
- #  define ITT_ARCH_ARM  4
- #endif /* ITT_ARCH_ARM */
diff --git a/package/tbb/tbb.hash b/package/tbb/tbb.hash
index 9992fb3c4f..579581cfe4 100644
--- a/package/tbb/tbb.hash
+++ b/package/tbb/tbb.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  e5b57537c741400cf6134b428fc1689a649d7d38d9bb9c1b6d64f092ea28178a  tbb-2021.5.0.tar.gz
+sha256  eee380323bb7ce864355ed9431f85c43955faaae9e9bce35c62b372d7ffd9f8b  tbb-2021.8.0.tar.gz
 sha256  c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4  LICENSE.txt
diff --git a/package/tbb/tbb.mk b/package/tbb/tbb.mk
index fc720fd2f5..c3e06a4e6d 100644
--- a/package/tbb/tbb.mk
+++ b/package/tbb/tbb.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-TBB_VERSION = 2021.5.0
+TBB_VERSION = 2021.8.0
 TBB_SITE = $(call github,01org,tbb,v$(TBB_VERSION))
 TBB_INSTALL_STAGING = YES
 TBB_LICENSE = Apache-2.0