diff mbox series

[1/1] package/python-requests: bump to version 2.28.2

Message ID 20230329155154.75895-1-aaron@bubbl-tek.com
State Accepted
Headers show
Series [1/1] package/python-requests: bump to version 2.28.2 | expand

Commit Message

Aaron Sierra March 29, 2023, 3:51 p.m. UTC
Get explicit compatibility with charset-normalizer 3.x

Signed-off-by: Aaron Sierra <aaron@bubbl-tek.com>
---
 package/python-requests/python-requests.hash | 4 ++--
 package/python-requests/python-requests.mk   | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Yann E. MORIN March 29, 2023, 8:05 p.m. UTC | #1
Aaron, All,

+James

On 2023-03-29 10:51 -0500, Aaron Sierra spake thusly:
> Get explicit compatibility with charset-normalizer 3.x

Yes, that warning was getting annoying in my logs, thanks! :-)

That happens since 0511458dc1ef (package/python-charset-normalizer: bump
to version 3.0.0).

a0a9edb64caf (package/python-requests: bump to version 2.26.0), changed
the dependency from chardet to charset_normalizer without explanations,
although chardet was, and is, still supported.

James, do you remember why you changed the dependency?

The only reason I could unearth, is that upstream added support for
charset_nomalizer which is MIT, while chardet is LGPL. Anything else?

If at all, that change of dependency should have been done in a separate
patch, I think... Too late now... :-(

> Signed-off-by: Aaron Sierra <aaron@bubbl-tek.com>

Acked-by: Yann E. MORIN <yann.morin@orange.com>
Tested-by: Yann E. MORIN <yann.morin@orange.com>

Regards,
Yann E. MORIN.

> ---
>  package/python-requests/python-requests.hash | 4 ++--
>  package/python-requests/python-requests.mk   | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/package/python-requests/python-requests.hash b/package/python-requests/python-requests.hash
> index 1383e680d5..b6f696000b 100644
> --- a/package/python-requests/python-requests.hash
> +++ b/package/python-requests/python-requests.hash
> @@ -1,5 +1,5 @@
>  # md5, sha256 from https://pypi.org/pypi/requests/json
> -md5  796ea875cdae283529c03b9203d9c454  requests-2.28.1.tar.gz
> -sha256  7c5599b102feddaa661c826c56ab4fee28bfd17f5abca1ebbe3e7f19d7c97983  requests-2.28.1.tar.gz
> +md5  09b752e0b0a672d805ae54455c128d42  requests-2.28.2.tar.gz
> +sha256  98b1b2782e3c6c4904938b84c0eb932721069dfdb9134313beff7c83c2df24bf  requests-2.28.2.tar.gz
>  # Locally computed sha256 checksums
>  sha256  09e8a9bcec8067104652c168685ab0931e7868f9c8284b66f5ae6edae5f1130b  LICENSE
> diff --git a/package/python-requests/python-requests.mk b/package/python-requests/python-requests.mk
> index 7a21cca52c..8f9f4b2db4 100644
> --- a/package/python-requests/python-requests.mk
> +++ b/package/python-requests/python-requests.mk
> @@ -4,9 +4,9 @@
>  #
>  ################################################################################
>  
> -PYTHON_REQUESTS_VERSION = 2.28.1
> +PYTHON_REQUESTS_VERSION = 2.28.2
>  PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
> -PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/a5/61/a867851fd5ab77277495a8709ddda0861b28163c4613b011bc00228cc724
> +PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/9d/ee/391076f5937f0a8cdf5e53b701ffc91753e87b07d66bae4a09aa671897bf
>  PYTHON_REQUESTS_SETUP_TYPE = setuptools
>  PYTHON_REQUESTS_LICENSE = Apache-2.0
>  PYTHON_REQUESTS_LICENSE_FILES = LICENSE
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
James Hilliard March 29, 2023, 8:11 p.m. UTC | #2
On Wed, Mar 29, 2023 at 2:05 PM <yann.morin@orange.com> wrote:
>
> Aaron, All,
>
> +James
>
> On 2023-03-29 10:51 -0500, Aaron Sierra spake thusly:
> > Get explicit compatibility with charset-normalizer 3.x
>
> Yes, that warning was getting annoying in my logs, thanks! :-)
>
> That happens since 0511458dc1ef (package/python-charset-normalizer: bump
> to version 3.0.0).
>
> a0a9edb64caf (package/python-requests: bump to version 2.26.0), changed
> the dependency from chardet to charset_normalizer without explanations,
> although chardet was, and is, still supported.
>
> James, do you remember why you changed the dependency?

Only charset_normalizer is a required dependency in 2.26.0 for python3:
https://github.com/psf/requests/blob/v2.26.0/setup.py#L44-L45

chardet is a requirement for python2 but not python3 in 2.26.0

>
> The only reason I could unearth, is that upstream added support for
> charset_nomalizer which is MIT, while chardet is LGPL. Anything else?
>
> If at all, that change of dependency should have been done in a separate
> patch, I think... Too late now... :-(
>
> > Signed-off-by: Aaron Sierra <aaron@bubbl-tek.com>
>
> Acked-by: Yann E. MORIN <yann.morin@orange.com>
> Tested-by: Yann E. MORIN <yann.morin@orange.com>
>
> Regards,
> Yann E. MORIN.
>
> > ---
> >  package/python-requests/python-requests.hash | 4 ++--
> >  package/python-requests/python-requests.mk   | 4 ++--
> >  2 files changed, 4 insertions(+), 4 deletions(-)
> >
> > diff --git a/package/python-requests/python-requests.hash b/package/python-requests/python-requests.hash
> > index 1383e680d5..b6f696000b 100644
> > --- a/package/python-requests/python-requests.hash
> > +++ b/package/python-requests/python-requests.hash
> > @@ -1,5 +1,5 @@
> >  # md5, sha256 from https://pypi.org/pypi/requests/json
> > -md5  796ea875cdae283529c03b9203d9c454  requests-2.28.1.tar.gz
> > -sha256  7c5599b102feddaa661c826c56ab4fee28bfd17f5abca1ebbe3e7f19d7c97983  requests-2.28.1.tar.gz
> > +md5  09b752e0b0a672d805ae54455c128d42  requests-2.28.2.tar.gz
> > +sha256  98b1b2782e3c6c4904938b84c0eb932721069dfdb9134313beff7c83c2df24bf  requests-2.28.2.tar.gz
> >  # Locally computed sha256 checksums
> >  sha256  09e8a9bcec8067104652c168685ab0931e7868f9c8284b66f5ae6edae5f1130b  LICENSE
> > diff --git a/package/python-requests/python-requests.mk b/package/python-requests/python-requests.mk
> > index 7a21cca52c..8f9f4b2db4 100644
> > --- a/package/python-requests/python-requests.mk
> > +++ b/package/python-requests/python-requests.mk
> > @@ -4,9 +4,9 @@
> >  #
> >  ################################################################################
> >
> > -PYTHON_REQUESTS_VERSION = 2.28.1
> > +PYTHON_REQUESTS_VERSION = 2.28.2
> >  PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
> > -PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/a5/61/a867851fd5ab77277495a8709ddda0861b28163c4613b011bc00228cc724
> > +PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/9d/ee/391076f5937f0a8cdf5e53b701ffc91753e87b07d66bae4a09aa671897bf
> >  PYTHON_REQUESTS_SETUP_TYPE = setuptools
> >  PYTHON_REQUESTS_LICENSE = Apache-2.0
> >  PYTHON_REQUESTS_LICENSE_FILES = LICENSE
> > --
> > 2.25.1
> >
> > _______________________________________________
> > buildroot mailing list
> > buildroot@buildroot.org
> > https://lists.buildroot.org/mailman/listinfo/buildroot
>
> --
>                                         ____________
> .-----------------.--------------------:       _    :------------------.
> |  Yann E. MORIN  | Real-Time Embedded |    __/ )   | /"\ ASCII RIBBON |
> |                 | Software  Designer |  _/ - /'   | \ / CAMPAIGN     |
> | +33 638.411.245 '--------------------: (_    `--, |  X  AGAINST      |
> | yann.morin (at) orange.com           |_="    ,--' | / \ HTML MAIL    |
> '--------------------------------------:______/_____:------------------'
>
>
> _________________________________________________________________________________________________________________________
>
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> they should not be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
>
Yann E. MORIN May 6, 2023, 3:29 p.m. UTC | #3
Aaron, All,

On 2023-03-29 10:51 -0500, Aaron Sierra spake thusly:
> Get explicit compatibility with charset-normalizer 3.x
> 
> Signed-off-by: Aaron Sierra <aaron@bubbl-tek.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/python-requests/python-requests.hash | 4 ++--
>  package/python-requests/python-requests.mk   | 4 ++--
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/package/python-requests/python-requests.hash b/package/python-requests/python-requests.hash
> index 1383e680d5..b6f696000b 100644
> --- a/package/python-requests/python-requests.hash
> +++ b/package/python-requests/python-requests.hash
> @@ -1,5 +1,5 @@
>  # md5, sha256 from https://pypi.org/pypi/requests/json
> -md5  796ea875cdae283529c03b9203d9c454  requests-2.28.1.tar.gz
> -sha256  7c5599b102feddaa661c826c56ab4fee28bfd17f5abca1ebbe3e7f19d7c97983  requests-2.28.1.tar.gz
> +md5  09b752e0b0a672d805ae54455c128d42  requests-2.28.2.tar.gz
> +sha256  98b1b2782e3c6c4904938b84c0eb932721069dfdb9134313beff7c83c2df24bf  requests-2.28.2.tar.gz
>  # Locally computed sha256 checksums
>  sha256  09e8a9bcec8067104652c168685ab0931e7868f9c8284b66f5ae6edae5f1130b  LICENSE
> diff --git a/package/python-requests/python-requests.mk b/package/python-requests/python-requests.mk
> index 7a21cca52c..8f9f4b2db4 100644
> --- a/package/python-requests/python-requests.mk
> +++ b/package/python-requests/python-requests.mk
> @@ -4,9 +4,9 @@
>  #
>  ################################################################################
>  
> -PYTHON_REQUESTS_VERSION = 2.28.1
> +PYTHON_REQUESTS_VERSION = 2.28.2
>  PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
> -PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/a5/61/a867851fd5ab77277495a8709ddda0861b28163c4613b011bc00228cc724
> +PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/9d/ee/391076f5937f0a8cdf5e53b701ffc91753e87b07d66bae4a09aa671897bf
>  PYTHON_REQUESTS_SETUP_TYPE = setuptools
>  PYTHON_REQUESTS_LICENSE = Apache-2.0
>  PYTHON_REQUESTS_LICENSE_FILES = LICENSE
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard May 30, 2023, 7:39 p.m. UTC | #4
>>>>> "Aaron" == Aaron Sierra <aaron@bubbl-tek.com> writes:

 > Get explicit compatibility with charset-normalizer 3.x
 > Signed-off-by: Aaron Sierra <aaron@bubbl-tek.com>

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/python-requests/python-requests.hash b/package/python-requests/python-requests.hash
index 1383e680d5..b6f696000b 100644
--- a/package/python-requests/python-requests.hash
+++ b/package/python-requests/python-requests.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/requests/json
-md5  796ea875cdae283529c03b9203d9c454  requests-2.28.1.tar.gz
-sha256  7c5599b102feddaa661c826c56ab4fee28bfd17f5abca1ebbe3e7f19d7c97983  requests-2.28.1.tar.gz
+md5  09b752e0b0a672d805ae54455c128d42  requests-2.28.2.tar.gz
+sha256  98b1b2782e3c6c4904938b84c0eb932721069dfdb9134313beff7c83c2df24bf  requests-2.28.2.tar.gz
 # Locally computed sha256 checksums
 sha256  09e8a9bcec8067104652c168685ab0931e7868f9c8284b66f5ae6edae5f1130b  LICENSE
diff --git a/package/python-requests/python-requests.mk b/package/python-requests/python-requests.mk
index 7a21cca52c..8f9f4b2db4 100644
--- a/package/python-requests/python-requests.mk
+++ b/package/python-requests/python-requests.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_REQUESTS_VERSION = 2.28.1
+PYTHON_REQUESTS_VERSION = 2.28.2
 PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
-PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/a5/61/a867851fd5ab77277495a8709ddda0861b28163c4613b011bc00228cc724
+PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/9d/ee/391076f5937f0a8cdf5e53b701ffc91753e87b07d66bae4a09aa671897bf
 PYTHON_REQUESTS_SETUP_TYPE = setuptools
 PYTHON_REQUESTS_LICENSE = Apache-2.0
 PYTHON_REQUESTS_LICENSE_FILES = LICENSE