diff mbox series

[1/1] package/octave: bump to version 8.1.0

Message ID 20230315061415.1709900-1-ju.o@free.fr
State Accepted
Headers show
Series [1/1] package/octave: bump to version 8.1.0 | expand

Commit Message

Julien Olivain March 15, 2023, 6:14 a.m. UTC
For change log, see:
https://octave.org/NEWS-8.html

Notable changes in this commit:
- the package patch was rebased and updated for this new version
- a comment in .hash file about signature verification is added
- the pcre dependency is replaced by pcre2, following the upstream
  package recommendation and preference. See:
  https://octave.org/NEWS-8.html#general-improvements
  This change also adds the host-pkgconf as a dependency.

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
Commit tested on branch master at commit 7107a98, with commands:

    make check-package
    ...
    0 warnings generated

    utils/test-pkg -a -p octave
    ...
    45 builds, 35 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed

    support/testing/run-tests \
        -d dl -o output_folder \
        tests.package.test_octave
    ...
    OK

Also tested manually in qemu_aarch64_virt_defconfig by running full
test suite, with command in qemu:

    octave --quiet --eval 'oruntests()'

---
 ...1-Fix-BLAS-library-integer-size-detection.patch | 14 +++++++-------
 package/octave/Config.in                           |  3 +--
 package/octave/octave.hash                         |  6 ++++--
 package/octave/octave.mk                           |  5 +++--
 4 files changed, 15 insertions(+), 13 deletions(-)

Comments

Yann E. MORIN May 13, 2023, 8:45 p.m. UTC | #1
Julien, All,

On 2023-03-15 07:14 +0100, Julien Olivain spake thusly:
> For change log, see:
> https://octave.org/NEWS-8.html
> 
> Notable changes in this commit:
> - the package patch was rebased and updated for this new version
> - a comment in .hash file about signature verification is added
> - the pcre dependency is replaced by pcre2, following the upstream
>   package recommendation and preference. See:
>   https://octave.org/NEWS-8.html#general-improvements
>   This change also adds the host-pkgconf as a dependency.
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> Commit tested on branch master at commit 7107a98, with commands:
> 
>     make check-package
>     ...
>     0 warnings generated
> 
>     utils/test-pkg -a -p octave
>     ...
>     45 builds, 35 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed
> 
>     support/testing/run-tests \
>         -d dl -o output_folder \
>         tests.package.test_octave
>     ...
>     OK
> 
> Also tested manually in qemu_aarch64_virt_defconfig by running full
> test suite, with command in qemu:
> 
>     octave --quiet --eval 'oruntests()'
> 
> ---
>  ...1-Fix-BLAS-library-integer-size-detection.patch | 14 +++++++-------
>  package/octave/Config.in                           |  3 +--
>  package/octave/octave.hash                         |  6 ++++--
>  package/octave/octave.mk                           |  5 +++--
>  4 files changed, 15 insertions(+), 13 deletions(-)
> 
> diff --git a/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch b/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch
> index 3fb609de07..6603295e03 100644
> --- a/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch
> +++ b/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch
> @@ -1,4 +1,4 @@
> -From e4dcfefac4215ee66c3dda5b067dd6d06066b0a2 Mon Sep 17 00:00:00 2001
> +From 75b973373ed2e9a7a30f62dfe330299306ecff75 Mon Sep 17 00:00:00 2001
>  From: Julien Olivain <ju.o@free.fr>
>  Date: Sat, 5 Mar 2022 12:36:09 +0100
>  Subject: [PATCH] Fix BLAS library integer size detection
> @@ -19,22 +19,22 @@ Signed-off-by: Julien Olivain <ju.o@free.fr>
>   1 file changed, 6 insertions(+)
>  
>  diff --git a/configure.ac b/configure.ac
> -index de7a00a330..383ce27b06 100644
> +index 4092e5915d..f4ea2c1987 100644
>  --- a/configure.ac
>  +++ b/configure.ac
> -@@ -781,6 +781,12 @@ if test $ax_blas_ok = no || test $ax_lapack_ok = no; then
> +@@ -757,6 +757,12 @@ if test $ax_blas_ok = no || test $ax_lapack_ok = no; then
>     AC_MSG_ERROR([BLAS and LAPACK libraries are required])
>   fi
>   
>  +if ac_fn_f77_try_run "$LINENO"; then :
> -+  ax_blas_integer_size=8
> ++  ax_cv_blas_integer_size=8
>  +else
> -+  ax_blas_integer_size=4
> ++  ax_cv_blas_integer_size=4
>  +fi
>  +
> - case $ax_blas_integer_size in
> + case $ax_cv_blas_integer_size in
>     4)
>       HAVE_64_BIT_BLAS=no
>  -- 
> -2.36.0
> +2.39.2
>  
> diff --git a/package/octave/Config.in b/package/octave/Config.in
> index 171bdfa156..73e27f65e8 100644
> --- a/package/octave/Config.in
> +++ b/package/octave/Config.in
> @@ -13,8 +13,7 @@ config BR2_PACKAGE_OCTAVE
>  	# used by the "utils/test-pkg" script.
>  	depends on !BR2_TOOLCHAIN_EXTERNAL_BOOTLIN || !BR2_x86_64
>  	select BR2_PACKAGE_OPENBLAS
> -	select BR2_PACKAGE_PCRE
> -	select BR2_PACKAGE_PCRE_UTF
> +	select BR2_PACKAGE_PCRE2
>  	help
>  	  GNU Octave is a high-level language, primarily intended for
>  	  numerical computations. It provides a convenient command
> diff --git a/package/octave/octave.hash b/package/octave/octave.hash
> index 9696f2a00a..f301feb6fd 100644
> --- a/package/octave/octave.hash
> +++ b/package/octave/octave.hash
> @@ -1,3 +1,5 @@
> -# Locally computed
> -sha256  fdb32602252289e068431329add2eed146e6f26301cbb5fc4412f9d972db9475  octave-7.3.0.tar.lz
> +# Locally computed after checking signature
> +# https://ftp.gnu.org/gnu/octave/octave-8.1.0.tar.lz.sig
> +# using key DBD9C84E39FE1AAE99F04446B05F05B75D36644B
> +sha256  79f35c249e5ed71c6cafcf26ef72ffcf4845637093efde309b499a6690154b4f  octave-8.1.0.tar.lz
>  sha256  3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986  COPYING
> diff --git a/package/octave/octave.mk b/package/octave/octave.mk
> index 647f988a3f..63265e7d25 100644
> --- a/package/octave/octave.mk
> +++ b/package/octave/octave.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -OCTAVE_VERSION = 7.3.0
> +OCTAVE_VERSION = 8.1.0
>  OCTAVE_SITE = https://ftp.gnu.org/gnu/octave
>  OCTAVE_SOURCE = octave-$(OCTAVE_VERSION).tar.lz
>  OCTAVE_LICENSE = GPL-3.0+
> @@ -15,8 +15,9 @@ OCTAVE_CONF_OPTS = --disable-java
>  
>  OCTAVE_DEPENDENCIES = \
>  	host-gperf \
> +	host-pkgconf \
>  	openblas \
> -	pcre
> +	pcre2
>  
>  ifeq ($(BR2_PACKAGE_READLINE),y)
>  OCTAVE_CONF_OPTS += --enable-readline
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch b/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch
index 3fb609de07..6603295e03 100644
--- a/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch
+++ b/package/octave/0001-Fix-BLAS-library-integer-size-detection.patch
@@ -1,4 +1,4 @@ 
-From e4dcfefac4215ee66c3dda5b067dd6d06066b0a2 Mon Sep 17 00:00:00 2001
+From 75b973373ed2e9a7a30f62dfe330299306ecff75 Mon Sep 17 00:00:00 2001
 From: Julien Olivain <ju.o@free.fr>
 Date: Sat, 5 Mar 2022 12:36:09 +0100
 Subject: [PATCH] Fix BLAS library integer size detection
@@ -19,22 +19,22 @@  Signed-off-by: Julien Olivain <ju.o@free.fr>
  1 file changed, 6 insertions(+)
 
 diff --git a/configure.ac b/configure.ac
-index de7a00a330..383ce27b06 100644
+index 4092e5915d..f4ea2c1987 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -781,6 +781,12 @@ if test $ax_blas_ok = no || test $ax_lapack_ok = no; then
+@@ -757,6 +757,12 @@ if test $ax_blas_ok = no || test $ax_lapack_ok = no; then
    AC_MSG_ERROR([BLAS and LAPACK libraries are required])
  fi
  
 +if ac_fn_f77_try_run "$LINENO"; then :
-+  ax_blas_integer_size=8
++  ax_cv_blas_integer_size=8
 +else
-+  ax_blas_integer_size=4
++  ax_cv_blas_integer_size=4
 +fi
 +
- case $ax_blas_integer_size in
+ case $ax_cv_blas_integer_size in
    4)
      HAVE_64_BIT_BLAS=no
 -- 
-2.36.0
+2.39.2
 
diff --git a/package/octave/Config.in b/package/octave/Config.in
index 171bdfa156..73e27f65e8 100644
--- a/package/octave/Config.in
+++ b/package/octave/Config.in
@@ -13,8 +13,7 @@  config BR2_PACKAGE_OCTAVE
 	# used by the "utils/test-pkg" script.
 	depends on !BR2_TOOLCHAIN_EXTERNAL_BOOTLIN || !BR2_x86_64
 	select BR2_PACKAGE_OPENBLAS
-	select BR2_PACKAGE_PCRE
-	select BR2_PACKAGE_PCRE_UTF
+	select BR2_PACKAGE_PCRE2
 	help
 	  GNU Octave is a high-level language, primarily intended for
 	  numerical computations. It provides a convenient command
diff --git a/package/octave/octave.hash b/package/octave/octave.hash
index 9696f2a00a..f301feb6fd 100644
--- a/package/octave/octave.hash
+++ b/package/octave/octave.hash
@@ -1,3 +1,5 @@ 
-# Locally computed
-sha256  fdb32602252289e068431329add2eed146e6f26301cbb5fc4412f9d972db9475  octave-7.3.0.tar.lz
+# Locally computed after checking signature
+# https://ftp.gnu.org/gnu/octave/octave-8.1.0.tar.lz.sig
+# using key DBD9C84E39FE1AAE99F04446B05F05B75D36644B
+sha256  79f35c249e5ed71c6cafcf26ef72ffcf4845637093efde309b499a6690154b4f  octave-8.1.0.tar.lz
 sha256  3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986  COPYING
diff --git a/package/octave/octave.mk b/package/octave/octave.mk
index 647f988a3f..63265e7d25 100644
--- a/package/octave/octave.mk
+++ b/package/octave/octave.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-OCTAVE_VERSION = 7.3.0
+OCTAVE_VERSION = 8.1.0
 OCTAVE_SITE = https://ftp.gnu.org/gnu/octave
 OCTAVE_SOURCE = octave-$(OCTAVE_VERSION).tar.lz
 OCTAVE_LICENSE = GPL-3.0+
@@ -15,8 +15,9 @@  OCTAVE_CONF_OPTS = --disable-java
 
 OCTAVE_DEPENDENCIES = \
 	host-gperf \
+	host-pkgconf \
 	openblas \
-	pcre
+	pcre2
 
 ifeq ($(BR2_PACKAGE_READLINE),y)
 OCTAVE_CONF_OPTS += --enable-readline