diff mbox series

[1/1] Revert "package/pkg-autotools: force cross compiling"

Message ID 20230308174753.9766-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] Revert "package/pkg-autotools: force cross compiling" | expand

Commit Message

Fabrice Fontaine March 8, 2023, 5:47 p.m. UTC
This reverts commit 83e06196ab2193b73b4d7c1decc12bdd654a91e1 which
raises the following build failure with thttpd or wipe:

configure: warning: cross_compiling=yes: invalid host type
loading site script /dev/null
creating cache ./config.cache
configure: error: can only configure for one host and one target at a time

Fixes:
 - http://autobuild.buildroot.org/results/e2156c3747b37d0ec2559a67f2f468ad42a20dbc
 - http://autobuild.buildroot.org/results/a356dd0cd1fb4c9a1b9d6a4cbad4ae2a34dbb562

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/pkg-autotools.mk | 2 --
 1 file changed, 2 deletions(-)

Comments

Peter Korsgaard March 8, 2023, 8:32 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

Hi,

 > This reverts commit 83e06196ab2193b73b4d7c1decc12bdd654a91e1 which
 > raises the following build failure with thttpd or wipe:

 > configure: warning: cross_compiling=yes: invalid host type
 > loading site script /dev/null
 > creating cache ./config.cache
 > configure: error: can only configure for one host and one target at a time

 > Fixes:
 >  - http://autobuild.buildroot.org/results/e2156c3747b37d0ec2559a67f2f468ad42a20dbc
 >  - http://autobuild.buildroot.org/results/a356dd0cd1fb4c9a1b9d6a4cbad4ae2a34dbb562

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

I was afraid of this. I guess it is because thttpd and wipe use really
old autotools versions:

output/build/thttpd-2.29/configure --version
configure generated by autoconf version 2.13

output/build/wipe-2.3.1/configure --version
configure generated by autoconf version 2.13

I guess a safer approach is to only pass it for the packages known to be
affected by the issue. Daniel, care to send a patch for that?

Committed, thanks.
diff mbox series

Patch

diff --git a/package/pkg-autotools.mk b/package/pkg-autotools.mk
index aac80369e0..717ff81593 100644
--- a/package/pkg-autotools.mk
+++ b/package/pkg-autotools.mk
@@ -195,7 +195,6 @@  define $(2)_CONFIGURE_CMDS
 		--disable-documentation \
 		--with-xmlto=no \
 		--with-fop=no \
-		cross_compiling=yes \
 		$$(if $$($$(PKG)_OVERRIDE_SRCDIR),,--disable-dependency-tracking) \
 		--enable-ipv6 \
 		$$(NLS_OPTS) \
@@ -230,7 +229,6 @@  define $(2)_CONFIGURE_CMDS
 		--with-xmlto=no \
 		--with-fop=no \
 		--disable-nls \
-		cross_compiling=no \
 		$$(if $$($$(PKG)_OVERRIDE_SRCDIR),,--disable-dependency-tracking) \
 		$$(QUIET) $$($$(PKG)_CONF_OPTS) \
 	)