diff mbox series

[next,1/1] package/unrar: bump to version 6.2.6

Message ID 20230306184050.7107-1-ju.o@free.fr
State Accepted
Headers show
Series [next,1/1] package/unrar: bump to version 6.2.6 | expand

Commit Message

Julien Olivain March 6, 2023, 6:40 p.m. UTC
Uptream does not provide a change log.

The package now needs a C++11 compiler. For example, the source file
"blake2s.hpp" is using the "constexpr" keyword.

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
Patch tested on branch next at commit b793f3a, with commands:

    make check-package
    ...
    0 warnings generated

    utils/test-pkg -a -p unrar
    ...
    45 builds, 3 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed
---
 package/unrar/Config.in  | 4 +++-
 package/unrar/unrar.hash | 2 +-
 package/unrar/unrar.mk   | 4 ++--
 3 files changed, 6 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni March 12, 2023, 12:30 p.m. UTC | #1
On Mon,  6 Mar 2023 19:40:50 +0100
Julien Olivain <ju.o@free.fr> wrote:

> Uptream does not provide a change log.
> 
> The package now needs a C++11 compiler. For example, the source file
> "blake2s.hpp" is using the "constexpr" keyword.
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>
> ---
> Patch tested on branch next at commit b793f3a, with commands:

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/unrar/Config.in b/package/unrar/Config.in
index 29696c35aa..8a3def699b 100644
--- a/package/unrar/Config.in
+++ b/package/unrar/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_PACKAGE_UNRAR
 	bool "unrar"
 	depends on BR2_INSTALL_LIBSTDCPP
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on BR2_USE_WCHAR
 	help
@@ -8,6 +9,7 @@  config BR2_PACKAGE_UNRAR
 
 	  http://www.rarlab.com/rar_add.htm
 
-comment "unrar needs a toolchain w/ C++, wchar, threads"
+comment "unrar needs a toolchain w/ C++, wchar, threads, gcc >= 4.8"
 	depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP \
+		|| !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
 		|| !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/unrar/unrar.hash b/package/unrar/unrar.hash
index 40e05a1a32..bc8f986875 100644
--- a/package/unrar/unrar.hash
+++ b/package/unrar/unrar.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  de75b6136958173fdfc530d38a0145b72342cf0d3842bf7bb120d336602d88ed  unrarsrc-6.1.7.tar.gz
+sha256  0c2d4cbc8b34d0e3bec7b474e0f52bbcc6c4320ec089b4141223ee355f63c318  unrarsrc-6.2.6.tar.gz
 sha256  6ecc1687808b7d66b24f874755abfed7464d9751ed0001cd4e8e5d9bf397ff8a  license.txt
diff --git a/package/unrar/unrar.mk b/package/unrar/unrar.mk
index fee9fb753b..f59d199558 100644
--- a/package/unrar/unrar.mk
+++ b/package/unrar/unrar.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-UNRAR_VERSION = 6.1.7
+UNRAR_VERSION = 6.2.6
 UNRAR_SOURCE = unrarsrc-$(UNRAR_VERSION).tar.gz
 UNRAR_SITE = https://www.rarlab.com/rar
 UNRAR_LICENSE = unrar
@@ -13,7 +13,7 @@  UNRAR_CPE_ID_VENDOR = rarlab
 
 define UNRAR_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) CXX="$(TARGET_CXX)" STRIP="/bin/true" \
-		CXXFLAGS="$(TARGET_CXXFLAGS) -pthread" \
+		CXXFLAGS="$(TARGET_CXXFLAGS) -pthread -std=c++11" \
 		LDFLAGS="$(TARGET_LDFLAGS) -pthread" -C $(@D)
 endef