diff mbox series

[1/1] package/bash: fix naming of target-finalize-hook

Message ID 20230303093754.2180686-1-sebastian.weyer@smile.fr
State Accepted
Headers show
Series [1/1] package/bash: fix naming of target-finalize-hook | expand

Commit Message

Sebastian Weyer March 3, 2023, 9:37 a.m. UTC
When the target-finalize-hook for bash was added in commit
311c9eebc4dcfb764e3a7082706daf68e0603188 in order to write bash into
/etc/shells, it was done at the same time as for package/mksh and it was
incorrectly copied and MKSH still appeared in the name of the hook.

The hook is now correctly named BASH_ADD_BASH_TO_SHELLS

Signed-off-by: Sebastian Weyer <sebastian.weyer@smile.fr>
---
 package/bash/bash.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard March 5, 2023, 6:22 p.m. UTC | #1
>>>>> "Sebastian" == Sebastian Weyer <sebastian.weyer@smile.fr> writes:

 > When the target-finalize-hook for bash was added in commit
 > 311c9eebc4dcfb764e3a7082706daf68e0603188 in order to write bash into
 > /etc/shells, it was done at the same time as for package/mksh and it was
 > incorrectly copied and MKSH still appeared in the name of the hook.

 > The hook is now correctly named BASH_ADD_BASH_TO_SHELLS

 > Signed-off-by: Sebastian Weyer <sebastian.weyer@smile.fr>

Committed, thanks.
Peter Korsgaard March 15, 2023, 1:06 p.m. UTC | #2
>>>>> "Sebastian" == Sebastian Weyer <sebastian.weyer@smile.fr> writes:

 > When the target-finalize-hook for bash was added in commit
 > 311c9eebc4dcfb764e3a7082706daf68e0603188 in order to write bash into
 > /etc/shells, it was done at the same time as for package/mksh and it was
 > incorrectly copied and MKSH still appeared in the name of the hook.

 > The hook is now correctly named BASH_ADD_BASH_TO_SHELLS

 > Signed-off-by: Sebastian Weyer <sebastian.weyer@smile.fr>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index ec5e2d722f..9a73ed8c36 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -62,10 +62,10 @@  endif
 
 # Add /bin/bash to /etc/shells otherwise some login tools like dropbear
 # can reject the user connection. See man shells.
-define BASH_ADD_MKSH_TO_SHELLS
+define BASH_ADD_BASH_TO_SHELLS
 	grep -qsE '^/bin/bash$$' $(TARGET_DIR)/etc/shells \
 		|| echo "/bin/bash" >> $(TARGET_DIR)/etc/shells
 endef
-BASH_TARGET_FINALIZE_HOOKS += BASH_ADD_MKSH_TO_SHELLS
+BASH_TARGET_FINALIZE_HOOKS += BASH_ADD_BASH_TO_SHELLS
 
 $(eval $(autotools-package))