diff mbox series

[1/4] package/gensio: add libglib2 optional dependency

Message ID 20230302175350.183840-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/4] package/gensio: add libglib2 optional dependency | expand

Commit Message

Fabrice Fontaine March 2, 2023, 5:53 p.m. UTC
libglib2 is an optional dependency which is enabled by default since
version 2.3.0 and
https://github.com/cminyard/gensio/commit/866924d69dabe8b8a981e19bd745d5c84e529881

Handle it properly to avoid the following build failure since bump to
version 2.5.2 in commit 5bb747f0b783a0d3f1712350ca3277263045b299:

sparc64-buildroot-linux-gnu-gcc: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/glib-2.0'

Fixes:
 - http://autobuild.buildroot.org/results/3602c5cc2aff668211fd8e6eeab778b3fe287246

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gensio/gensio.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard March 7, 2023, 9:06 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > libglib2 is an optional dependency which is enabled by default since
 > version 2.3.0 and
 > https://github.com/cminyard/gensio/commit/866924d69dabe8b8a981e19bd745d5c84e529881

 > Handle it properly to avoid the following build failure since bump to
 > version 2.5.2 in commit 5bb747f0b783a0d3f1712350ca3277263045b299:

 > sparc64-buildroot-linux-gnu-gcc: ERROR: unsafe header/library path
 > used in cross-compilation: '-I/usr/include/glib-2.0'

 > Fixes:
 >  - http://autobuild.buildroot.org/results/3602c5cc2aff668211fd8e6eeab778b3fe287246

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 15, 2023, 2:40 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > libglib2 is an optional dependency which is enabled by default since
 > version 2.3.0 and
 > https://github.com/cminyard/gensio/commit/866924d69dabe8b8a981e19bd745d5c84e529881

 > Handle it properly to avoid the following build failure since bump to
 > version 2.5.2 in commit 5bb747f0b783a0d3f1712350ca3277263045b299:

 > sparc64-buildroot-linux-gnu-gcc: ERROR: unsafe header/library path
 > used in cross-compilation: '-I/usr/include/glib-2.0'

 > Fixes:
 >  - http://autobuild.buildroot.org/results/3602c5cc2aff668211fd8e6eeab778b3fe287246

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.11.x, thanks.
diff mbox series

Patch

diff --git a/package/gensio/gensio.mk b/package/gensio/gensio.mk
index 5538f97b19..dafc0bf5d5 100644
--- a/package/gensio/gensio.mk
+++ b/package/gensio/gensio.mk
@@ -14,6 +14,13 @@  GENSIO_CONF_OPTS = \
 	--without-swig \
 	--without-python
 
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+GENSIO_DEPENDENCIES += host-pkgconf libglib2
+GENSIO_CONF_OPTS += --with-glib
+else
+GENSIO_CONF_OPTS += --without-glib
+endif
+
 ifeq ($(BR2_PACKAGE_OPENIPMI),y)
 GENSIO_DEPENDENCIES += openipmi
 GENSIO_CONF_OPTS += --with-openipmi