diff mbox series

[1/1] package/opus: force arm mode instead of Thumb mode

Message ID 20230302175107.32479-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/opus: force arm mode instead of Thumb mode | expand

Commit Message

Fabrice Fontaine March 2, 2023, 5:51 p.m. UTC
Fix the following build failure:

/tmp/cckXvlOO.s:352: Error: selected processor does not support `smull r6,ip,r5,r0' in Thumb mode

Fixes:
 - http://autobuild.buildroot.org/results/fdedcc8f68651ec34417d609b40effbac456c80d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/opus/opus.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard March 5, 2023, 6:27 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure:
 > /tmp/cckXvlOO.s:352: Error: selected processor does not support `smull
 > r6,ip,r5,r0' in Thumb mode

 > Fixes:
 >  - http://autobuild.buildroot.org/results/fdedcc8f68651ec34417d609b40effbac456c80d

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Slightly tweaked comment and committed, thanks.
Peter Korsgaard March 15, 2023, 2:09 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure:
 > /tmp/cckXvlOO.s:352: Error: selected processor does not support `smull r6,ip,r5,r0' in Thumb mode

 > Fixes:
 >  - http://autobuild.buildroot.org/results/fdedcc8f68651ec34417d609b40effbac456c80d

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/opus/opus.mk b/package/opus/opus.mk
index 2fa929c7df..1372711038 100644
--- a/package/opus/opus.mk
+++ b/package/opus/opus.mk
@@ -12,6 +12,13 @@  OPUS_INSTALL_STAGING = YES
 
 OPUS_CFLAGS = $(TARGET_CFLAGS)
 
+# opus has some assembly function that is not present in Thumb mode:
+# Error: selected processor does not support `smull r6,ip,r5,r0' in Thumb mode
+# so, we desactivate Thumb mode
+ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
+OPUS_CFLAGS += -marm
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
 OPUS_CFLAGS += -O0
 endif