diff mbox series

[v5,5/5] package/libgtk3: fix update-icon-cache on empty directory

Message ID 20230227105838.358916-5-thomas.devoogdt@barco.com
State Superseded, archived
Delegated to: Thomas Petazzoni
Headers show
Series [v5,1/5] package/at-spi2-core: bump to version 2.47.1 | expand

Commit Message

Thomas Devoogdt Feb. 27, 2023, 10:58 a.m. UTC
If both, hicolor-icon-theme (selected by libgtk3-demo) and
adwaita-icon-theme is not selected, then the /usr/share/icons
folder is empty, causing find to fail.

Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
v5: 
 - Fixed indentation.
 - Grouped patches.
---
 package/libgtk3/libgtk3.mk | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Adrian Perez de Castro April 24, 2023, 12:14 p.m. UTC | #1
On Mon, 27 Feb 2023 11:58:38 +0100 Thomas Devoogdt <thomas@devoogdt.com> wrote:
> If both, hicolor-icon-theme (selected by libgtk3-demo) and
> adwaita-icon-theme is not selected, then the /usr/share/icons
> folder is empty, causing find to fail.
> 
> Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>

Tested-by: Adrian Perez de Castro <aperez@igalia.com>

> ---
> v5: 
>  - Fixed indentation.
>  - Grouped patches.
> ---
>  package/libgtk3/libgtk3.mk | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/package/libgtk3/libgtk3.mk b/package/libgtk3/libgtk3.mk
> index 2821c7eb52..191e28dda6 100644
> --- a/package/libgtk3/libgtk3.mk
> +++ b/package/libgtk3/libgtk3.mk
> @@ -146,8 +146,9 @@ endef
>  # Create icon-theme.cache for each of the icon directories/themes
>  # It's not strictly necessary but speeds up lookups
>  define LIBGTK3_UPDATE_ICON_CACHE
> -	find $(TARGET_DIR)/usr/share/icons -maxdepth 1 -mindepth 1 -type d \
> -		-exec $(HOST_DIR)/bin/gtk-update-icon-cache {} \;
> +	[ ! -d $(TARGET_DIR)/usr/share/icons ] || \
> +		find $(TARGET_DIR)/usr/share/icons -maxdepth 1 -mindepth 1 -type d \
> +			-exec $(HOST_DIR)/bin/gtk-update-icon-cache {} \;
>  endef
>  LIBGTK3_TARGET_FINALIZE_HOOKS += LIBGTK3_UPDATE_ICON_CACHE
>  
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
> 

Cheers,
—Adrián
Peter Korsgaard June 8, 2023, 8:52 p.m. UTC | #2
>>>>> "Adrian" == Adrian Perez de Castro <aperez@igalia.com> writes:

 > On Mon, 27 Feb 2023 11:58:38 +0100 Thomas Devoogdt <thomas@devoogdt.com> wrote:
 >> If both, hicolor-icon-theme (selected by libgtk3-demo) and
 >> adwaita-icon-theme is not selected, then the /usr/share/icons
 >> folder is empty, causing find to fail.
 >> 
 >> Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>

 > Tested-by: Adrian Perez de Castro <aperez@igalia.com>

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libgtk3/libgtk3.mk b/package/libgtk3/libgtk3.mk
index 2821c7eb52..191e28dda6 100644
--- a/package/libgtk3/libgtk3.mk
+++ b/package/libgtk3/libgtk3.mk
@@ -146,8 +146,9 @@  endef
 # Create icon-theme.cache for each of the icon directories/themes
 # It's not strictly necessary but speeds up lookups
 define LIBGTK3_UPDATE_ICON_CACHE
-	find $(TARGET_DIR)/usr/share/icons -maxdepth 1 -mindepth 1 -type d \
-		-exec $(HOST_DIR)/bin/gtk-update-icon-cache {} \;
+	[ ! -d $(TARGET_DIR)/usr/share/icons ] || \
+		find $(TARGET_DIR)/usr/share/icons -maxdepth 1 -mindepth 1 -type d \
+			-exec $(HOST_DIR)/bin/gtk-update-icon-cache {} \;
 endef
 LIBGTK3_TARGET_FINALIZE_HOOKS += LIBGTK3_UPDATE_ICON_CACHE