diff mbox series

[1/1] package/optee-client: fix BR2_PACKAGE_OPTEE_CLIENT_TEEACL

Message ID 20230222220835.355342-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/optee-client: fix BR2_PACKAGE_OPTEE_CLIENT_TEEACL | expand

Commit Message

Fabrice Fontaine Feb. 22, 2023, 10:08 p.m. UTC
Fix typo added by commit 917a961d9c77d5f1aaa47206add9b9ff80e74a82
resulting in the following build failure:

-- Checking for module 'uuid'
--   Package 'uuid', required by 'virtual:world', not found
CMake Error at /tmp/instance-5/output-1/per-package/optee-client/host/share/cmake-3.22/Modules/FindPkgConfig.cmake:603 (message):
  A required package was not found
Call Stack (most recent call first):
  /tmp/instance-5/output-1/per-package/optee-client/host/share/cmake-3.22/Modules/FindPkgConfig.cmake:825 (_pkg_check_modules_internal)
  CMakeLists.txt:43 (pkg_check_modules)

Fixes:
 - http://autobuild.buildroot.org/results/e1c6b5c9e841a003037045b2ff7afd9836e7c640

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/optee-client/optee-client.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 22, 2023, 11:01 p.m. UTC | #1
On Wed, 22 Feb 2023 23:08:35 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fix typo added by commit 917a961d9c77d5f1aaa47206add9b9ff80e74a82
> resulting in the following build failure:
> 
> -- Checking for module 'uuid'
> --   Package 'uuid', required by 'virtual:world', not found
> CMake Error at /tmp/instance-5/output-1/per-package/optee-client/host/share/cmake-3.22/Modules/FindPkgConfig.cmake:603 (message):
>   A required package was not found
> Call Stack (most recent call first):
>   /tmp/instance-5/output-1/per-package/optee-client/host/share/cmake-3.22/Modules/FindPkgConfig.cmake:825 (_pkg_check_modules_internal)
>   CMakeLists.txt:43 (pkg_check_modules)
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/e1c6b5c9e841a003037045b2ff7afd9836e7c640
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/optee-client/optee-client.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/optee-client/optee-client.mk b/package/optee-client/optee-client.mk
index 311ca191b0..ef113c838f 100644
--- a/package/optee-client/optee-client.mk
+++ b/package/optee-client/optee-client.mk
@@ -27,7 +27,7 @@  OPTEE_CLIENT_CONF_OPTS += -DCFG_TEE_SUPP_PLUGINS=OFF
 endif
 
 ifeq ($(BR2_PACKAGE_OPTEE_CLIENT_TEEACL),y)
-OPTEE_CLIENT_EXT_DEPENDENCIES += host-pkgconf util-linux
+OPTEE_CLIENT_DEPENDENCIES += host-pkgconf util-linux
 OPTEE_CLIENT_CONF_OPTS += -DWITH_TEEACL=ON
 else
 OPTEE_CLIENT_CONF_OPTS += -DWITH_TEEACL=OFF