diff mbox series

[1/1] package/multipath-tools: fix path to kernel headers

Message ID 20230218092943.2598-1-egorenar-dev@posteo.net
State Accepted
Headers show
Series [1/1] package/multipath-tools: fix path to kernel headers | expand

Commit Message

Alexander Egorenkov Feb. 18, 2023, 9:29 a.m. UTC
With change 6b7d47be3b23 ("multipath-tools: Makefiles: simplify code for
include dirs") the Makefile variable 'LINUX_HEADERS_INCDIR' has been replaced
with 'kernel_incdir'.

fpin_handlers.c:355:32: note: each undeclared identifier is reported only once for each function it appears in
fpin_handlers.c:360:37: error: ‘ELS_DTAG_LNK_INTEGRITY’ undeclared (first use in this function)
  360 |                         if (dtag == ELS_DTAG_LNK_INTEGRITY) {
      |                                     ^~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [../Makefile.inc:116: fpin_handlers.o] Error 1

Fixes: http://autobuild.buildroot.net/results/e0f56ef924c13d6b1535fdc350ad8ecc06ea0a58
Signed-off-by: Alexander Egorenkov <egorenar-dev@posteo.net>
---
 package/multipath-tools/multipath-tools.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 21, 2023, 8:37 a.m. UTC | #1
On Sat, 18 Feb 2023 09:29:43 +0000
Alexander Egorenkov <egorenar-dev@posteo.net> wrote:

> With change 6b7d47be3b23 ("multipath-tools: Makefiles: simplify code for
> include dirs") the Makefile variable 'LINUX_HEADERS_INCDIR' has been replaced
> with 'kernel_incdir'.
> 
> fpin_handlers.c:355:32: note: each undeclared identifier is reported only once for each function it appears in
> fpin_handlers.c:360:37: error: ‘ELS_DTAG_LNK_INTEGRITY’ undeclared (first use in this function)
>   360 |                         if (dtag == ELS_DTAG_LNK_INTEGRITY) {
>       |                                     ^~~~~~~~~~~~~~~~~~~~~~
> make[2]: *** [../Makefile.inc:116: fpin_handlers.o] Error 1
> 
> Fixes: http://autobuild.buildroot.net/results/e0f56ef924c13d6b1535fdc350ad8ecc06ea0a58
> Signed-off-by: Alexander Egorenkov <egorenar-dev@posteo.net>
> ---
>  package/multipath-tools/multipath-tools.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/multipath-tools/multipath-tools.mk b/package/multipath-tools/multipath-tools.mk
index 90394fae9fde..23b3cc944267 100644
--- a/package/multipath-tools/multipath-tools.mk
+++ b/package/multipath-tools/multipath-tools.mk
@@ -22,7 +22,7 @@  MULTIPATH_TOOLS_CPE_ID_VENDOR = opensvc
 
 MULTIPATH_TOOLS_DEPENDENCIES = lvm2 json-c readline udev liburcu libaio host-pkgconf
 MULTIPATH_TOOLS_MAKE_OPTS = \
-	LINUX_HEADERS_INCDIR=$(STAGING_DIR)/usr/include \
+	kernel_incdir=$(STAGING_DIR)/usr/include \
 	LIB="lib" \
 	RUN="run" \
 	OPTFLAGS="" \