diff mbox series

[v1] package/fft_eval: new package

Message ID 20230211163422.25944-1-ps.report@gmx.net
State Accepted
Headers show
Series [v1] package/fft_eval: new package | expand

Commit Message

Peter Seiderer Feb. 11, 2023, 4:34 p.m. UTC
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/Config.in              |  1 +
 package/fft_eval/Config.in     | 13 ++++++++++++
 package/fft_eval/fft_eval.hash |  5 +++++
 package/fft_eval/fft_eval.mk   | 36 ++++++++++++++++++++++++++++++++++
 4 files changed, 55 insertions(+)
 create mode 100644 package/fft_eval/Config.in
 create mode 100644 package/fft_eval/fft_eval.hash
 create mode 100644 package/fft_eval/fft_eval.mk

Comments

Thomas Petazzoni Aug. 10, 2023, 10:07 p.m. UTC | #1
Hello Peter,

On Sat, 11 Feb 2023 17:34:22 +0100
Peter Seiderer <ps.report@gmx.net> wrote:

> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

I have finally reviewed your patch and applied to next, with some changes. See below.

> ---
>  package/Config.in              |  1 +
>  package/fft_eval/Config.in     | 13 ++++++++++++
>  package/fft_eval/fft_eval.hash |  5 +++++
>  package/fft_eval/fft_eval.mk   | 36 ++++++++++++++++++++++++++++++++++
>  4 files changed, 55 insertions(+)
>  create mode 100644 package/fft_eval/Config.in
>  create mode 100644 package/fft_eval/fft_eval.hash
>  create mode 100644 package/fft_eval/fft_eval.mk

I've renamed from fft_eval to fft-eval, as we prefer - as the separator
in package names these days.

I've added an entry in the DEVELOPERS file as well.


> diff --git a/package/fft_eval/Config.in b/package/fft_eval/Config.in
> new file mode 100644
> index 0000000000..4b6aa9b388
> --- /dev/null
> +++ b/package/fft_eval/Config.in
> @@ -0,0 +1,13 @@
> +config BR2_PACKAGE_FFT_EVAL
> +	bool "fft_eval"
> +	help
> +	  Pogram to aid open source spectrum analyzer development

          ^^ Program

> +	  for Qualcomm/Atheros AR92xx and AR93xx based chipsets.
> +
> +	  It visualizes the FFT data reported by the chips to help
> +	  interpreting and understanding the data.
> +
> +	  Enabel sdl2 and sdl2_ttf for the graphic output tool

          ^^ Enable

> +FFT_EVAL_VERSION = 6a82b383ce79afc4c1ba26ffcf34b15d3e95894b
> +FFT_EVAL_SITE = $(call github,simonwunderlich,FFT_eval,$(FFT_EVAL_VERSION))
> +FFT_EVAL_LICENSE = CC0-1.0 (doc), GPL-2.0-only, OFL-1.1 (LiberationSans-Regular.ttf)
> +FFT_EVAL_LICENSE_FILES = \
> +	LICENSES/CC0-1.0.txt \
> +	LICENSES/GPL-2.0-only.txt \
> +	LICENSES/OFL-1.1.txt
> +
> +FFT_EVAL_CONV_OPTS = CONFIG_fft_eval_json=y
> +FFT_EVAL_TARGETS = fft_eval_json
> +
> +ifeq ($(BR2_PACKAGE_SDL2)$(BR2_PACKAGE_SDL2_TTF),yy)
> +FFT_EVAL_CONV_OPTS += CONFIG_fft_eval_sdl=y
> +FFT_EVAL_DEPENDENCIES += sdl2 sdl2_ttf
> +FFT_EVAL_TARGETS += fft_eval_sdl
> +else
> +FFT_EVAL_CONV_OPTS += CONFIG_fft_eval_sdl=n
> +endif
> +
> +define FFT_EVAL_BUILD_CMDS
> +	$(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS=$(STAGING_DIR)/usr/bin/ $(FFT_EVAL_CONV_OPTS) -C $(@D) all
> +endef
> +
> +define FFT_EVAL_INSTALL_TARGET_CMDS
> +	for i in $(FFT_EVAL_TARGETS); do \
> +		$(INSTALL) -D -m 0755 $(@D)/$$i $(TARGET_DIR)/usr/bin || exit 1; \
> +	done
> +endef

I've use "make install" instead of doing the manual installation here.

Applied to next with those changes. Thanks!

Thomas
Peter Seiderer Aug. 11, 2023, 7:22 p.m. UTC | #2
Hello Thomas,

On Fri, 11 Aug 2023 00:07:38 +0200, Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> Hello Peter,
>
> On Sat, 11 Feb 2023 17:34:22 +0100
> Peter Seiderer <ps.report@gmx.net> wrote:
>
> > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
>
> I have finally reviewed your patch and applied to next, with some changes. See below.
>
> > ---
> >  package/Config.in              |  1 +
> >  package/fft_eval/Config.in     | 13 ++++++++++++
> >  package/fft_eval/fft_eval.hash |  5 +++++
> >  package/fft_eval/fft_eval.mk   | 36 ++++++++++++++++++++++++++++++++++
> >  4 files changed, 55 insertions(+)
> >  create mode 100644 package/fft_eval/Config.in
> >  create mode 100644 package/fft_eval/fft_eval.hash
> >  create mode 100644 package/fft_eval/fft_eval.mk
>
> I've renamed from fft_eval to fft-eval, as we prefer - as the separator
> in package names these days.

O.k.

>
> I've added an entry in the DEVELOPERS file as well.

O.k.

>
>
> > diff --git a/package/fft_eval/Config.in b/package/fft_eval/Config.in
> > new file mode 100644
> > index 0000000000..4b6aa9b388
> > --- /dev/null
> > +++ b/package/fft_eval/Config.in
> > @@ -0,0 +1,13 @@
> > +config BR2_PACKAGE_FFT_EVAL
> > +	bool "fft_eval"
> > +	help
> > +	  Pogram to aid open source spectrum analyzer development
>
>           ^^ Program
>
> > +	  for Qualcomm/Atheros AR92xx and AR93xx based chipsets.
> > +
> > +	  It visualizes the FFT data reported by the chips to help
> > +	  interpreting and understanding the data.
> > +
> > +	  Enabel sdl2 and sdl2_ttf for the graphic output tool
>
>           ^^ Enable

Thanks for fixing my typos ;-)

>
> > +FFT_EVAL_VERSION = 6a82b383ce79afc4c1ba26ffcf34b15d3e95894b
> > +FFT_EVAL_SITE = $(call github,simonwunderlich,FFT_eval,$(FFT_EVAL_VERSION))
> > +FFT_EVAL_LICENSE = CC0-1.0 (doc), GPL-2.0-only, OFL-1.1 (LiberationSans-Regular.ttf)
> > +FFT_EVAL_LICENSE_FILES = \
> > +	LICENSES/CC0-1.0.txt \
> > +	LICENSES/GPL-2.0-only.txt \
> > +	LICENSES/OFL-1.1.txt
> > +
> > +FFT_EVAL_CONV_OPTS = CONFIG_fft_eval_json=y
> > +FFT_EVAL_TARGETS = fft_eval_json
> > +
> > +ifeq ($(BR2_PACKAGE_SDL2)$(BR2_PACKAGE_SDL2_TTF),yy)
> > +FFT_EVAL_CONV_OPTS += CONFIG_fft_eval_sdl=y
> > +FFT_EVAL_DEPENDENCIES += sdl2 sdl2_ttf
> > +FFT_EVAL_TARGETS += fft_eval_sdl
> > +else
> > +FFT_EVAL_CONV_OPTS += CONFIG_fft_eval_sdl=n
> > +endif
> > +
> > +define FFT_EVAL_BUILD_CMDS
> > +	$(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS=$(STAGING_DIR)/usr/bin/ $(FFT_EVAL_CONV_OPTS) -C $(@D) all
> > +endef
> > +
> > +define FFT_EVAL_INSTALL_TARGET_CMDS
> > +	for i in $(FFT_EVAL_TARGETS); do \
> > +		$(INSTALL) -D -m 0755 $(@D)/$$i $(TARGET_DIR)/usr/bin || exit 1; \
> > +	done
> > +endef
>
> I've use "make install" instead of doing the manual installation here.

Looks nicer..., but now the variable FFT_EVAL_TARGETS is unused?

Regards,
Peter

>
> Applied to next with those changes. Thanks!
>
> Thomas
Thomas Petazzoni Aug. 11, 2023, 10:23 p.m. UTC | #3
On Fri, 11 Aug 2023 21:22:20 +0200
Peter Seiderer <ps.report@gmx.net> wrote:

> > I've use "make install" instead of doing the manual installation here.  
> 
> Looks nicer..., but now the variable FFT_EVAL_TARGETS is unused?

Dammit, indeed. One of us needs to send a follow-up patch :-)

Thomas
Yann E. MORIN Aug. 12, 2023, 1:33 p.m. UTC | #4
Thomas, Peter, All,

On 2023-08-12 00:23 +0200, Thomas Petazzoni via buildroot spake thusly:
> On Fri, 11 Aug 2023 21:22:20 +0200
> Peter Seiderer <ps.report@gmx.net> wrote:
> > > I've use "make install" instead of doing the manual installation here.  
> > Looks nicer..., but now the variable FFT_EVAL_TARGETS is unused?
> Dammit, indeed. One of us needs to send a follow-up patch :-)

I've pushed a fixup commit, thanks!

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 511e691ed3..aa19164802 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2206,6 +2206,7 @@  menu "Miscellaneous"
 	source "package/collectl/Config.in"
 	source "package/domoticz/Config.in"
 	source "package/empty/Config.in"
+	source "package/fft_eval/Config.in"
 	source "package/gitlab-runner/Config.in"
 	source "package/gnuradio/Config.in"
 	source "package/googlefontdirectory/Config.in"
diff --git a/package/fft_eval/Config.in b/package/fft_eval/Config.in
new file mode 100644
index 0000000000..4b6aa9b388
--- /dev/null
+++ b/package/fft_eval/Config.in
@@ -0,0 +1,13 @@ 
+config BR2_PACKAGE_FFT_EVAL
+	bool "fft_eval"
+	help
+	  Pogram to aid open source spectrum analyzer development
+	  for Qualcomm/Atheros AR92xx and AR93xx based chipsets.
+
+	  It visualizes the FFT data reported by the chips to help
+	  interpreting and understanding the data.
+
+	  Enabel sdl2 and sdl2_ttf for the graphic output tool
+	  fft_eval_sdl.
+
+	  https://github.com/simonwunderlich/FFT_eval
diff --git a/package/fft_eval/fft_eval.hash b/package/fft_eval/fft_eval.hash
new file mode 100644
index 0000000000..ab09e916e7
--- /dev/null
+++ b/package/fft_eval/fft_eval.hash
@@ -0,0 +1,5 @@ 
+# Locally calculated
+sha256  154f99c3567835bbbbc9ec4c58bc79961f9fa5342effb6f0bc41475fc9a6d11f  fft_eval-6a82b383ce79afc4c1ba26ffcf34b15d3e95894b.tar.gz
+sha256  6a573fb2f9082662978cf21fb153096df0a1981deaea7dbc10a11046fe005d9f  LICENSES/CC0-1.0.txt
+sha256  d1cf0896da7045d841fe45b0991cf35540bac1a17b5d11f4afcf8fcb950246b5  LICENSES/GPL-2.0-only.txt
+sha256  797832eda5ff4360a10fee3be94a3250995e76423b79675c9c44204c37ca492d  LICENSES/OFL-1.1.txt
diff --git a/package/fft_eval/fft_eval.mk b/package/fft_eval/fft_eval.mk
new file mode 100644
index 0000000000..383b5f9a51
--- /dev/null
+++ b/package/fft_eval/fft_eval.mk
@@ -0,0 +1,36 @@ 
+################################################################################
+#
+# fft_eval
+#
+################################################################################
+
+FFT_EVAL_VERSION = 6a82b383ce79afc4c1ba26ffcf34b15d3e95894b
+FFT_EVAL_SITE = $(call github,simonwunderlich,FFT_eval,$(FFT_EVAL_VERSION))
+FFT_EVAL_LICENSE = CC0-1.0 (doc), GPL-2.0-only, OFL-1.1 (LiberationSans-Regular.ttf)
+FFT_EVAL_LICENSE_FILES = \
+	LICENSES/CC0-1.0.txt \
+	LICENSES/GPL-2.0-only.txt \
+	LICENSES/OFL-1.1.txt
+
+FFT_EVAL_CONV_OPTS = CONFIG_fft_eval_json=y
+FFT_EVAL_TARGETS = fft_eval_json
+
+ifeq ($(BR2_PACKAGE_SDL2)$(BR2_PACKAGE_SDL2_TTF),yy)
+FFT_EVAL_CONV_OPTS += CONFIG_fft_eval_sdl=y
+FFT_EVAL_DEPENDENCIES += sdl2 sdl2_ttf
+FFT_EVAL_TARGETS += fft_eval_sdl
+else
+FFT_EVAL_CONV_OPTS += CONFIG_fft_eval_sdl=n
+endif
+
+define FFT_EVAL_BUILD_CMDS
+	$(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS=$(STAGING_DIR)/usr/bin/ $(FFT_EVAL_CONV_OPTS) -C $(@D) all
+endef
+
+define FFT_EVAL_INSTALL_TARGET_CMDS
+	for i in $(FFT_EVAL_TARGETS); do \
+		$(INSTALL) -D -m 0755 $(@D)/$$i $(TARGET_DIR)/usr/bin || exit 1; \
+	done
+endef
+
+$(eval $(generic-package))