diff mbox series

[v2,1/1] package/postgresql: add lz4 and zstd support

Message ID 20230208071226.33697-1-fido_max@inbox.ru
State Accepted
Headers show
Series [v2,1/1] package/postgresql: add lz4 and zstd support | expand

Commit Message

Maxim Kochetkov Feb. 8, 2023, 7:12 a.m. UTC
PostgreSQL has optional compression support (LZ4 and Zstandard).
So enable it if libraries are available.

Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
---
 package/postgresql/postgresql.mk | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Thomas Petazzoni Feb. 20, 2023, 10:32 p.m. UTC | #1
On Wed,  8 Feb 2023 10:12:26 +0300
Maxim Kochetkov via buildroot <buildroot@buildroot.org> wrote:

> PostgreSQL has optional compression support (LZ4 and Zstandard).
> So enable it if libraries are available.
> 
> Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
> ---
>  package/postgresql/postgresql.mk | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
index 2ffcac6595..0fb0e01153 100644
--- a/package/postgresql/postgresql.mk
+++ b/package/postgresql/postgresql.mk
@@ -91,6 +91,20 @@  else
 POSTGRESQL_CONF_OPTS += --without-libxml
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+POSTGRESQL_DEPENDENCIES += zstd
+POSTGRESQL_CONF_OPTS += --with-zstd
+else
+POSTGRESQL_CONF_OPTS += --without-zstd
+endif
+
+ifeq ($(BR2_PACKAGE_LZ4),y)
+POSTGRESQL_DEPENDENCIES += lz4
+POSTGRESQL_CONF_OPTS += --with-lz4
+else
+POSTGRESQL_CONF_OPTS += --without-lz4
+endif
+
 # required for postgresql.service Type=notify
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 POSTGRESQL_DEPENDENCIES += systemd