diff mbox series

[1/2] package/pkg-generic.mk: require git on the host for packages using cargo/go vendoring

Message ID 20230207170040.3503236-1-peter@korsgaard.com
State Accepted
Headers show
Series [1/2] package/pkg-generic.mk: require git on the host for packages using cargo/go vendoring | expand

Commit Message

Peter Korsgaard Feb. 7, 2023, 5 p.m. UTC
The vendoring done for cargo / go packages (may) need git, so ensure we
check for it in dependencies, similar to how it is done for packages
directly using git.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/pkg-generic.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Thomas Petazzoni Feb. 7, 2023, 10:06 p.m. UTC | #1
On Tue,  7 Feb 2023 18:00:39 +0100
Peter Korsgaard <peter@korsgaard.com> wrote:

> The vendoring done for cargo / go packages (may) need git, so ensure we
> check for it in dependencies, similar to how it is done for packages
> directly using git.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  package/pkg-generic.mk | 7 +++++++
>  1 file changed, 7 insertions(+)

Both applied, thanks!

Thomas
Peter Korsgaard Feb. 28, 2023, 3:52 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > The vendoring done for cargo / go packages (may) need git, so ensure we
 > check for it in dependencies, similar to how it is done for packages
 > directly using git.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2022.11.x and 2022.02.x, thanks.
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 5d618c6b39..82187d7db9 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -1250,6 +1250,13 @@  else ifeq ($$($(2)_SITE_METHOD),cvs)
 DL_TOOLS_DEPENDENCIES += cvs
 endif # SITE_METHOD
 
+# cargo/go vendoring (may) need git
+ifeq ($$($(2)_DOWNLOAD_POST_PROCESS),cargo)
+DL_TOOLS_DEPENDENCIES += git
+else ifeq ($$($(2)_DOWNLOAD_POST_PROCESS),go)
+DL_TOOLS_DEPENDENCIES += git
+endif
+
 DL_TOOLS_DEPENDENCIES += $$(call extractor-system-dependency,$$($(2)_SOURCE))
 
 # Ensure all virtual targets are PHONY. Listed alphabetically.