diff mbox series

[1/1] package/fluent-bit: fix openssl dependency

Message ID 20230205145036.654667-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/fluent-bit: fix openssl dependency | expand

Commit Message

Fabrice Fontaine Feb. 5, 2023, 2:50 p.m. UTC
Fix the following build failure raised since the addition of the package
in commit 6a0f7c39bcb48fc13aa2ce3fc4996baf1be66483:

Makefile:576: *** libopenssl is in the dependency chain of fluent-bit that has added it to its _DEPENDENCIES variable without selecting it or depending on it from Config.in.  Stop.

Fixes:
 - http://autobuild.buildroot.org/results/9c3b8e19063f7587877fdb0598739b55abccb3e8

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/fluent-bit/fluent-bit.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN Feb. 5, 2023, 3:04 p.m. UTC | #1
Fabrice, All,

On 2023-02-05 15:50 +0100, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since the addition of the package
> in commit 6a0f7c39bcb48fc13aa2ce3fc4996baf1be66483:
> 
> Makefile:576: *** libopenssl is in the dependency chain of fluent-bit that has added it to its _DEPENDENCIES variable without selecting it or depending on it from Config.in.  Stop.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/9c3b8e19063f7587877fdb0598739b55abccb3e8
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Nice catch, applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/fluent-bit/fluent-bit.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/fluent-bit/fluent-bit.mk b/package/fluent-bit/fluent-bit.mk
> index 879437e5f4..13077e53cc 100644
> --- a/package/fluent-bit/fluent-bit.mk
> +++ b/package/fluent-bit/fluent-bit.mk
> @@ -10,7 +10,7 @@ FLUENT_BIT_LICENSE = Apache-2.0
>  FLUENT_BIT_LICENSE_FILES = LICENSE
>  FLUENT_BIT_CPE_ID_VENDOR = treasuredata
>  FLUENT_BIT_CPE_ID_PRODUCT = fluent_bit
> -FLUENT_BIT_DEPENDENCIES = host-bison host-flex libyaml libopenssl
> +FLUENT_BIT_DEPENDENCIES = host-bison host-flex libyaml openssl
>  
>  FLUENT_BIT_CONF_OPTS += \
>  	-DFLB_DEBUG=No \
> -- 
> 2.39.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/fluent-bit/fluent-bit.mk b/package/fluent-bit/fluent-bit.mk
index 879437e5f4..13077e53cc 100644
--- a/package/fluent-bit/fluent-bit.mk
+++ b/package/fluent-bit/fluent-bit.mk
@@ -10,7 +10,7 @@  FLUENT_BIT_LICENSE = Apache-2.0
 FLUENT_BIT_LICENSE_FILES = LICENSE
 FLUENT_BIT_CPE_ID_VENDOR = treasuredata
 FLUENT_BIT_CPE_ID_PRODUCT = fluent_bit
-FLUENT_BIT_DEPENDENCIES = host-bison host-flex libyaml libopenssl
+FLUENT_BIT_DEPENDENCIES = host-bison host-flex libyaml openssl
 
 FLUENT_BIT_CONF_OPTS += \
 	-DFLB_DEBUG=No \