diff mbox series

[1/1] package/gst1-plugins-bad: add new va option

Message ID 20230205042232.1014672-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/gst1-plugins-bad: add new va option | expand

Commit Message

James Hilliard Feb. 5, 2023, 4:22 a.m. UTC
This option enables va plugin support.

These plugins are vaapi based encoders/decoders that are eventually
intended to replace the legacy vaapi plugins.

Details:
https://gstreamer.freedesktop.org/documentation/va/index.html

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/gstreamer1/gst1-plugins-bad/Config.in         | 11 +++++++++++
 .../gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk   | 10 ++++++++++
 2 files changed, 21 insertions(+)

Comments

Yann E. MORIN Feb. 5, 2023, 12:36 p.m. UTC | #1
James, All,

On 2023-02-04 21:22 -0700, James Hilliard spake thusly:
> This option enables va plugin support.
> 
> These plugins are vaapi based encoders/decoders that are eventually
> intended to replace the legacy vaapi plugins.
> 
> Details:
> https://gstreamer.freedesktop.org/documentation/va/index.html
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/gstreamer1/gst1-plugins-bad/Config.in         | 11 +++++++++++
>  .../gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk   | 10 ++++++++++
>  2 files changed, 21 insertions(+)
> 
> diff --git a/package/gstreamer1/gst1-plugins-bad/Config.in b/package/gstreamer1/gst1-plugins-bad/Config.in
> index bcb4cb1545..1e89cd124f 100644
> --- a/package/gstreamer1/gst1-plugins-bad/Config.in
> +++ b/package/gstreamer1/gst1-plugins-bad/Config.in
> @@ -629,6 +629,17 @@ comment "uvch264 needs a toolchain w/ threads, wchar, gcc >= 4.9"
>  	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
>  		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
>  
> +config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VA
> +	bool "va"
> +	depends on !BR2_STATIC_LIBS # libva
> +	depends on BR2_TOOLCHAIN_HAS_THREADS # libva
> +	select BR2_PACKAGE_LIBVA
> +	help
> +	  VA-API new plugin
> +
> +comment "va needs a toolchain w/ threads, dynamic library"
> +	depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
> +
>  config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VOAACENC
>  	bool "voaacenc"
>  	select BR2_PACKAGE_VO_AACENC
> diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
> index 8f11ce6b37..dfe1f1c9eb 100644
> --- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
> +++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
> @@ -745,6 +745,16 @@ else
>  GST1_PLUGINS_BAD_CONF_OPTS += -Duvch264=disabled
>  endif
>  
> +ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VA),y)
> +GST1_PLUGINS_BAD_CONF_OPTS += -Dva=enabled
> +GST1_PLUGINS_BAD_DEPENDENCIES += libva
> +ifeq ($(BR2_PACKAGE_LIBDRM),y)
> +GST1_PLUGINS_BAD_DEPENDENCIES += libdrm
> +endif
> +else
> +GST1_PLUGINS_BAD_CONF_OPTS += -Dva=disabled
> +endif
> +
>  ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VOAACENC),y)
>  GST1_PLUGINS_BAD_CONF_OPTS += -Dvoaacenc=enabled
>  GST1_PLUGINS_BAD_DEPENDENCIES += vo-aacenc
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/gstreamer1/gst1-plugins-bad/Config.in b/package/gstreamer1/gst1-plugins-bad/Config.in
index bcb4cb1545..1e89cd124f 100644
--- a/package/gstreamer1/gst1-plugins-bad/Config.in
+++ b/package/gstreamer1/gst1-plugins-bad/Config.in
@@ -629,6 +629,17 @@  comment "uvch264 needs a toolchain w/ threads, wchar, gcc >= 4.9"
 	depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VA
+	bool "va"
+	depends on !BR2_STATIC_LIBS # libva
+	depends on BR2_TOOLCHAIN_HAS_THREADS # libva
+	select BR2_PACKAGE_LIBVA
+	help
+	  VA-API new plugin
+
+comment "va needs a toolchain w/ threads, dynamic library"
+	depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VOAACENC
 	bool "voaacenc"
 	select BR2_PACKAGE_VO_AACENC
diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
index 8f11ce6b37..dfe1f1c9eb 100644
--- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
+++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
@@ -745,6 +745,16 @@  else
 GST1_PLUGINS_BAD_CONF_OPTS += -Duvch264=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VA),y)
+GST1_PLUGINS_BAD_CONF_OPTS += -Dva=enabled
+GST1_PLUGINS_BAD_DEPENDENCIES += libva
+ifeq ($(BR2_PACKAGE_LIBDRM),y)
+GST1_PLUGINS_BAD_DEPENDENCIES += libdrm
+endif
+else
+GST1_PLUGINS_BAD_CONF_OPTS += -Dva=disabled
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_VOAACENC),y)
 GST1_PLUGINS_BAD_CONF_OPTS += -Dvoaacenc=enabled
 GST1_PLUGINS_BAD_DEPENDENCIES += vo-aacenc