diff mbox series

package/python-pytest: remove runtime dependency on python-toml

Message ID 20230202152743.3916949-1-arnout@mind.be
State Accepted
Headers show
Series package/python-pytest: remove runtime dependency on python-toml | expand

Commit Message

Arnout Vandecappelle Feb. 2, 2023, 3:27 p.m. UTC
Since version 7.2 [1], with Python 3.11+ pytest no longer uses tomli to
parse pyproject.toml but instead uses tomllib which is part of Python
itself [2]. Note that toml was replaced with tomli in version 7.0, so
the dependency was anyway incorrect.

Note that tomllib is unconditionally installed as part of Python 3.11,
there is no PYTHON3_LIBTOML option or anything like that that needs to
be selected.

[1] https://docs.pytest.org/en/latest/changelog.html#pytest-7-2-0-2022-10-23
[2] https://github.com/pytest-dev/pytest/pull/9741

Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
---
I can't be bother with sending a patch changing toml to tomli for
2022.11 - it's going EOL in two months anyway, and apparently nobody
noticed...
---
 package/python-pytest/Config.in | 1 -
 1 file changed, 1 deletion(-)

Comments

Ryan Barnett Feb. 4, 2023, 7:54 p.m. UTC | #1
On Thu, Feb 2, 2023 at 9:28 AM Arnout Vandecappelle <arnout@mind.be> wrote:
>
> Since version 7.2 [1], with Python 3.11+ pytest no longer uses tomli to
> parse pyproject.toml but instead uses tomllib which is part of Python
> itself [2]. Note that toml was replaced with tomli in version 7.0, so
> the dependency was anyway incorrect.
>
> Note that tomllib is unconditionally installed as part of Python 3.11,
> there is no PYTHON3_LIBTOML option or anything like that that needs to
> be selected.
>
> [1] https://docs.pytest.org/en/latest/changelog.html#pytest-7-2-0-2022-10-23
> [2] https://github.com/pytest-dev/pytest/pull/9741
>
> Signed-off-by: Arnout Vandecappelle <arnout@mind.be>

Reviewed-by: Ryan Barnett <ryanbarnett3@gmail.com>

> ---
> I can't be bother with sending a patch changing toml to tomli for
> 2022.11 - it's going EOL in two months anyway, and apparently nobody
> noticed...
> ---
>  package/python-pytest/Config.in | 1 -
>  1 file changed, 1 deletion(-)
>
> diff --git a/package/python-pytest/Config.in b/package/python-pytest/Config.in
> index c3956c76d2..9bbc9ea2d2 100644
> --- a/package/python-pytest/Config.in
> +++ b/package/python-pytest/Config.in
> @@ -5,7 +5,6 @@ config BR2_PACKAGE_PYTHON_PYTEST
>         select BR2_PACKAGE_PYTHON_PACKAGING # runtime
>         select BR2_PACKAGE_PYTHON_PLUGGY # runtime
>         select BR2_PACKAGE_PYTHON_PY # runtime
> -       select BR2_PACKAGE_PYTHON_TOML # runtime
>         select BR2_PACKAGE_PYTHON3_PYEXPAT # runtime
>         help
>           pytest is a framework that makes building simple and scalable
> --
> 2.39.1
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/python-pytest/Config.in b/package/python-pytest/Config.in
index c3956c76d2..9bbc9ea2d2 100644
--- a/package/python-pytest/Config.in
+++ b/package/python-pytest/Config.in
@@ -5,7 +5,6 @@  config BR2_PACKAGE_PYTHON_PYTEST
 	select BR2_PACKAGE_PYTHON_PACKAGING # runtime
 	select BR2_PACKAGE_PYTHON_PLUGGY # runtime
 	select BR2_PACKAGE_PYTHON_PY # runtime
-	select BR2_PACKAGE_PYTHON_TOML # runtime
 	select BR2_PACKAGE_PYTHON3_PYEXPAT # runtime
 	help
 	  pytest is a framework that makes building simple and scalable