diff mbox series

[3/3] package/postgresql: add lz4 and zstd support

Message ID 20230124054748.13980-3-fido_max@inbox.ru
State Changes Requested
Headers show
Series [1/3] package/postgresql: bump version to 15.1 | expand

Commit Message

Maxim Kochetkov Jan. 24, 2023, 5:47 a.m. UTC
PostgreSQL has optional compression support (LZ4 and Zstandard).
So enable it if libraries are available.

Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
---
 package/postgresql/postgresql.mk | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Thomas Petazzoni Jan. 28, 2023, 8:04 p.m. UTC | #1
On Tue, 24 Jan 2023 08:47:48 +0300
Maxim Kochetkov <fido_max@inbox.ru> wrote:

> PostgreSQL has optional compression support (LZ4 and Zstandard).
> So enable it if libraries are available.
> 
> Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
> ---
>  package/postgresql/postgresql.mk | 10 ++++++++++
>  1 file changed, 10 insertions(+)
> 
> diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
> index 5313e03b12..1f787231f8 100644
> --- a/package/postgresql/postgresql.mk
> +++ b/package/postgresql/postgresql.mk
> @@ -58,6 +58,16 @@ else
>  POSTGRESQL_CONF_OPTS += --without-zlib
>  endif
>  
> +ifeq ($(BR2_PACKAGE_ZSTD),y)
> +POSTGRESQL_DEPENDENCIES += zstd
> +POSTGRESQL_CONF_OPTS += --with-zstd

Could add an explicit else clause here to pass --without-zstd ?

> +endif
> +
> +ifeq ($(BR2_PACKAGE_LZ4),y)
> +POSTGRESQL_DEPENDENCIES += lz4
> +POSTGRESQL_CONF_OPTS += --with-lz4

Same here ?

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
index 5313e03b12..1f787231f8 100644
--- a/package/postgresql/postgresql.mk
+++ b/package/postgresql/postgresql.mk
@@ -58,6 +58,16 @@  else
 POSTGRESQL_CONF_OPTS += --without-zlib
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+POSTGRESQL_DEPENDENCIES += zstd
+POSTGRESQL_CONF_OPTS += --with-zstd
+endif
+
+ifeq ($(BR2_PACKAGE_LZ4),y)
+POSTGRESQL_DEPENDENCIES += lz4
+POSTGRESQL_CONF_OPTS += --with-lz4
+endif
+
 ifeq ($(BR2_PACKAGE_TZDATA),y)
 POSTGRESQL_DEPENDENCIES += tzdata
 POSTGRESQL_CONF_OPTS += --with-system-tzdata=/usr/share/zoneinfo