diff mbox series

[1/1] package/ipmitool: fix broken IANA PEN registry URL

Message ID 20230115191751.3884627-1-vfazio@xes-inc.com
State Accepted
Headers show
Series [1/1] package/ipmitool: fix broken IANA PEN registry URL | expand

Commit Message

Vincent Fazio Jan. 15, 2023, 7:17 p.m. UTC
From: Vincent Fazio <vfazio@gmail.com>

Backport the upstream fix for the IANA Private Enterprise Numbers
registry URL so the correct file gets downloaded and installed.

Signed-off-by: Vincent Fazio <vfazio@gmail.com>
Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>
---
 .../0002-Fix-enterprise-numbers-URL.patch     | 36 +++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 package/ipmitool/0002-Fix-enterprise-numbers-URL.patch

Comments

Yann E. MORIN Jan. 16, 2023, 9:26 p.m. UTC | #1
Vincent, All,

On 2023-01-15 13:17 -0600, Vincent Fazio spake thusly:
> From: Vincent Fazio <vfazio@gmail.com>
> 
> Backport the upstream fix for the IANA Private Enterprise Numbers
> registry URL so the correct file gets downloaded and installed.
> 
> Signed-off-by: Vincent Fazio <vfazio@gmail.com>
> Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  .../0002-Fix-enterprise-numbers-URL.patch     | 36 +++++++++++++++++++
>  1 file changed, 36 insertions(+)
>  create mode 100644 package/ipmitool/0002-Fix-enterprise-numbers-URL.patch
> 
> diff --git a/package/ipmitool/0002-Fix-enterprise-numbers-URL.patch b/package/ipmitool/0002-Fix-enterprise-numbers-URL.patch
> new file mode 100644
> index 0000000000..07cdbd4527
> --- /dev/null
> +++ b/package/ipmitool/0002-Fix-enterprise-numbers-URL.patch
> @@ -0,0 +1,36 @@
> +From 1edb0e27e44196d1ebe449aba0b9be22d376bcb6 Mon Sep 17 00:00:00 2001
> +From: Alexander Amelkin <alexander@amelkin.msk.ru>
> +Date: Tue, 22 Nov 2022 13:55:33 +0300
> +Subject: [PATCH] Fix enterprise-numbers URL
> +
> +IANA has changed their URL scheme, and the content at the old URL for
> +enterprise-numbers switched from text/plain to text/html.
> +
> +Fix Makefile.am to use the new URL
> +
> +Resolves ipmitool/ipmitool#377
> +
> +Signed-off-by: Alexander Amelkin <alexander@amelkin.msk.ru>
> +
> +[vfazio: backport from upstream 1edb0e27e44196d1ebe449aba0b9be22d376bcb6]
> +Signed-off-by: Vincent Fazio <vfazio@gmail.com>
> +---
> + Makefile.am | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/Makefile.am b/Makefile.am
> +index ce3267f..3182a52 100644
> +--- a/Makefile.am
> ++++ b/Makefile.am
> +@@ -41,7 +41,7 @@ MAINTAINERCLEANFILES = Makefile.in aclocal.m4 configure configure-stamp \
> + 	$(distdir).tar.gz $(distdir).tar.bz2
> + 
> + SUBDIRS = lib src include doc contrib control
> +-IANA_PEN = http://www.iana.org/assignments/enterprise-numbers
> ++IANA_PEN = http://www.iana.org/assignments/enterprise-numbers.txt
> + 
> + dist-hook:
> + 	cp control/ipmitool.spec $(distdir)
> +-- 
> +2.25.1
> +
> -- 
> 2.25.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Jan. 29, 2023, 9:01 p.m. UTC | #2
>>>>> "Vincent" == Vincent Fazio <vfazio@xes-inc.com> writes:

 > From: Vincent Fazio <vfazio@gmail.com>
 > Backport the upstream fix for the IANA Private Enterprise Numbers
 > registry URL so the correct file gets downloaded and installed.

 > Signed-off-by: Vincent Fazio <vfazio@gmail.com>
 > Signed-off-by: Vincent Fazio <vfazio@xes-inc.com>

Committed to 2022.11.x, thanks.
diff mbox series

Patch

diff --git a/package/ipmitool/0002-Fix-enterprise-numbers-URL.patch b/package/ipmitool/0002-Fix-enterprise-numbers-URL.patch
new file mode 100644
index 0000000000..07cdbd4527
--- /dev/null
+++ b/package/ipmitool/0002-Fix-enterprise-numbers-URL.patch
@@ -0,0 +1,36 @@ 
+From 1edb0e27e44196d1ebe449aba0b9be22d376bcb6 Mon Sep 17 00:00:00 2001
+From: Alexander Amelkin <alexander@amelkin.msk.ru>
+Date: Tue, 22 Nov 2022 13:55:33 +0300
+Subject: [PATCH] Fix enterprise-numbers URL
+
+IANA has changed their URL scheme, and the content at the old URL for
+enterprise-numbers switched from text/plain to text/html.
+
+Fix Makefile.am to use the new URL
+
+Resolves ipmitool/ipmitool#377
+
+Signed-off-by: Alexander Amelkin <alexander@amelkin.msk.ru>
+
+[vfazio: backport from upstream 1edb0e27e44196d1ebe449aba0b9be22d376bcb6]
+Signed-off-by: Vincent Fazio <vfazio@gmail.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index ce3267f..3182a52 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -41,7 +41,7 @@ MAINTAINERCLEANFILES = Makefile.in aclocal.m4 configure configure-stamp \
+ 	$(distdir).tar.gz $(distdir).tar.bz2
+ 
+ SUBDIRS = lib src include doc contrib control
+-IANA_PEN = http://www.iana.org/assignments/enterprise-numbers
++IANA_PEN = http://www.iana.org/assignments/enterprise-numbers.txt
+ 
+ dist-hook:
+ 	cp control/ipmitool.spec $(distdir)
+-- 
+2.25.1
+