diff mbox series

[7/7] package/systemd: create the /boot directory

Message ID 20230115125253.280257-8-nolange79@gmail.com
State Accepted
Headers show
Series Extent options for read-only /var handling | expand

Commit Message

Norbert Lange Jan. 15, 2023, 12:52 p.m. UTC
The gpt-auto-generator can generate the boot.mount unit, and
report an error if this directory cant be created (read-only fs).

Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
 package/systemd/systemd.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle Oct. 10, 2023, 8:36 p.m. UTC | #1
On 15/01/2023 13:52, Norbert Lange wrote:
> The gpt-auto-generator can generate the boot.mount unit, and
> report an error if this directory cant be created (read-only fs).
> 
> Signed-off-by: Norbert Lange <nolange79@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/systemd/systemd.mk | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index 420197005c..0074fa8791 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -603,6 +603,7 @@ define SYSTEMD_INSTALL_IMAGES_CMDS
>   endef
>   
>   define SYSTEMD_PERMISSIONS
> +	/boot d 700 0 0 - - - - -
>   	/var/spool d 755 0 0 - - - - -
>   	/var/lib d 755 0 0 - - - - -
>   	/var/lib/private d 700 0 0 - - - - -
diff mbox series

Patch

diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 420197005c..0074fa8791 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -603,6 +603,7 @@  define SYSTEMD_INSTALL_IMAGES_CMDS
 endef
 
 define SYSTEMD_PERMISSIONS
+	/boot d 700 0 0 - - - - -
 	/var/spool d 755 0 0 - - - - -
 	/var/lib d 755 0 0 - - - - -
 	/var/lib/private d 700 0 0 - - - - -