diff mbox series

[1/1] package/bpftool: bump to version 7.1.0

Message ID 20230110015658.3249549-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/bpftool: bump to version 7.1.0 | expand

Commit Message

James Hilliard Jan. 10, 2023, 1:56 a.m. UTC
Use install-bin for installation instead of install as we don't
want bash-completion files to be installed.

Set empty host installation prefix so that we install to:
$(HOST_DIR)/sbin/bpftool

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/bpftool/bpftool.hash | 2 +-
 package/bpftool/bpftool.mk   | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Thomas Petazzoni Jan. 14, 2023, 9:20 p.m. UTC | #1
On Mon,  9 Jan 2023 18:56:58 -0700
James Hilliard <james.hilliard1@gmail.com> wrote:

> Use install-bin for installation instead of install as we don't
> want bash-completion files to be installed.
> 
> Set empty host installation prefix so that we install to:
> $(HOST_DIR)/sbin/bpftool
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/bpftool/bpftool.hash | 2 +-
>  package/bpftool/bpftool.mk   | 6 +++---
>  2 files changed, 4 insertions(+), 4 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/bpftool/bpftool.hash b/package/bpftool/bpftool.hash
index 92b9359fe3..cfd3c54515 100644
--- a/package/bpftool/bpftool.hash
+++ b/package/bpftool/bpftool.hash
@@ -1,5 +1,5 @@ 
 # Locally calculated
-sha256  465a50fea4afbacd326f2209d81ae0dcff637fbb2c9d1a315e94f79a788ce960  bpftool-v7.0.0-br1.tar.gz
+sha256  35ff149cab4a3ab209b0c04cab2707243ab7ee753de5f4b5678296c975cf7fe0  bpftool-v7.1.0-br1.tar.gz
 sha256  7c588754d5e81e92e2a12e47cf78949d485c9c22b4850f12d21b3835c85947d1  LICENSE
 sha256  6313108c23efffa36948f8b2cff1560a5935373b527b0e1a837cc77e6ed1bacd  LICENSE.BSD-2-Clause
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  LICENSE.GPL-2.0
diff --git a/package/bpftool/bpftool.mk b/package/bpftool/bpftool.mk
index 3b27698130..cd68d89799 100644
--- a/package/bpftool/bpftool.mk
+++ b/package/bpftool/bpftool.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-BPFTOOL_VERSION = v7.0.0
+BPFTOOL_VERSION = v7.1.0
 BPFTOOL_SITE = https://github.com/libbpf/bpftool
 BPFTOOL_SITE_METHOD = git
 BPFTOOL_GIT_SUBMODULES = YES
@@ -33,12 +33,12 @@  endef
 
 define BPFTOOL_INSTALL_TARGET_CMDS
 	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) \
-		-C $(@D)/src install DESTDIR="$(TARGET_DIR)" prefix=/usr
+		-C $(@D)/src install-bin DESTDIR="$(TARGET_DIR)" prefix=/usr
 endef
 
 define HOST_BPFTOOL_INSTALL_CMDS
 	$(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) \
-		-C $(@D)/src install DESTDIR="$(HOST_DIR)" prefix=/usr
+		-C $(@D)/src install-bin DESTDIR="$(HOST_DIR)" prefix=
 endef
 
 $(eval $(generic-package))