diff mbox series

[2/5] package/python-webargs: new package

Message ID 20230105130000.682525-3-martin@geanix.com
State Accepted
Headers show
Series python flask-smorest packages | expand

Commit Message

Martin Hundebøll Jan. 5, 2023, 12:59 p.m. UTC
webargs is a dependency of to-be-added python-flask-smorest.

Signed-off-by: Martin Hundebøll <martin@geanix.com>
---
 package/Config.in                          |  1 +
 package/python-webargs/Config.in           | 11 +++++++++++
 package/python-webargs/python-webargs.hash |  5 +++++
 package/python-webargs/python-webargs.mk   | 14 ++++++++++++++
 4 files changed, 31 insertions(+)
 create mode 100644 package/python-webargs/Config.in
 create mode 100644 package/python-webargs/python-webargs.hash
 create mode 100644 package/python-webargs/python-webargs.mk
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index cb5af9a7e2..e05f4271e3 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1326,6 +1326,7 @@  menu "External python modules"
 	source "package/python-wcwidth/Config.in"
 	source "package/python-weasyprint/Config.in"
 	source "package/python-web2py/Config.in"
+	source "package/python-webargs/Config.in"
 	source "package/python-webencodings/Config.in"
 	source "package/python-webob/Config.in"
 	source "package/python-webpy/Config.in"
diff --git a/package/python-webargs/Config.in b/package/python-webargs/Config.in
new file mode 100644
index 0000000000..f2332d3b70
--- /dev/null
+++ b/package/python-webargs/Config.in
@@ -0,0 +1,11 @@ 
+config BR2_PACKAGE_PYTHON_WEBARGS
+	bool "python-webargs"
+	select BR2_PACKAGE_PYTHON_MARSHMALLOW # runtime
+	select BR2_PACKAGE_PYTHON_PACKAGING # runtime
+	help
+	  Declarative parsing and validation of HTTP request objects,
+	  with built-in support for popular web frameworks, including
+	  Flask, Django, Bottle, Tornado, Pyramid, Falcon, and
+	  aiohttp.
+
+	  https://github.com/marshmallow-code/webargs
diff --git a/package/python-webargs/python-webargs.hash b/package/python-webargs/python-webargs.hash
new file mode 100644
index 0000000000..619b584807
--- /dev/null
+++ b/package/python-webargs/python-webargs.hash
@@ -0,0 +1,5 @@ 
+# md5, sha256 from https://pypi.org/pypi/webargs/json
+md5   9fff29294a5db748eca791da2b93e370  webargs-8.2.0.tar.gz
+sha256  99d68940c452e07726485a15fef43f12f8ae6c0c5b391bcba76065d4527fb85d  webargs-8.2.0.tar.gz
+# Locally computed sha256 checksums
+sha256  5973e5dcc20b65e4eb4b4acdf273bb78a18522914ab626f496f1b070f7e6294d  LICENSE
diff --git a/package/python-webargs/python-webargs.mk b/package/python-webargs/python-webargs.mk
new file mode 100644
index 0000000000..e048d8a4ac
--- /dev/null
+++ b/package/python-webargs/python-webargs.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-webargs
+#
+################################################################################
+
+PYTHON_WEBARGS_VERSION = 8.2.0
+PYTHON_WEBARGS_SOURCE = webargs-$(PYTHON_WEBARGS_VERSION).tar.gz
+PYTHON_WEBARGS_SITE = https://files.pythonhosted.org/packages/4b/7d/fece8e6547b3edde8953b1c84a63da02e1a88efcb9d7d485e4d1b25d9c47
+PYTHON_WEBARGS_SETUP_TYPE = setuptools
+PYTHON_WEBARGS_LICENSE = MIT
+PYTHON_WEBARGS_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))