diff mbox series

[1/1] package/crun: add libgcrypt optional dependency

Message ID 20221230180843.521147-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/crun: add libgcrypt optional dependency | expand

Commit Message

Fabrice Fontaine Dec. 30, 2022, 6:08 p.m. UTC
libgcrypt is an optional dependency which is enabled by default since
version 1.7 and
https://github.com/containers/crun/commit/dd310aaf5aee336d0f6236c1c2add7b7cb030482

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/crun/crun.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Christian Stewart Jan. 8, 2023, 2:38 a.m. UTC | #1
Hi Fabrice,

On Fri, Dec 30, 2022 at 10:08 AM Fabrice Fontaine
<fontaine.fabrice@gmail.com> wrote:
>
> libgcrypt is an optional dependency which is enabled by default since
> version 1.7 and
> https://github.com/containers/crun/commit/dd310aaf5aee336d0f6236c1c2add7b7cb030482
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/crun/crun.mk | 4 ++++
>  1 file changed, 4 insertions(+)
>

Reviewed-by: Christian Stewart <christian@paral.in>

Thanks!
Yann E. MORIN Jan. 8, 2023, 3:58 p.m. UTC | #2
Fabrice, All,

On 2022-12-30 19:08 +0100, Fabrice Fontaine spake thusly:
> libgcrypt is an optional dependency which is enabled by default since
> version 1.7 and
> https://github.com/containers/crun/commit/dd310aaf5aee336d0f6236c1c2add7b7cb030482
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, after extending the commit log to state that there
are no associated --enable/disable flags, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/crun/crun.mk | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/package/crun/crun.mk b/package/crun/crun.mk
> index 8c9993993c..fd8bfb0981 100644
> --- a/package/crun/crun.mk
> +++ b/package/crun/crun.mk
> @@ -26,6 +26,10 @@ else
>  CRUN_CONF_OPTS += --disable-caps
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
> +CRUN_DEPENDENCIES += libgcrypt
> +endif
> +
>  ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
>  CRUN_DEPENDENCIES += libseccomp
>  CRUN_CONF_OPTS += --enable-seccomp
> -- 
> 2.35.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/crun/crun.mk b/package/crun/crun.mk
index 8c9993993c..fd8bfb0981 100644
--- a/package/crun/crun.mk
+++ b/package/crun/crun.mk
@@ -26,6 +26,10 @@  else
 CRUN_CONF_OPTS += --disable-caps
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+CRUN_DEPENDENCIES += libgcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
 CRUN_DEPENDENCIES += libseccomp
 CRUN_CONF_OPTS += --enable-seccomp