diff mbox series

[v6,1/3] package/rtl8723ds-bt: new package

Message ID 20221216080433.1997432-1-angelo@amarulasolutions.com
State Accepted
Headers show
Series [v6,1/3] package/rtl8723ds-bt: new package | expand

Commit Message

Angelo Compagnucci Dec. 16, 2022, 8:04 a.m. UTC
This package install the required firmware for enabling the
Bluetooth device embedded in the RTL8723DS chip.
The driver is included in Linux main tree and can be enabled
with the BT_HCIUART_RTL symbol.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Tested-by: Indrek Kruusa <indrek.kruusa@gmail.com>
---
v6:
* Added me to developers file

 DEVELOPERS                             |  1 +
 package/Config.in                      |  1 +
 package/rtl8723ds-bt/Config.in         |  6 ++++++
 package/rtl8723ds-bt/rtl8723ds-bt.hash |  2 ++
 package/rtl8723ds-bt/rtl8723ds-bt.mk   | 17 +++++++++++++++++
 5 files changed, 27 insertions(+)
 create mode 100644 package/rtl8723ds-bt/Config.in
 create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.hash
 create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.mk

Comments

Peter Korsgaard Dec. 18, 2022, 2:52 p.m. UTC | #1
>>>>> "Angelo" == Angelo Compagnucci <angelo@amarulasolutions.com> writes:

 > This package install the required firmware for enabling the
 > Bluetooth device embedded in the RTL8723DS chip.
 > The driver is included in Linux main tree and can be enabled
 > with the BT_HCIUART_RTL symbol.

 > Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
 > Tested-by: Indrek Kruusa <indrek.kruusa@gmail.com>
 > ---
 > v6:
 > * Added me to developers file

 >  DEVELOPERS                             |  1 +
 >  package/Config.in                      |  1 +
 >  package/rtl8723ds-bt/Config.in         |  6 ++++++
 >  package/rtl8723ds-bt/rtl8723ds-bt.hash |  2 ++
 >  package/rtl8723ds-bt/rtl8723ds-bt.mk   | 17 +++++++++++++++++
 >  5 files changed, 27 insertions(+)
 >  create mode 100644 package/rtl8723ds-bt/Config.in
 >  create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.hash
 >  create mode 100644 package/rtl8723ds-bt/rtl8723ds-bt.mk

 > diff --git a/DEVELOPERS b/DEVELOPERS
 > index 3a0e3c14ab..b52a065dbc 100644
 > --- a/DEVELOPERS
 > +++ b/DEVELOPERS
 > @@ -185,6 +185,7 @@ F:	package/qt5/qt5coap/
 >  F:	package/qt5/qt5knx/
 >  F:	package/qt5/qt5mqtt/
 >  F:	package/rtl8723ds/
 > +F:	package/rtl8723ds-bt/
 >  F:	package/sam-ba/
 >  F:	package/sshguard/
 >  F:	package/sunwait/
 > diff --git a/package/Config.in b/package/Config.in
 > index 914c3584e9..999feae08a 100644
 > --- a/package/Config.in
 > +++ b/package/Config.in
 > @@ -585,6 +585,7 @@ endmenu
 >  	source "package/rtl8192eu/Config.in"
 >  	source "package/rtl8723bu/Config.in"
 >  	source "package/rtl8723ds/Config.in"
 > +	source "package/rtl8723ds-bt/Config.in"
 >  	source "package/rtl8812au-aircrack-ng/Config.in"
 >  	source "package/rtl8821au/Config.in"
 >  	source "package/sane-backends/Config.in"
 > diff --git a/package/rtl8723ds-bt/Config.in b/package/rtl8723ds-bt/Config.in
 > new file mode 100644
 > index 0000000000..0a604310c0
 > --- /dev/null
 > +++ b/package/rtl8723ds-bt/Config.in
 > @@ -0,0 +1,6 @@
 > +config BR2_PACKAGE_RTL8723DS_BT
 > +	bool "rtl8723ds-bt"
 > +	help
 > +	  rtl8723ds UART attached Bluetooth module firmware.
 > +
 > +	  https://github.com/wsyco/RTL8723DS_BT_Linux
 > diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.hash b/package/rtl8723ds-bt/rtl8723ds-bt.hash
 > new file mode 100644
 > index 0000000000..1ec4e350f9
 > --- /dev/null
 > +++ b/package/rtl8723ds-bt/rtl8723ds-bt.hash
 > @@ -0,0 +1,2 @@
 > +# Locally computed
 > +sha256  9e70a981946abeeb6437d9a27d8437cea15aa4df72f8d56ded0ae28af484d2f4  rtl8723ds-bt-14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08.tar.gz
 > diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.mk b/package/rtl8723ds-bt/rtl8723ds-bt.mk
 > new file mode 100644
 > index 0000000000..efd0a5bae9
 > --- /dev/null
 > +++ b/package/rtl8723ds-bt/rtl8723ds-bt.mk
 > @@ -0,0 +1,17 @@
 > +################################################################################
 > +#
 > +# rtl8723ds-bt
 > +#
 > +################################################################################
 > +
 > +RTL8723DS_BT_VERSION = 14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08
 > +RTL8723DS_BT_SITE = $(call github,wsyco,RTL8723DS_BT_Linux,$(RTL8723DS_BT_VERSION))
 > +RTL8723DS_BT_LICENSE = PROPRIETARY
 > +
 > +define RTL8723DS_BT_INSTALL_TARGET_CMDS
 > +	mkdir -p $(TARGET_DIR)/lib/firmware/rtl_bt/
 > +	cp $(@D)/8723D/rtl8723d_fw $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_fw.bin
 > +	cp $(@D)/8723D/rtl8723d_config $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_config.bin

We normally use install -D to install files to control the
permissions. Committed after changing that, thanks.
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 3a0e3c14ab..b52a065dbc 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -185,6 +185,7 @@  F:	package/qt5/qt5coap/
 F:	package/qt5/qt5knx/
 F:	package/qt5/qt5mqtt/
 F:	package/rtl8723ds/
+F:	package/rtl8723ds-bt/
 F:	package/sam-ba/
 F:	package/sshguard/
 F:	package/sunwait/
diff --git a/package/Config.in b/package/Config.in
index 914c3584e9..999feae08a 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -585,6 +585,7 @@  endmenu
 	source "package/rtl8192eu/Config.in"
 	source "package/rtl8723bu/Config.in"
 	source "package/rtl8723ds/Config.in"
+	source "package/rtl8723ds-bt/Config.in"
 	source "package/rtl8812au-aircrack-ng/Config.in"
 	source "package/rtl8821au/Config.in"
 	source "package/sane-backends/Config.in"
diff --git a/package/rtl8723ds-bt/Config.in b/package/rtl8723ds-bt/Config.in
new file mode 100644
index 0000000000..0a604310c0
--- /dev/null
+++ b/package/rtl8723ds-bt/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_RTL8723DS_BT
+	bool "rtl8723ds-bt"
+	help
+	  rtl8723ds UART attached Bluetooth module firmware.
+
+	  https://github.com/wsyco/RTL8723DS_BT_Linux
diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.hash b/package/rtl8723ds-bt/rtl8723ds-bt.hash
new file mode 100644
index 0000000000..1ec4e350f9
--- /dev/null
+++ b/package/rtl8723ds-bt/rtl8723ds-bt.hash
@@ -0,0 +1,2 @@ 
+# Locally computed
+sha256  9e70a981946abeeb6437d9a27d8437cea15aa4df72f8d56ded0ae28af484d2f4  rtl8723ds-bt-14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08.tar.gz
diff --git a/package/rtl8723ds-bt/rtl8723ds-bt.mk b/package/rtl8723ds-bt/rtl8723ds-bt.mk
new file mode 100644
index 0000000000..efd0a5bae9
--- /dev/null
+++ b/package/rtl8723ds-bt/rtl8723ds-bt.mk
@@ -0,0 +1,17 @@ 
+################################################################################
+#
+# rtl8723ds-bt
+#
+################################################################################
+
+RTL8723DS_BT_VERSION = 14cedf3a9fec1aa8c500fa52f3e3acc433cbcf08
+RTL8723DS_BT_SITE = $(call github,wsyco,RTL8723DS_BT_Linux,$(RTL8723DS_BT_VERSION))
+RTL8723DS_BT_LICENSE = PROPRIETARY
+
+define RTL8723DS_BT_INSTALL_TARGET_CMDS
+	mkdir -p $(TARGET_DIR)/lib/firmware/rtl_bt/
+	cp $(@D)/8723D/rtl8723d_fw $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_fw.bin
+	cp $(@D)/8723D/rtl8723d_config $(TARGET_DIR)/lib/firmware/rtl_bt/rtl8723ds_config.bin
+endef
+
+$(eval $(generic-package))