diff mbox series

[4/4] boot/sun20i-d1-spl: drop package

Message ID 20221212071747.2829022-4-peter@korsgaard.com
State Accepted
Headers show
Series [1/4] nezha_defconfig: bump u-boot to current top of d1-wip | expand

Commit Message

Peter Korsgaard Dec. 12, 2022, 7:17 a.m. UTC
U-Boot has now gained SPL support for D1, so this temporary bootloader is no
longer supported.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 Config.in.legacy                      |  7 +++++++
 DEVELOPERS                            |  1 -
 boot/Config.in                        |  1 -
 boot/sun20i-d1-spl/Config.in          |  8 --------
 boot/sun20i-d1-spl/sun20i-d1-spl.hash |  2 --
 boot/sun20i-d1-spl/sun20i-d1-spl.mk   | 23 -----------------------
 6 files changed, 7 insertions(+), 35 deletions(-)
 delete mode 100644 boot/sun20i-d1-spl/Config.in
 delete mode 100644 boot/sun20i-d1-spl/sun20i-d1-spl.hash
 delete mode 100644 boot/sun20i-d1-spl/sun20i-d1-spl.mk

Comments

Peter Korsgaard Dec. 13, 2022, 8:21 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > U-Boot has now gained SPL support for D1, so this temporary bootloader is no
 > longer supported.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index cb0176a31c..d513bfea73 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,13 @@  endif
 
 comment "Legacy options removed in 2023.02"
 
+config BR2_TARGET_SUN20I_D1_SPL
+	bool "sun20-d1-spl removed"
+	select BR2_LEGACY
+	help
+	  U-Boot has gained SPL support for D1, so this temporary
+	  bootloader is no longer supported.
+
 config BR2_KERNEL_HEADERS_5_19
 	bool "kernel headers version 5.19.x are no longer supported"
 	select BR2_LEGACY
diff --git a/DEVELOPERS b/DEVELOPERS
index 04047d43da..2dc2d3820c 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -2300,7 +2300,6 @@  F:	board/pandaboard/
 F:	board/roseapplepi/
 F:	board/visionfive/
 F:	boot/shim/
-F:	boot/sun20i-d1-spl/
 F:	configs/avenger96_defconfig
 F:	configs/beagleboneai_defconfig
 F:	configs/lafrite_defconfig
diff --git a/boot/Config.in b/boot/Config.in
index 40472ae07d..ff98a49796 100644
--- a/boot/Config.in
+++ b/boot/Config.in
@@ -20,7 +20,6 @@  source "boot/optee-os/Config.in"
 source "boot/opensbi/Config.in"
 source "boot/s500-bootloader/Config.in"
 source "boot/shim/Config.in"
-source "boot/sun20i-d1-spl/Config.in"
 source "boot/syslinux/Config.in"
 source "boot/uboot/Config.in"
 source "boot/vexpress-firmware/Config.in"
diff --git a/boot/sun20i-d1-spl/Config.in b/boot/sun20i-d1-spl/Config.in
deleted file mode 100644
index 9d94d87b1c..0000000000
--- a/boot/sun20i-d1-spl/Config.in
+++ /dev/null
@@ -1,8 +0,0 @@ 
-config BR2_TARGET_SUN20I_D1_SPL
-	bool "sun20-d1-spl"
-	depends on BR2_RISCV_64
-	help
-	  Allwinner D1 boot0 code with modifications to use as U-Boot
-	  SPL.
-
-	  https://github.com/smaeul/sun20i_d1_spl
diff --git a/boot/sun20i-d1-spl/sun20i-d1-spl.hash b/boot/sun20i-d1-spl/sun20i-d1-spl.hash
deleted file mode 100644
index 11d17a9a16..0000000000
--- a/boot/sun20i-d1-spl/sun20i-d1-spl.hash
+++ /dev/null
@@ -1,2 +0,0 @@ 
-# Locally computed
-sha256  08e2d0574e58c99734cd1d9ea89b86464242bf2db4f6769b23803bf9dcdac3c4  sun20i-d1-spl-882671fcf53137aaafc3a94fa32e682cb7b921f1.tar.gz
diff --git a/boot/sun20i-d1-spl/sun20i-d1-spl.mk b/boot/sun20i-d1-spl/sun20i-d1-spl.mk
deleted file mode 100644
index 6bcea0fa96..0000000000
--- a/boot/sun20i-d1-spl/sun20i-d1-spl.mk
+++ /dev/null
@@ -1,23 +0,0 @@ 
-################################################################################
-#
-# sun20i-d1-spl
-#
-################################################################################
-
-# Commit on the 'mainline' branch
-SUN20I_D1_SPL_VERSION = 882671fcf53137aaafc3a94fa32e682cb7b921f1
-SUN20I_D1_SPL_SITE = $(call github,smaeul,sun20i_d1_spl,$(SUN20I_D1_SPL_VERSION))
-SUN20I_D1_SPL_INSTALL_TARGET = NO
-SUN20I_D1_SPL_INSTALL_IMAGES = YES
-SUN20I_D1_SPL_LICENSE = GPL-2.0+
-
-define SUN20I_D1_SPL_BUILD_CMDS
-	$(MAKE) -C $(@D) CROSS_COMPILE="$(TARGET_CROSS)" p=sun20iw1p1 mmc
-endef
-
-define SUN20I_D1_SPL_INSTALL_IMAGES_CMDS
-	$(INSTALL) -D -m 0644 $(@D)/nboot/boot0_sdcard_sun20iw1p1.bin \
-		$(BINARIES_DIR)/boot0_sdcard_sun20iw1p1.bin
-endef
-
-$(eval $(generic-package))