diff mbox series

package/pkg-meson.mk: add 'setup' to meson command in config step

Message ID 20221208200339.12108-1-heiko.thiery@gmail.com
State Accepted
Headers show
Series package/pkg-meson.mk: add 'setup' to meson command in config step | expand

Commit Message

Heiko Thiery Dec. 8, 2022, 8:03 p.m. UTC
When building/configure meson packages the following warning is displayed:
WARNING: Running the setup command as meson [options] instead of meson setup [options] is ambiguous and deprecated.

This warning was introduced in meson release 0.64.0 [1].

Follow the advise and add the 'setup' argument to the meson command.

[1] https://github.com/mesonbuild/meson/commit/3c7ab542c0c4770241eae149b0d4cd8de329aee0

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---
 package/pkg-meson.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Dec. 11, 2022, 3:38 p.m. UTC | #1
Heiko, All,

On 2022-12-08 21:03 +0100, Heiko Thiery spake thusly:
> When building/configure meson packages the following warning is displayed:
> WARNING: Running the setup command as meson [options] instead of meson setup [options] is ambiguous and deprecated.
> 
> This warning was introduced in meson release 0.64.0 [1].
> 
> Follow the advise and add the 'setup' argument to the meson command.

The manual is very confusing:

    https://mesonbuild.com/Commands.html#setup

    Deprecated since 0.64.0: This is the default Meson command (invoked
    if there was no COMMAND supplied). However, supplying the command is
    necessary to avoid clashes with future added commands, so "setup"
    should be used explicitly.

On first read, I understand that 'setup' is deprecated since 0.64.0. But
then, re-reading that, it can be understood that what is deprecated, is
to treat it as the default command if none is supplied. Subtle...

Applied to master, after tweaking the commit log to also refere to the
manual, thanks.

Regards,
Yann E. MORIN.

> [1] https://github.com/mesonbuild/meson/commit/3c7ab542c0c4770241eae149b0d4cd8de329aee0
> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> ---
>  package/pkg-meson.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/pkg-meson.mk b/package/pkg-meson.mk
> index d675f7f733..4aa6e44afa 100644
> --- a/package/pkg-meson.mk
> +++ b/package/pkg-meson.mk
> @@ -149,7 +149,7 @@ define $(2)_CONFIGURE_CMDS
>  	CC_FOR_BUILD="$$(HOSTCC)" \
>  	CXX_FOR_BUILD="$$(HOSTCXX)" \
>  	$$($$(PKG)_CONF_ENV) \
> -	$$(MESON) \
> +	$$(MESON) setup \
>  		--prefix=/usr \
>  		--libdir=lib \
>  		--default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
> @@ -169,7 +169,7 @@ define $(2)_CONFIGURE_CMDS
>  	rm -rf $$($$(PKG)_SRCDIR)/build
>  	mkdir -p $$($$(PKG)_SRCDIR)/build
>  	$$(HOST_CONFIGURE_OPTS) \
> -	$$($$(PKG)_CONF_ENV) $$(MESON) \
> +	$$($$(PKG)_CONF_ENV) $$(MESON) setup \
>  		--prefix=$$(HOST_DIR) \
>  		--libdir=lib \
>  		--sysconfdir=$$(HOST_DIR)/etc \
> -- 
> 2.20.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/pkg-meson.mk b/package/pkg-meson.mk
index d675f7f733..4aa6e44afa 100644
--- a/package/pkg-meson.mk
+++ b/package/pkg-meson.mk
@@ -149,7 +149,7 @@  define $(2)_CONFIGURE_CMDS
 	CC_FOR_BUILD="$$(HOSTCC)" \
 	CXX_FOR_BUILD="$$(HOSTCXX)" \
 	$$($$(PKG)_CONF_ENV) \
-	$$(MESON) \
+	$$(MESON) setup \
 		--prefix=/usr \
 		--libdir=lib \
 		--default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
@@ -169,7 +169,7 @@  define $(2)_CONFIGURE_CMDS
 	rm -rf $$($$(PKG)_SRCDIR)/build
 	mkdir -p $$($$(PKG)_SRCDIR)/build
 	$$(HOST_CONFIGURE_OPTS) \
-	$$($$(PKG)_CONF_ENV) $$(MESON) \
+	$$($$(PKG)_CONF_ENV) $$(MESON) setup \
 		--prefix=$$(HOST_DIR) \
 		--libdir=lib \
 		--sysconfdir=$$(HOST_DIR)/etc \