diff mbox series

boot/uboot: add BR2_TARGET_UBOOT_NEEDS_VIM option

Message ID 20221108144308.1795042-1-jerry.kooyman@entrust.com
State Changes Requested
Headers show
Series boot/uboot: add BR2_TARGET_UBOOT_NEEDS_VIM option | expand

Commit Message

Jerry Kooyman Nov. 8, 2022, 2:43 p.m. UTC
From: Jerry Kooyman <jerry.kooyman@entrust.com>

A host dependency to vim is required if the
U-Boot board configuration has CONFIG_USE_DEFAULT_ENV_FILE enabled. So
introduce a new BR U-Boot config option BR2_TARGET_UBOOT_NEEDS_VIM
to solve this problem.
---
 boot/uboot/Config.in | 8 ++++++++
 boot/uboot/uboot.mk  | 4 ++++
 2 files changed, 12 insertions(+)

Comments

Thomas Petazzoni Nov. 22, 2022, 10:12 p.m. UTC | #1
Hello Jerry,

On Tue, 8 Nov 2022 08:43:07 -0600
Jerry Kooyman via buildroot <buildroot@buildroot.org> wrote:

> From: Jerry Kooyman <jerry.kooyman@entrust.com>
> 
> A host dependency to vim is required if the
> U-Boot board configuration has CONFIG_USE_DEFAULT_ENV_FILE enabled. So
> introduce a new BR U-Boot config option BR2_TARGET_UBOOT_NEEDS_VIM
> to solve this problem.

Thanks for the patch! First of all, in order for your patch to be
merged, we need it to carry a Signed-off-by line with your name and
email, like this:

Signed-off-by: Your Name <your.email@domain.com>

as the last line of your commit log.

> +config BR2_TARGET_UBOOT_NEEDS_VIM
> +	bool "U-Boot needs vim"

I am wondering if we shouldn't make this:

config BR2_TARGET_UBOOT_NEEDS_XXD
	bool "U-Boot needs xxd"

because really what U-Boot needs is xxd... which happens to be provided
by host-vim.

Indeed, if I see U-Boot failing to build because xxd is missing, if I'm
not familiar with this, I will have hard time realizing that what is
needed is this BR2_TARGET_UBOOT_NEEDS_VIM option.

In order to avoid building host-vim, which needs host-ncurses, we could
also package a standalone version of xxd, such as
https://github.com/ckormanyos/xxd. But that clearly isn't a
requirement, I will be happy to take a modified patch from you that has
the option renamed to BR2_TARGET_UBOOT_NEEDS_XXD.

Thanks a lot!

Thomas
diff mbox series

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 557472b58b..b0f546000e 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -198,6 +198,14 @@  config BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX
 	  This is typically the case when the board configuration
 	  has CONFIG_TOOLS_MKEFICAPSULE enabled.
 
+config BR2_TARGET_UBOOT_NEEDS_VIM
+	bool "U-Boot needs vim"
+	help
+	  Select this option if your U-Boot board configuration
+	  requires vim to be available on the host. This is
+	  typically the case when the board configuration has
+	  CONFIG_USE_DEFAULT_ENV_FILE enabled.
+
 config BR2_TARGET_UBOOT_NEEDS_ATF_BL31
 	bool "U-Boot needs ATF BL31"
 	depends on BR2_TARGET_ARM_TRUSTED_FIRMWARE
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 0439ec5e4b..a64d3a2c2c 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -235,6 +235,10 @@  ifeq ($(BR2_TARGET_UBOOT_NEEDS_UTIL_LINUX),y)
 UBOOT_DEPENDENCIES += host-util-linux
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_VIM),y)
+UBOOT_DEPENDENCIES += host-vim
+endif
+
 # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
 # legal-info finds it
 define UBOOT_COPY_OLD_LICENSE_FILE